Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003728Doomseeker[All Projects] Bugpublic2020-01-15 23:402020-01-30 12:58
Reporterauratoostronk 
Assigned ToZalewa 
PriorityhighSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS Version10
Product Version1.3 
Target Version1.3.1Fixed in Version1.3.1 
Summary0003728: Doomseeker randomly crashes when loading the server list
DescriptionEvery time I load up doomseeker, it will load servers until it just randomly closes itself. No crash pop-up, no error window, it just closes. Not too sure what's causing it either.
Steps To ReproduceOpen up doomseeker
Wait a bit
Crashes
Additional Information0003728:0021091
0003728:0021116
Attached Files? file icon doomseeker.ini [^] (6,195 bytes) 2020-01-21 09:33

- Relationships
related to 0003733new Auto-updates may fire late after other buggy threads / functions have initiated and crashed the program 
related to 0003734resolvedZalewa Missing complete corresponding source for Doomseeker 1.3 on Windows after issue 0003728 

-  Notes
User avatar (0021084)
auratoostronk (reporter)
2020-01-16 05:06

Also I should note that my friend first-time downloaded doomseeker as well and was having the exact same issue.
User avatar (0021085)
WubTheCaptain (developer)
2020-01-18 02:43

I can't reproduce this (albeit I'm using Debian GNU/Linux instead of Windows). I made sure all five games are queried from master servers for servers.
Can you reproduce the issue if you disable querying specific games from the top menu bar (Query), or disconnect from the Internet?
Attaching an application crash dump (aka User-Mode Dump) might be useful to diagnose this issue. This requires local admin privileges and Windows Vista SP1 or later, then finding the appropriate crash dump from %LOCALAPPDATA%\CrashDumps. (Note the crash dump may contain IRC and server join passwords from configuration / memory, though.)
Having the standard output could be useful too, which is done by starting doomseeker.exe from CMD.exe or a .bat file, something like so (this is just a guess, depending on where Doomseeker is actually installed):
  1. Windows key + R (Run)
  2. CMD /c %ProgramFiles%\Doomseeker\doomseeker.exe
  3. Wait for the crash, maybe CMD doesn't close on itself for log output

0003456 and 0003395 are the other unresolved crash bugs.
Zalewa might be able to tell more about this, assigning this issue.
User avatar (0021086)
WubTheCaptain (developer)
2020-01-18 02:47
edited on: 2020-01-18 03:07

Also, OP, please tell us if you can reproduce your issue after disabling IP2C auto update from Options → Configure (F5) → Auto Updates → IP2C auto update. (If it does, this issue is a duplicate of 0003395.)

If you can't do this because of crashing, try disconnecting from the Internet first, firewall Doomseeker or modify doomseeker.ini in the Doomseeker directory, changing IP2CAutoUpdate=1 to IP2CAutoUpdate=0 and saving the file.

User avatar (0021087)
WubTheCaptain (developer)
2020-01-18 02:51
edited on: 2020-01-18 03:27

I suspect this is indeed an IP2C issue, again. I got this immediately after enabling IP2C updates (which are enabled by default with first-time setup):

[02:49:05] Init finished.
================================
[02:49:05] IP2C parsing thread has finished.
[02:49:05] IP2C parsing finished.
[02:49:05] Total refresh initialized!
[02:49:05] Comparing IP2C hashes: local = 93c3ec9df4c7e7728213b9e10f7a92c2, remote = aeca013c6eb838531099b9727f2187a0

[02:49:05] IP2C update needed.
[02:49:05] Starting IP2C update.
[02:49:07] IP2C database finished downloading.
[02:49:07] Please wait. IP2C database is being read. This may take some time.
[02:49:07] Parsing IP2C database: /home/wub/.local/share/doomseeker/IpToCountry.dat
[02:49:07] IP2C database read in 100 ms. Entries read: 196041
[02:49:07] IP2C parsing thread has finished.
[02:49:07] IP2C parsing finished.
Segmentation fault


Which all points to 0003395.

User avatar (0021090)
Zalewa (developer)
2020-01-18 23:45

It's probably the 0003395 issue caught again. I'll fix it.
User avatar (0021091)
Zalewa (developer)
2020-01-19 11:33

It's probably not 0003395 at all.

There was a severe problem in SRB2 plugin that would trigger an assertion in Qt which, in turn, would cause the program to shut down.

Fix:https://bitbucket.org/Doomseeker/doomseeker/commits/b623ab1412ab1fefde469c9f298e94c8087e6368 [^]

The fix is deployed for Windows to the stable and beta update channels, the DRD Team site and silently to Doomseeker's official site. I replaced the SRB2 plugin in the zip for version 1.3.

The issue in the old SRB2 plugin version can be avoided by disabling the SRB2 plugin (from the Query menu or the status bar) before the "bad" server gets refreshed and quickly closing the program so that the configuration gets saved.

Windows package with the fix can be downloaded here:
-http://doomseeker.drdteam.org/files/doomseeker-1.3_windows.zip [^]
-https://devbuilds.drdteam.org/doomseeker/doomseeker-1.3.0.1_windows.zip [^]
- from the auto-updater

Please confirm that the problem is fixed.
User avatar (0021102)
WubTheCaptain (developer)
2020-01-19 14:47

Zalewa, can the auto-updater operate before the crash occurs? (I'm not familiar with the auto-updater and how it works on Windows.)
User avatar (0021106)
Zalewa (developer)
2020-01-19 15:48

I doubt there will be enough time. That's why I provided the update in all the packages too.
User avatar (0021107)
WubTheCaptain (developer)
2020-01-19 16:58
edited on: 2020-01-19 16:58

In such case, the workaround for OP can be changing doomseeker.ini configuration from Query=1 to Query=0.
[SonicRoboBlast2]
BinaryPath=
CustomParameters=
IRCRegistered=1
Masterserver=ms.srb2.org:28900
Query=1

Change to:
[SonicRoboBlast2]
BinaryPath=
CustomParameters=
IRCRegistered=1
Masterserver=ms.srb2.org:28900
Query=0

And start Doomseeker for auto-updates (or update manually, either way).

User avatar (0021109)
auratoostronk (reporter)
2020-01-20 00:47

The issue seems to be on or off now, but with the latest update, it gives me two errors: libgcc_s_dw2-1.dll and libstdc++-6.dll were not found. I'll try the other fixes on the older version.
User avatar (0021110)
auratoostronk (reporter)
2020-01-20 00:56
edited on: 2020-01-20 00:57

Disconnecting from the internet did not cause a crash.
Reconnecting with IP2C disabled caused the crash again.
Disabling Sonic Query still caused the crash.

So I'm still stuck.

User avatar (0021111)
WubTheCaptain (developer)
2020-01-20 06:12
edited on: 2020-01-20 06:15

Would you attach your doomseeker.ini configuration to this issue, please? (See if I can reproduce the issue with your config.)
Can you determine if setting Query=0 on other games helps you? (I looked at the source code yesterday, and Vavoom / Odamex looked plausibly suspicious.)
Other than that, I think we're going to need logs to diagnose this.

User avatar (0021112)
WubTheCaptain (developer)
2020-01-20 06:17

Also, Zalewa will say something about the missing DLLs in auto-updater. (Doesn't seem to be issue 0003667 but... hm.)
User avatar (0021113)
Zalewa (developer)
2020-01-20 07:33
edited on: 2020-01-20 18:39

The DLLs are in all the packages. auratoostronk didn't mention how they updated the program. I checked some possibilities and found no problems.

The fix for 0003395 is not in any of the above packages. To have that, Doomseeker needs to be updated from the "beta" update channel. Perhaps 0003395 is still causing the crashes?

I just uploaded the full package of this "beta" to the DRD Site:
https://devbuilds.drdteam.org/doomseeker/doomseeker-1.3.0.1~beta-200119-1007_windows.zip [^]

User avatar (0021114)
auratoostronk (reporter)
2020-01-21 09:35

Uploaded the .ini. Also I used the auto-updater for Doomseeker on the stable channel. My friend who had first-time downloaded Doomseeker was having the exact same issue off a fresh installation. I can see if she can provide feedback.
User avatar (0021115)
auratoostronk (reporter)
2020-01-21 09:38

Also, I just tried disabling all queries besides Zandronum and it seems to be working after a failed attempt with all queries enabled.
User avatar (0021116)
WubTheCaptain (developer)
2020-01-22 06:13

Quote from Doomseeker 1.3
Thread 1 "doomseeker" received signal SIGSEGV, Segmentation fault.
0x00007ffff69a751d in QString::operator=(QString const&) () from /lib/x86_64-linux-gnu/libQt5Core.so.5

(gdb) bt
#0  0x00007ffff69a751d in QString::operator=(QString const&) () from /lib/x86_64-linux-gnu/libQt5Core.so.5

#1  0x00007ffff0c6b9dd in Srb2Server::processServerInfo(Srb2ServerPacket::ServerInfo const&) () from 
/usr/lib/x86_64-linux-gnu/doomseeker/engines/libsrb2.so
0000002  0x00007ffff0c6bd71 in Srb2Server::processInfoPackets() () from /usr/lib/x86_64-linux-gnu/doomseeker/engines/libsrb2.so

0000003  0x00007ffff0c6be80 in Srb2Server::readRequest(QByteArray const&) () from /usr/lib/x86_64-linux-gnu/doomseeker/engines/libsrb2.so

0000004  0x0000000000639625 in Refresher::tryReadDatagramByServer(QHostAddress const&, unsigned short, 
QByteArray&) ()
0000005  0x000000000063b606 in Refresher::readPendingDatagram() ()
0000006  0x000000000063b6db in Refresher::readAllPendingDatagrams() ()
0000007  0x00007ffff6b12458 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5

0000008  0x00007ffff6b12458 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5

0000009  0x00007ffff74aa874 in ?? () from /lib/x86_64-linux-gnu/libQt5Network.so.5
0000010 0x00007ffff74aa90b in ?? () from /lib/x86_64-linux-gnu/libQt5Network.so.5
0000011 0x00007ffff74bc921 in ?? () from /lib/x86_64-linux-gnu/libQt5Network.so.5
0000012 0x00007ffff77f2c32 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5

0000013 0x00007ffff77fc190 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5

0000014 0x00007ffff6ae7b22 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5

0000015 0x00007ffff6b3e495 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
0000016 0x00007ffff5b04f1d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000017 0x00007ffff5b051a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000018 0x00007ffff5b0522f in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000019 0x00007ffff6b3d891 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) 
() from /lib/x86_64-linux-gnu/libQt5Core.so.5
0000020 0x00007ffff6ae67ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5

0000021 0x00007ffff6aee252 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
0000022 0x00000000006242e0 in Main::run() ()
0000023 0x00000000004d81eb in main ()


Looks like it's what Zalewa said about SRB2. It doesn't crash every time, but I was able to reproduce the issue with the provided doomseeker.ini. I attempted verifying if the latest beta has fixed this issue, and the patch seems to be working.

The sources for Doomseeker 1.4 will ship with this fixed plugin; stable and beta builds for Doomseeker 1.3 on Windows should have this fixed in Sonic Robo Blast 2 plugin version 14.

Please make a note if you're still experiencing one of the two crashes in the doomseeker-1.3.0.1~beta-200119-1007 build Zalewa posted earlier.
User avatar (0021117)
WubTheCaptain (developer)
2020-01-22 06:16
edited on: 2020-01-22 06:22

To be clear, if you installed Doomseeker 1.3 Windows build before 2020-01-19, please redownload it from the DRDTeam website or use the doomseeker-1.3.0.1~beta-200119-1007 at 0003728:0021113.

If you still experience issues with libgcc_s_dw2-1.dll and/or libstdc++-6.dll missing, please report an issue.


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2020-01-15 23:40 auratoostronk New Issue
2020-01-16 05:06 auratoostronk Note Added: 0021084
2020-01-18 02:43 WubTheCaptain Note Added: 0021085
2020-01-18 02:43 WubTheCaptain Assigned To => Zalewa
2020-01-18 02:43 WubTheCaptain Status new => feedback
2020-01-18 02:47 WubTheCaptain Note Added: 0021086
2020-01-18 02:51 WubTheCaptain Note Added: 0021087
2020-01-18 02:53 WubTheCaptain Note Edited: 0021086 View Revisions
2020-01-18 02:56 WubTheCaptain Priority normal => high
2020-01-18 03:01 WubTheCaptain Note Edited: 0021086 View Revisions
2020-01-18 03:06 WubTheCaptain Category UI => Bug
2020-01-18 03:07 WubTheCaptain Note Edited: 0021086 View Revisions
2020-01-18 03:07 WubTheCaptain Note Edited: 0021086 View Revisions
2020-01-18 03:27 WubTheCaptain Note Edited: 0021087 View Revisions
2020-01-18 23:45 Zalewa Note Added: 0021090
2020-01-19 11:33 Zalewa Note Added: 0021091
2020-01-19 11:33 Zalewa Status feedback => needs testing
2020-01-19 14:33 WubTheCaptain Target Version => 1.3
2020-01-19 14:47 WubTheCaptain Note Added: 0021102
2020-01-19 15:48 Zalewa Note Added: 0021106
2020-01-19 16:21 WubTheCaptain Relationship added related to 0003733
2020-01-19 16:58 WubTheCaptain Note Added: 0021107
2020-01-19 16:58 WubTheCaptain Note Edited: 0021107 View Revisions
2020-01-20 00:47 auratoostronk Note Added: 0021109
2020-01-20 00:56 auratoostronk Note Added: 0021110
2020-01-20 00:57 auratoostronk Note Edited: 0021110 View Revisions
2020-01-20 05:49 WubTheCaptain Status needs testing => new
2020-01-20 06:12 WubTheCaptain Note Added: 0021111
2020-01-20 06:12 WubTheCaptain Assigned To Zalewa => WubTheCaptain
2020-01-20 06:12 WubTheCaptain Status new => feedback
2020-01-20 06:15 WubTheCaptain Note Edited: 0021111 View Revisions
2020-01-20 06:17 WubTheCaptain Note Added: 0021112
2020-01-20 06:19 WubTheCaptain Assigned To WubTheCaptain =>
2020-01-20 07:33 Zalewa Note Added: 0021113
2020-01-20 07:36 Zalewa Note Edited: 0021113 View Revisions
2020-01-20 18:39 Zalewa Note Edited: 0021113 View Revisions
2020-01-21 09:33 auratoostronk File Added: doomseeker.ini
2020-01-21 09:35 auratoostronk Note Added: 0021114
2020-01-21 09:35 auratoostronk Status feedback => new
2020-01-21 09:38 auratoostronk Note Added: 0021115
2020-01-22 05:59 WubTheCaptain Reproducibility always => sometimes
2020-01-22 05:59 WubTheCaptain Status new => acknowledged
2020-01-22 06:13 WubTheCaptain Note Added: 0021116
2020-01-22 06:13 WubTheCaptain Status acknowledged => resolved
2020-01-22 06:13 WubTheCaptain Fixed in Version => 1.4
2020-01-22 06:13 WubTheCaptain Resolution open => fixed
2020-01-22 06:13 WubTheCaptain Assigned To => Zalewa
2020-01-22 06:16 WubTheCaptain Note Added: 0021117
2020-01-22 06:18 WubTheCaptain Note Edited: 0021117 View Revisions
2020-01-22 06:18 WubTheCaptain Note Edited: 0021117 View Revisions
2020-01-22 06:21 WubTheCaptain Note Edited: 0021117 View Revisions
2020-01-22 06:22 WubTheCaptain Note Edited: 0021117 View Revisions
2020-01-22 06:29 WubTheCaptain Additional Information Updated View Revisions
2020-01-22 07:05 WubTheCaptain Relationship added related to 0003734
2020-01-27 20:32 WubTheCaptain Fixed in Version 1.4 => 1.3.1
2020-01-27 20:32 WubTheCaptain Target Version 1.3 => 1.3.1
2020-01-30 12:58 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker