Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000002Zandronum[All Projects] Bugpublic2010-08-23 19:092018-09-30 19:47
ReporterTorr Samaho 
Assigned ToTorr Samaho 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version98c 
Target VersionFixed in Version98d 
Summary0000002: Crouch Toggle doesn't work online
DescriptionConflagratedCanine wrote:
This actually WAS reported before, but it was by Lord of Hell and everybody instantly flamed his one useful post.

Just as the title says, using crouch toggle online does nothing at all.
Normally this isn't a problem, but with more and more 'environmentally sensitive' wads floating around (Hide N' Seek, WDI, blah blah), I think it would be a nice feature to fix for players.
Steps To ReproduceExecute "crouch" in the console. Works offline, has no effect online.
Additional InformationThe crouch console command doesn't work because it uses ZDoom's Net_WriteByte mechanism which isn't used in multiplayer in Skulltag at all. To fix this, additional net code needs to be written: CLIENTCOMMANDS_ToggleCrouch, etc.
Attached Files

- Relationships

-  Notes
User avatar (0000028)
Torr Samaho (administrator)
2010-09-11 12:10

I think I found a way to let the client toggle crouch without writing any new net code (uses +crouch and +crouch internally). Can somebody test if this works sufficiently well:

http://www.dailydoomer.com/tsst/misc/SkullDev98dCrouchToggleTest.7z [^]
User avatar (0000032)
unknownna (updater)
2010-09-12 03:36
edited on: 2010-09-12 13:29

It works, but there's a difference between online and offline behaviour.

Offline, if in crouch mode, jumping doesn't alter your viewpoint and sprite, but online, if jumping while in crouch mode, your viewpoint and sprite changes back to the regular height and sprite until you release the jump button.

Offline, while holding jump, you cannot toggle crouch until you release the jump button. Online you can.

Edit:

And BTW, can you enable client-side prediction for crouching? Offline, there's a smooth transition in the viewpoint from standing to crouching, but online it's fast and instant.

User avatar (0000041)
Torr Samaho (administrator)
2010-09-12 19:40

Since the online version is implemented very differently it's not surprising that it doesn't behave exactly the same. From what you report, I'd say it works sufficiently well though. Agreed?

IIRC client side prediction for crouching isn't implemented. If you would like to have it, please make a feature request. I personally don't think that it's really necessary though.
User avatar (0000050)
unknownna (updater)
2010-09-13 02:33

It works, but I really think that client-side prediction for crouching is crucial from a practical point of view. The instant transition also has some shakiness to it, so it can be quite disorienting if you use it a lot while aiming and such.

It'd be like not having jumping predicted.
User avatar (0000076)
Torr Samaho (administrator)
2010-09-18 18:01

Crouch toggling should now work sufficiently well. The fact that there is no client side prediction for crouching is a completely separate issue that it not only limited to toggling crouch.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2010-08-23 19:09 Torr Samaho New Issue
2010-09-05 17:45 Torr Samaho Status new => confirmed
2010-09-05 17:49 Torr Samaho Steps to Reproduce Updated View Revisions
2010-09-06 18:39 Torr Samaho Additional Information Updated View Revisions
2010-09-11 12:06 Torr Samaho Assigned To => Torr Samaho
2010-09-11 12:06 Torr Samaho Status confirmed => assigned
2010-09-11 12:10 Torr Samaho Note Added: 0000028
2010-09-11 12:10 Torr Samaho Status assigned => feedback
2010-09-11 12:12 Torr Samaho Product Version => 98c
2010-09-12 03:36 unknownna Note Added: 0000032
2010-09-12 12:44 unknownna Note Edited: 0000032 View Revisions
2010-09-12 13:29 unknownna Note Edited: 0000032 View Revisions
2010-09-12 19:40 Torr Samaho Note Added: 0000041
2010-09-12 19:40 Torr Samaho Status feedback => assigned
2010-09-12 19:41 Torr Samaho Status assigned => feedback
2010-09-13 02:33 unknownna Note Added: 0000050
2010-09-18 18:01 Torr Samaho Note Added: 0000076
2010-09-18 18:01 Torr Samaho Status feedback => assigned
2010-09-18 18:01 Torr Samaho Status assigned => resolved
2010-09-18 18:01 Torr Samaho Fixed in Version => 98d
2010-09-18 18:01 Torr Samaho Resolution open => fixed
2012-06-09 13:22 Torr Samaho Category General => Bug
2018-09-30 19:47 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker