Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003667Doomseeker[All Projects] Bugpublic2019-06-22 17:302019-06-23 09:53
ReporterAOSP 
Assigned ToZalewa 
PriorityurgentSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformMicrosoftOSWindowsOS Version7 SP1 x64
Product Version1.3 
Target Version1.3Fixed in Version1.3 
Summary0003667: Latest beta update does not launch
DescriptionThe latest beta update does not launch with an error saying libstdc++-6.dll is missing. Also heard from some other people that the DLL exists, but is outdated.
Steps To ReproduceUpdate Doomseeker on Windows to latest beta.
Attached Files

- Relationships

-  Notes
User avatar (0020806)
Zalewa (developer)
2019-06-22 18:40
edited on: 2019-06-22 18:41

This is the first auto-update since the compiler has been switched to MinGW. I didn't forget about adding libstdc++-6.dll to the update package generator's manifest, but I forgot that this file manifest is a list of regular expressions. So, the + in the filename was being interpreted as a regexp action...

Fix:https://bitbucket.org/Doomseeker/doomseeker/commits/1c35910d8db02b4e921c47acca13eefef24b9b6a [^]

I have deployed the fixed package so that hopefully no one else downloads a broken update.

Those who were affected can obtain the full release package from here:
https://devbuilds.drdteam.org/doomseeker/doomseeker-1.3~beta-190622-1032.zip [^]

User avatar (0020817)
AOSP (reporter)
2019-06-23 09:52

Yeah, the update works now. This issue can be closed as resolved.
User avatar (0020818)
Zalewa (developer)
2019-06-23 09:53

Ok. And sorry :(

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-06-22 17:30 AOSP New Issue
2019-06-22 18:18 Zalewa Assigned To => Zalewa
2019-06-22 18:18 Zalewa Status new => assigned
2019-06-22 18:40 Zalewa Note Added: 0020806
2019-06-22 18:40 Zalewa Status assigned => needs testing
2019-06-22 18:41 Zalewa Note Edited: 0020806 View Revisions
2019-06-22 18:42 Zalewa Product Version => 1.3
2019-06-22 18:42 Zalewa Target Version => 1.3
2019-06-23 09:52 AOSP Note Added: 0020817
2019-06-23 09:53 Zalewa Note Added: 0020818
2019-06-23 09:53 Zalewa Status needs testing => resolved
2019-06-23 09:53 Zalewa Fixed in Version => 1.3
2019-06-23 09:53 Zalewa Resolution open => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker