Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000003Zandronum[All Projects] Bugpublic2010-09-05 11:042018-09-30 19:48
ReporterAnonymous 
Assigned ToTorr Samaho 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version98c 
Target VersionFixed in Version98d 
Summary0000003: Ghost items appear on drop
DescriptionWhen a player gets rid of a weapon/inventory item via the 'drop' console command,
a duplicate of the object that cannot be picked up appears at 0,0 on the map grid.
Steps To Reproduce1. Host a server using the attached .wad with sv_nodrop set to 0. Use Map01 for this test.
2. Connect to the server.
3. Pick up any of the weapons in front of the spawns
4. Drop the weapons. The dropped item's duplicate will appear on the black pad, which is positioned at 0,0 on the map grid.
Attached Files? file icon Dropbugtest.wad [^] (2,520 bytes) 2010-09-05 11:04

- Relationships

-  Notes
(0000001)
Anonymous (viewer)
2010-09-05 11:39

When a client reconnects, the ghost items dissapear for them. I assume this means the problem is on the client's side.
User avatar (0000003)
Torr Samaho (administrator)
2010-09-05 17:28
edited on: 2010-09-05 17:28

Now that's a commendable example wad! Fixed in revision 2911.


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2010-09-05 11:04 Anonymous New Issue
2010-09-05 11:04 Anonymous File Added: Dropbugtest.wad
2010-09-05 11:39 Anonymous Note Added: 0000001
2010-09-05 16:58 Torr Samaho Assigned To => Torr Samaho
2010-09-05 16:58 Torr Samaho Status new => confirmed
2010-09-05 17:28 Torr Samaho Note Added: 0000003
2010-09-05 17:28 Torr Samaho Status confirmed => resolved
2010-09-05 17:28 Torr Samaho Resolution open => fixed
2010-09-05 17:28 Torr Samaho Note Edited: 0000003 View Revisions
2010-09-07 21:02 Torr Samaho Fixed in Version => 98d
2012-06-09 13:22 Torr Samaho Category General => Bug
2018-09-30 19:48 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker