Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000006Zandronum[All Projects] Bugpublic2010-09-06 20:592018-09-30 22:52
ReporterKonda 
Assigned ToTorr Samaho 
PrioritynoneSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version98c 
Target VersionFixed in Version 
Summary0000006: ONLINE - Weapon shows 0 ammo but functions almost normally
DescriptionI have been working on a project, and there you pick up custom inventory that do checks before giving you the weapon (checking for slots taken, if the player already has the weapon, etc.). The weapon's ammo maximum amount is 1 and it disappears from your inventory after you use it. It all works perfectly fine offline but online when you pick up the weapon it shows 0 ammo. After using it, it works normally, but doesn't disappear from your inventory after using it. Alt fire works the same way but it spawns the projectile that spawns the weapon (weapon drop) but that is probably because the weapon uses no ammo for alt fire. On alt fire, the weapon is "dropped" and the weapon disappears from your inventory.
Steps To ReproduceTrying to reproduce it online, I have tried the 'give' cheats to give myself ammo of that weapon or the custom inventory that gives me the weapon, but nothing has changed. After that I tried giving myself the weapon and the ammo was showing up like it should, and the weapon disappears from your inventory after fire like it should be. Bingo! I found how to reproduce it! Then in the DECORATE script I tried raising the second parameter of A_GiveInventory (for weapon) which is inventory amount given but it didn't work. So after I was thinking what the hell is wrong now I figured out that there must be a delay between each time the script gives you the weapon. So I did delay 1 between each A_GiveInventory (for weapon).

TL;DR version:
The script gave the weapon to the player once. After researches I found out that the script has to give the weapon to the player at least twice (with a delay between each time), which shouldn't be the only way it works properly.
Additional InformationThe ZIP contains 2 files, the WAD with the issue mentioned (smokebomb-onlinebug.wad) and the one which has reproduced the bug via DECORATE script (smokebomb-reproduced.wad). In the game turn on cheats and summon "ISmokeGrenade" and pick it up. First try it with smokebomb-onlinebug.wad and then with smokebomb-reproduced.wad online. The wads must NOT be loaded together

DON'T MIND THE TEXT.TXT, IT IS AN EMPTY TEXT FILE. I COULDN'T REMOVE THE FILE FROM THE UPLOAD ONCE I REALIZED IT HAS MORE THAN 2MB OF SIZE.

DOWNLOAD LINK:http://www.speedyshare.com/files/24145358/smokebomb-report.zip [^]
Attached Files

- Relationships

-  Notes
User avatar (0000083)
Torr Samaho (administrator)
2010-09-19 08:23

http://www.dailydoomer.com/tsst/misc/SkullDev98dAmmoFixTest.7z [^] should fix the issue. Please test and report back.
User avatar (0000096)
Konda (reporter)
2010-09-19 16:02
edited on: 2010-09-19 16:05

After trying the skulltag version you posted, everything works fine - It shows me 1/1 in ammo like it should and the weapon disappears after fire like it should.
EDIT: I tried it online too, and everything works fine just like in single player. Good job

User avatar (0000097)
Torr Samaho (administrator)
2010-09-19 16:24

Thanks for testing! I'll consider this to be fixed then.
User avatar (0000138)
Torr Samaho (administrator)
2010-09-22 20:31

It turned out that this is not a Skulltag bug at all, but a bug in the example wad. SNadeAmmo is not an ammo type because it is not directly derived from AAmmo and hence can't be used as ammo type for SmokeGrenade. Seehttp://zdoom.org/wiki/Classes:Ammo [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2010-09-06 20:59 Konda New Issue
2010-09-19 07:51 Torr Samaho Assigned To => Torr Samaho
2010-09-19 07:51 Torr Samaho Status new => assigned
2010-09-19 08:23 Torr Samaho Note Added: 0000083
2010-09-19 08:23 Torr Samaho Status assigned => feedback
2010-09-19 08:25 Torr Samaho View Status private => public
2010-09-19 16:02 Konda Note Added: 0000096
2010-09-19 16:02 Konda Status feedback => assigned
2010-09-19 16:05 Konda Note Edited: 0000096 View Revisions
2010-09-19 16:24 Torr Samaho Note Added: 0000097
2010-09-19 16:24 Torr Samaho Status assigned => resolved
2010-09-19 16:24 Torr Samaho Fixed in Version => 98d
2010-09-19 16:24 Torr Samaho Resolution open => fixed
2010-09-22 20:31 Torr Samaho Note Added: 0000138
2010-09-22 20:31 Torr Samaho Resolution fixed => no change required
2010-09-22 20:31 Torr Samaho Fixed in Version 98d =>
2012-06-09 13:22 Torr Samaho Category General => Bug
2018-09-30 22:52 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker