Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003575Site[All Projects] Cleanuppublic2018-12-09 16:062018-12-10 19:41
ReporterWubTheCaptain 
Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
StatusnewResolutionopen 
PlatformOSOS Version
Summary0003575: Undealt incidences for scrutinity of user's behavior on the tracker
DescriptionI try to be civil and understanding in this ticket.

Filystea's behavioral patterns indicate to clearly not be here to work collaboratively to improving the projects hosted on Zandronum tracker. Indications of this include:

  • Treating the issue tracker as a battleground or soapbox, when his/her/their anger becomes the main focus of ticket(s) and not working towards resolving issues (whether reported by him/her/them or others)
  • Conflict of attitude or intention, demanding (unpaid and not often thanked) volunteers of the project to "do your job and read what I wrote"
  • Sometimes little interest to working collaboratively in resolving issues when requested for more feedback, stalling the tickets open by repeating the issue mentioned in OP to still exist without improvement (e.g., not uploading an example WAD)
  • Long-term history suggesting a low value of reported issues to the projects


I am proposing some scrutinity to this kind of behavior on the issue tracker (irregardless of the user to be scrutinized).
Steps To Reproduce
  • 0003574: "This MUST be BUG and if it is not than NEEDS TO BE CHANGED - vide fixed anyway", immediate priority, major severity.
  • 0003403: Indescriptive title "hu"
  • 0002756: Indescriptive title "Strange"
  • 0003570: Indescriptive title "Does this look like bug ?" and steps "hue" "hue"
  • 0003106: "hue" "hue"
  • 0002981, 0003567, others: Reporting Doomseeker issues to the Zandronum project tracker.
  • 0003328: Little interest to work collaboratively and conflict of attitude (only collaborating "If I see some of stuff I reported resolved.")
  • 0003335: Little interest to work collaboratively
  • 0003351: Immediate priority (no actual urgency shown), invalid ticket.
  • 0002990:0020183: Bumping a ticket with no additional information, question or resolution to contribute.
  • ...and many more.


Many are not actionable, but yet-to-be resolved/closed as invalid tickets.

I seem to not be the only one dealing with this issue. One particular user has caused comments such as 0003106:0017390 (although the ticket itself is a valid feature request):

Quote from mifu
Could of sworn a certian dev already told you to stop making bullshit tickets.


0003567:0020201:

Quote from Blzut3
The original poster is someone who consistently writes tickets in this manner and is unlikely to ever change.


0003223:0018173:

Quote from Dusk
I also don't understand why do you bother yourself in community matters like this when you're supposed to be banned from it pretty much entirely.


0003223:0018178:

Quote from Filystea
Don't get me wrong I don't give a single shit about the community and after I was banned without stating a reason why ( waited month for answer ?). I will rarely take my time for pleasure in causing shit for some certain garbage people who happen to be main head of the *community*,


However, no scrutinity was taken at the time of comments.
Additional InformationAbout Filystea in particular: Something changed in the behavior from early 2017 onwards; tickets from 2016 were mostly descriptive and useful to the developers. 0002974:0016777 is an example of a civil response, appreciated here.

Looking back, I could have handled 0003567 differently and asked for more feedback before closing it as resolved. (I try to keep tickets at "resolved" for a week or two before closing them.) I am not certain if this could have provoked an irritated or fed-up response, such as the one in 0003574.

I ask that people posting notes to this ticket remain civil, clearly but kindly explaining what they may have felt uncivil. Remain calm and reasonable.
Attached Files

- Relationships

-  Notes
User avatar (0020228)
AOSP (reporter)
2018-12-09 16:21
edited on: 2018-12-09 16:23

Fily has been g-lined on sight on IRC for many years now, and has been involved with a very large scale defacing of the Zan wiki back when it was still owned by Konar6. Why he was ever let near the tracker at all, never mind for this long, is beyond me...

Edit - oh, they're banned many times on the master ban list as well, even with a bit of drama arising from that recently.

User avatar (0020229)
WubTheCaptain (reporter)
2018-12-09 18:12

I'll take a risk of bringing this up here.

As I see it about Filystea and I'm trying to understand, the reasons for his/her/their negative attitudes may be two-fold and external. I don't know the full history/life story of Filystea in particular, but factors outside the tracker with relevance to the Zandronum project may be reflected here on the tracker too (especially lately).

WaTaKiD, in his/her/their role as a Zandronum master server administrator, may have his/her/their mind set on "hounding" particular players; such as those found on the master server ban list. It may be a form of harassment, seen as an apparent aim of creating irritation, annoyance or distress to the player.

I personally scrutinize WaTaKiD's requests for personal data of players (nicks + IP-addresses) from server operators, which may lack a lawful reason for server operators to transfer to third-parties in the EU's GDPR era. More condemning is the publication of the master ban list's personal data collection to the wide public, with no transparency to lawfulness of processing or why the data must be published publicly (while still being lawful).

From what I understood, Filystea just wanted to have fun and play games maturely. But my heart is absolutely broken by how external people affiliated with Zandronum have taken willful and proactive exclusion of somebody who just wants to play some fucking games without causing a disturbance. To quote:

Quote from grrfield
Since he was not trolling and not even being a dick by taking hp when there are people almost dead


Fair enough, I can't agree to all the master server rules either and WaTaKiD has a heart breaking right to express ignorance to any person or the law on personal data processing. Complete and utter bullshit excuses, not using what a master server banlist may be useful for: Cheaters.

I can like Filystea, who I don't know and who I will probably never meet in-game, for their past good contributions because I'm capable of basic empathy and they deserve that inclusivity and love more than they deserve being distressed and hounded by few abhorrent, "some certain garbage people" in the small "community".

Now, I'd like to hear what Filystea has to say about this.
User avatar (0020230)
Filystea (reporter)
2018-12-09 19:09

I am a man. Just for record. I don't remember now why womanish nick was picked, probably because i thought it's funny.

I will write longer answer today but later since now I am quite busy.
For time being I mostly blasted because I spent hour for finding where I did mistake, to conclude it works differently than the documentation says. That function is fairy old. How come stuff like that is never tested. I feel sometimes most functions where never tested. Anyway longer answer later. I am not that innocent here but they masterbanned me without ever stating reason. This is the foundation stone of the main conflict.

Later as said - will give clarification.
User avatar (0020231)
Filystea (reporter)
2018-12-09 23:03

Answer probably will take few posts.

About stuff that is out there and *playing the game we test it*.

There are too many situations basic stuff does not work.
They should list things that need testing. And I mean real testing. Not fucking around. So if something is in documentation - it works.
Eventually make a huge testing wad and test it each new stable release.
I guess we are forced to do gzdoom job here. Since we must first test gzdoom than if we are lucky and things work test zandronum.

Secondly the general feeling is. Not much job is being done. Is there a list of priorities/plans to do ? Like for this year we are going to *this* and *this*. Becuase this and this is important.

Let us face the fact. Since most stuff is broken ( each time I tried to use some other function than most popular it never works or missbehaves ). Where they not added because someone asked for them or something? Developers don't test anything they do? No wonder that most mods just add new sprites and change basic shit in monsters. Doing anything sophisticated ends IF LUCKY in doing strange hacks to make things work.

At some point I stoped carrying. Things just take too much time. I will spend 1 hour making an example test it on zdoom and zan offline new old versions. And nothing ill be done. So it's better to simply report the problem exists and at least I can refresh if I forget what was wrong.

"0002990:0020183: Bumping a ticket with no additional information, question or resolution to contribute."
Zdoom fixed it, quite fast as i remember. All is known. Now we are waiting. 2 years for repairing health stealing feature in zan. (had to remove this from my mod ).

And so on.
User avatar (0020232)
Filystea (reporter)
2018-12-09 23:12

So clearing this part up

"if this could have provoked an irritated or fed-up response, such as the one in 0003574."

You did not provoke anything.

Al thou I think some tickets you make have little need to be solved and are more of time wasters. I don't have anything serious against you.
_________
I set the bugs as major or urgent because well they are important bugs that need to be fixed. Even if for most they are not.
User avatar (0020233)
Filystea (reporter)
2018-12-09 23:33

Ofc sometiems I set them to urgent for lolz. Tbh no one will do anything what ever I set there.

Now about that drama since it was brought here. This has little influence on me. I felt quite bad for Grrfield and even went on irc to tell masterserver admin that he is not hiding my ip etc. Since Flem/Grrfield is kind of ok person. But this is all I can do. Still it's not something that makes me completely lose control.
What is really pathetic tho is that except Leonard no one tried to somehow take Grrfield side. Shame. Hue hue.

When it comes to me I did a lot of bad stuff. But I think nothing that deserved full lifetime perma ban. Anyway there are people here I like to play with and interact so when I feel I want I will evade. Evading is so easy and talking out any issue with master admins seem impossible. So the answer is simple.

Also not much holds me back from pulling out some shit. I am quite experienced with the stuff I can do and the top admins build up their negative reputation over years so yeah answer is obvious.

Now we are heading to the real gem:

"More condemning is the publication of the master ban list's personal data collection to the wide public, with no transparency to lawfulness of processing or why the data must be published publicly (while still being lawful)."

It always makes me wander. Do they have like zero imagination? They even keep people there who are commented out and been ban for crap like dropping ssg.

Like immediately one would think hey lets take this Galactus kid IP and spoof it on synflood. Or spoof on ping flood and attack as many as I can. maybe they will take notice and even ban him again,
Or shoot out http dos attack via proxy on their fucking website and put some crap in HTTP header in user agent like cracker trial ip: *galactusIP* or put it in via part or where do the open proxies put it hue?

Many ways to have it funny. Yet they decide to keep it open.
User avatar (0020234)
Filystea (reporter)
2018-12-09 23:34
edited on: 2018-12-09 23:36

I think I cleared the most of stuff I wanted to say.

Last thing.

I actually have copied the master ban list in case they would smarten up and remove it in future.

User avatar (0020235)
Blzut3 (administrator)
2018-12-10 02:23
edited on: 2018-12-10 02:31

I've separated Zandronum software development and Zandronum community administration for a reason. Please take the drama discussion elsewhere. If you guys don't like the way the current admins are running the community, you're free to start a new master server. I've seen enough between here and reports of how things are handled on AAA game communities to know that there will always be drama, so discussing it here only serves to pollute a platform that really isn't geared for this sort of thing.

I will let this ticket remain open, perhaps against my better judgement since I'm curious what will come of it.

As for why we haven't removed Filystea from the tracker: Because I know it's not a productive use of time. He is not currently making tickets or spamming threads at a rate that couldn't just be solved by deleting spam or fixing legit reports. I guess at this point I shall remind everyone about the rules page on this tracker of which the third point reads (and has always read):
Quote from The rules
Notes that don't contain useful information will be deleted to keep the tickets clean of bloat. This is a bug tracker, not a forum.


The purpose of the bug tracker is to assist with software development, not a discussion board. To that end, and I'm sure Filystea has notice on at least I few occasions, I have been deleting the more egregious notes and tickets that he has made. It's nothing personal, the rules clearly state that it will happen.

Quote from "Filystea"
I guess we are forced to do gzdoom job here. Since we must first test gzdoom than if we are lucky and things work test zandronum.

I think the big thing that happens is the community's taste in mods changes over time. Back when I was an active mod author and involved in coming up with very clever ways to achieve effects (G)ZDoom has always been quite solid. It should be telling that ZDoom rarely went past the .1 release since fixes never really accumulated until the release got too old to really worry about. Somehow by the time Zandronum gets around to using a given version we're all using the code completely differently and finding issues that just never manifested at the time.

Now compound this with the historically unstable Skulltag code base and I'm not surprised that some things are just more broken. You shouldn't be surprised either since Skulltag/Zandronum has always had over a thousand open reports while ZDoom usually would be somewhere between 40-200 reports at any given time. Now we could debate on why that is for a long time, but the reality is unlikely to change. Especially currently where it seems time to work on Zandronum has been limited for everyone.
Quote from "Filystea"
Secondly the general feeling is. Not much job is being done. Is there a list of priorities/plans to do ? Like for this year we are going to *this* and *this*. Becuase this and this is important.

Pretty much ever since Torr joined the team the plan has been basically: Upgrade the GZDoom code base, and then have a smaller list of regressions compared to the last release. By the time we got our head out of the water (which I would argue was only about the Zandronum 2.x time frame) developer resources started to get spread thin. To that end while I don't disagree with the sentiment, I'm not sure there's enough of a team regularly working to enforce such a plan right now.
Quote from "Filystea"
Ofc sometiems I set them to urgent for lolz. Tbh no one will do anything what ever I set there.

For the Zandronum tracker this is absolutely true. Frankly I do think MantisBT gives the reporter too much control over the initial state of a ticket. It never really bothered me though since after a report is made only elevated users can modify it so if we really cared about the priority field or whatever we could just take care of it during triage (a process we don't have in place since after doing it for a few weeks everyone just seemingly gave up).

I totally understand the frustration on not having tickets looked at, but again we have over 1,000 tickets. I don't think it should be surprising. This doesn't mean that adding to the pile isn't valuable. The whole point of the tracker is to prevent things from getting lost. A good report will eventually get looked into, even if it takes years.

However your tickets as of late at least have not been very clear and have not included examples. For example the mentioned 0003570. Since you give literally zero details it's literally impossible to answer the question in the title. For all I know that's the intended effect you were going for.

User avatar (0020240)
Filystea (reporter)
2018-12-10 19:41

"You're free to start a new master server."

Yeah. I am gona fucking do it. I will rebuild all the fucking doom.
From fucking zero.

You don't advertise. you drive away people. You even admit you don't do that much development. Die in peace, the faster - the better.

I kind of regret I started making that mod. Since most of cool things with your speed of doing will never happen to see light.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: AOSP WubTheCaptain
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-12-09 16:06 WubTheCaptain New Issue
2018-12-09 16:21 AOSP Note Added: 0020228
2018-12-09 16:23 AOSP Note Edited: 0020228 View Revisions
2018-12-09 18:12 WubTheCaptain Note Added: 0020229
2018-12-09 19:09 Filystea Note Added: 0020230
2018-12-09 23:03 Filystea Note Added: 0020231
2018-12-09 23:12 Filystea Note Added: 0020232
2018-12-09 23:33 Filystea Note Added: 0020233
2018-12-09 23:34 Filystea Note Added: 0020234
2018-12-09 23:36 Filystea Note Edited: 0020234 View Revisions
2018-12-10 02:23 Blzut3 Note Added: 0020235
2018-12-10 02:31 Blzut3 Note Edited: 0020235 View Revisions
2018-12-10 19:41 Filystea Note Added: 0020240






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker