Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003567Doomseeker[All Projects] Suggestionpublic2018-11-25 15:032018-12-04 00:04
ReporterFilystea 
Assigned ToWubTheCaptain 
PrioritylowSeverityfeatureReproducibilityalways
StatusclosedResolutioninvalid 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version 
Target VersionFixed in Version 
Summary0003567: Unable to log/redirect stderr/stdout output of servers started from Doomseeker on Windows
Descriptionthis is only windows problem.

In unix you can do it easily but not sure how to do it on windows when starting from doomseeker.

Save console lines.
Rarely it helps in debugging.
Attached Files

- Relationships

-  Notes
User avatar (0020195)
Blzut3 (administrator)
2018-11-25 19:10

The thing you can do right now is to add "+logfile C:\Path\to\logfile.log" to the Custom parameters under Games->Zandronum in the configuration dialog.

It may perhaps be worthwhile to add an option to log games. I don't even think we have that in the server creation dialog now that I think about it.
User avatar (0020196)
WubTheCaptain (developer)
2018-11-25 21:55
edited on: 2018-11-25 21:55

I see Blzut3 removed duplicate of issue 0003446, but that's what this ticket seems to be from OP's description.

I don't understand if OP couldn't do "zandronum-server.exe +flags >> C:\zandronum-server.log" after getting the server command line (unless 0003446 is the reason why). If the suggestion was really here to add graphical +logfile support to Doomseeker game engines, better reword OP's suggestion in an understandable way in a new ticket (and something better than "hurry", empty steps to reproduce and a stupidly high ticket priority).

So uh, this ticket is not salvageable and almost "invalid".

User avatar (0020197)
Blzut3 (administrator)
2018-11-25 22:01
edited on: 2018-11-25 22:05

OP's description is a little vague since I had to move it from the Zandronum category from here.

0003446 involves the output of the Doomseeker stdout/err which is a different thing.

User avatar (0020198)
WubTheCaptain (developer)
2018-11-25 22:04
edited on: 2018-11-25 22:08

Fine. But make a new ticket please, with a clear resolvable software issue.

User avatar (0020199)
WubTheCaptain (developer)
2018-11-25 22:11
edited on: 2018-11-25 22:12

And if the issue is "there is no documentation how to log started server output" or "documentation how to do X is missing", that's a seperate issue too. This ticket is too vague.

User avatar (0020201)
Blzut3 (administrator)
2018-11-25 22:16

The original poster is someone who consistently writes tickets in this manner and is unlikely to ever change. That doesn't mean you can't get useful things out of it, while still keeping him the POC. I fail to see why editing a ticket to clarify the intent differs at all from creating a new one besides the latter wasting everyone's time.

Ugh, whatever. I'd rather have you helping out then fight over this further, especially now that this ticket has been ruined by this fight anyway.
User avatar (0020202)
WubTheCaptain (developer)
2018-11-25 22:31

0003568.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2018-11-25 15:03 Filystea New Issue
2018-11-25 19:06 Blzut3 Relationship added duplicate of 0003446
2018-11-25 19:06 Blzut3 Project Zandronum => Doomseeker
2018-11-25 19:06 Blzut3 Relationship deleted 0003446
2018-11-25 19:10 Blzut3 Note Added: 0020195
2018-11-25 19:11 Blzut3 Summary save the console output when starting from doomseeker => Game logging
2018-11-25 19:11 Blzut3 Additional Information Updated View Revisions
2018-11-25 19:11 Blzut3 Status new => acknowledged
2018-11-25 21:38 WubTheCaptain Priority immediate => low
2018-11-25 21:43 WubTheCaptain Steps to Reproduce Updated View Revisions
2018-11-25 21:48 WubTheCaptain Summary Game logging => Unable to log/redirect stderr/stdout output of servers started from Doomseeker on Windows
2018-11-25 21:55 WubTheCaptain Note Added: 0020196
2018-11-25 21:55 WubTheCaptain Relationship added duplicate of 0003446
2018-11-25 21:55 WubTheCaptain Status acknowledged => resolved
2018-11-25 21:55 WubTheCaptain Resolution open => duplicate
2018-11-25 21:55 WubTheCaptain Assigned To => WubTheCaptain
2018-11-25 21:55 WubTheCaptain Note Edited: 0020196 View Revisions
2018-11-25 22:01 Blzut3 Note Added: 0020197
2018-11-25 22:02 Blzut3 Assigned To WubTheCaptain =>
2018-11-25 22:02 Blzut3 Status resolved => feedback
2018-11-25 22:02 Blzut3 Resolution duplicate => reopened
2018-11-25 22:02 Blzut3 Assigned To => Blzut3
2018-11-25 22:02 Blzut3 Status feedback => acknowledged
2018-11-25 22:02 Blzut3 Assigned To Blzut3 =>
2018-11-25 22:02 Blzut3 Relationship deleted 0003446
2018-11-25 22:04 WubTheCaptain Note Added: 0020198
2018-11-25 22:04 WubTheCaptain Status acknowledged => resolved
2018-11-25 22:04 WubTheCaptain Resolution reopened => invalid
2018-11-25 22:04 WubTheCaptain Assigned To => WubTheCaptain
2018-11-25 22:05 Blzut3 Note Edited: 0020197 View Revisions
2018-11-25 22:07 WubTheCaptain Note Edited: 0020198 View Revisions
2018-11-25 22:08 WubTheCaptain Note Edited: 0020198 View Revisions
2018-11-25 22:11 WubTheCaptain Note Added: 0020199
2018-11-25 22:12 WubTheCaptain Note Edited: 0020199 View Revisions
2018-11-25 22:16 Blzut3 Note Added: 0020201
2018-11-25 22:31 WubTheCaptain Note Added: 0020202
2018-12-04 00:04 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker