Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003223Zandronum[All Projects] Bugpublic2017-08-12 15:272017-08-13 12:10
ReporterFilystea 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutiondenied 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003223: Current downloading maps is a missudnerstanding
DescriptionThere should be a global maps server containing community maps.
That would USE MAP HASH taken from game server to look for a map.
Instead at the moment you get a name lookup and end up with info - sorry your downloaded map is different. Because the hash do not match. If lucky the server it self will provide the download of map ( often it does not ).
Steps To Reproducehue
Additional InformationTired of downloading crap that does not match.
Attached Files

- Relationships

-  Notes
User avatar (0018167)
Dusk (developer)
2017-08-12 18:31

It's up to the community to arrange the servers. The engine has no part in that, in fact Zandronum doesn't even download wads at all.
User avatar (0018168)
Filystea (reporter)
2017-08-12 18:38
edited on: 2017-08-12 18:44

You should provide the software for easy and normal map downloading + a server so anyone can host map repositories and publish ip of such server. One could even host from his own home.

This is fairly easy job but must be done by someone respected by community so there are no doubts. Probably a simple client + server doing fairly good job would take me 1 week to write with my current free time.

Finally if not a zandronum bug than defiantly doomseeker bug.

Provide the client and server. Fix the bug.

+ Server or master server should pass map hash. Tho it seems this is done after connection to the game server.

User avatar (0018169)
Ivan (reporter)
2017-08-12 19:27

Use TSPG services for any kind of wad you want to get. If it's not there upload it there. If it's suspicious it gets removed. Sounds easy enough.
User avatar (0018171)
Filystea (reporter)
2017-08-12 23:08
edited on: 2017-08-12 23:22

This would be ok but TSPG won't go for ever. This should be possible for any one to host a map repository.

Main zandronum bug here is:

https://wiki.zandronum.com/Launcher_protocol [^]

There is no *get map hashes* We only have some fucking map name. hashes should be obtainable.

User avatar (0018173)
Dusk (developer)
2017-08-13 10:09
edited on: 2017-08-13 10:10

If you have the same wads as the server the maps will also match. If they don't then you have a different wad by the same name. This happens if either you change the wad yourself or the wad author publishes different versions of the wad with the same name. The former is your own problem, the second is the community's. If wads aren't versioned properly, confusion will happen in any case and authentication mismatches are just one symptom.

Maintaining an individual maps server would be a silly workaround that wouldn't really solve anything.

The problem with sending map hashes is that the server could have any number of maps loaded. Suppose a server has a mod with wads and uses skulltag_data.pk3. In this case you get the IWAD map hashes, Skulltag map hashes and the mod map hashes from each server that loads these. It would be an incredible spike in bandwidth use in the launcher protocol... to what end? So you can force yourself through the authentication with correct maps but otherwise broken wads?

I also don't understand why do you bother yourself in community matters like this when you're supposed to be banned from it pretty much entirely.

User avatar (0018178)
Filystea (reporter)
2017-08-13 10:57

Give me a break. Like where is that incredible spike either you have names that you need to send anyway or you have instead of name 16 bytes, always.

And the bandwidth is a fairy tale. Not enough zandronumers to have problem on this level.

" I also don't understand why do you bother yourself in community matters like this when you're supposed to be banned from it pretty much entirely."

I just evade the ban, it's not a big problem. With bad proxies not worth to be kept I will even play under my normal nick. Till now normal ( not staff members etc ) players never reported me to your master server admins so they at least block proxy I use. For good ping there are better ways, but any way the point is I am playing sometimes so I will report things that irritate me or I dislike. Also i still work on my mod so this also enforces to report bugs.

This issue here needs to be solved by community this is why I pointed it out. Don't get me wrong I don't give a single shit about the community and after I was banned without stating a reason why ( waited month for answer ?). I will rarely take my time for pleasure in causing shit for some certain garbage people who happen to be main head of the *community*,
User avatar (0018180)
Dusk (developer)
2017-08-13 11:34
edited on: 2017-08-13 12:10

Quote
And the bandwidth is a fairy tale. Not enough zandronumers to have problem on this level.

You're wrong. A lot of players still use dial-up.

It doesn't really matter if you evade and play the game anyway. The point is that you were rejected from the community so your suggestions to the community aren't going to be taken too seriously. But this is about the engine and not the community.

If you don't get past the map authentication that means your wads are different. It would happen at the moment of connection but the server can't know what maps it's going to play. It cannot authenticate all maps loaded because that would break Freedoom support and we don't want that.

I get where you're coming from with the map server idea, but it's not the right way to fix the problem. The problem is that your wads are different and the fix is to get the correct ones. If you're not being served the right wads then that's a problem with the host. The map name is only there for the browser to display to the user so there's a rough idea at what point in the game the server is currently at.

I don't think this is worth an SQF_ flag, because there's no real use case, or the time required to implement this because it wouldn't really benefit anyone. People just need to learn to version their wads properly. Downloading maps individually doesn't make sense because then the rest of the wad isn't included in this system, and we already have a system for that and it's called wad hosting.


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-08-12 15:27 Filystea New Issue
2017-08-12 18:31 Dusk Note Added: 0018167
2017-08-12 18:31 Dusk Status new => closed
2017-08-12 18:31 Dusk Resolution open => out of scope
2017-08-12 18:38 Filystea Note Added: 0018168
2017-08-12 18:38 Filystea Status closed => feedback
2017-08-12 18:38 Filystea Resolution out of scope => reopened
2017-08-12 18:44 Filystea Note Edited: 0018168 View Revisions
2017-08-12 19:27 Ivan Note Added: 0018169
2017-08-12 23:08 Filystea Note Added: 0018171
2017-08-12 23:08 Filystea Status feedback => new
2017-08-12 23:22 Filystea Note Edited: 0018171 View Revisions
2017-08-13 10:09 Dusk Note Added: 0018173
2017-08-13 10:10 Dusk Note Edited: 0018173 View Revisions
2017-08-13 10:57 Filystea Note Added: 0018178
2017-08-13 11:34 Dusk Note Added: 0018180
2017-08-13 11:34 Dusk Status new => closed
2017-08-13 11:34 Dusk Resolution reopened => denied
2017-08-13 12:06 Dusk Note Added: 0018182
2017-08-13 12:08 Dusk Note Edited: 0018180 View Revisions
2017-08-13 12:08 Dusk Note Deleted: 0018182
2017-08-13 12:08 Dusk Note Edited: 0018180 View Revisions
2017-08-13 12:09 Dusk Note Edited: 0018180 View Revisions
2017-08-13 12:10 Dusk Note Edited: 0018180 View Revisions






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker