Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002981Doomseeker[All Projects] Bugpublic2017-01-14 20:182018-09-29 14:24
ReporterFilystea 
Assigned ToZalewa 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version1.0 
Target Version1.1Fixed in Version1.1 
Summary0002981: Doomseeker allows to join the server even if IWAD is missing.
DescriptionSee "Steps to Reproduce".

The expected behavior is to display "WADs are missing" notification and inform the user that Doom should be bought or Freedoom should be installed.
Steps To Reproduce1. Host a server using doom2.wad
2. Run Doomseeker and make sure that it cannot find doom2.wad in its file paths or in Zandronum folder nor that it cannot find Freedoom alias. This can be confirmed by hovering over the IWAD cell in the server table and checking if Doomseeker says MISSING in red font there.
3a. Try to join the server.
3b. Try to retrieve server's command line.
Additional InformationOriginal report: My mate doom2.wad from steam is completly broken.

Each time he connects to my games he does not see most of doom2.wad stuff, invisible vanilia doom monsters, missing textures of map.

If there are such differences why there is no fail on check sum? Should he not get something like "you are using wrong doom version etc?"

I just gave him my pirated doom2.wad that works fine always.
Attached Files

- Relationships

-  Notes
User avatar (0016635)
mifu (reporter)
2017-01-15 04:20

I can say this is false as I use doom2.wad from my steam copy and it works fine. Even if this is not bullshit which I beg to differ, sounds like the iwad got corrupted somehow.
User avatar (0016642)
Filystea (reporter)
2017-01-15 10:59
edited on: 2017-01-15 11:00

It turned out the folder he was pointing at to look for the doom2.wad had no doom2.wad. Only doom.wad.

Funny game still let him inside the server without actually having the doom2.wad.

User avatar (0016643)
Edward-san (reporter)
2017-01-15 11:15
edited on: 2017-01-15 11:15

It can happen only if you also load a wad containing at least a valid map.

User avatar (0016653)
Dusk (reporter)
2017-01-18 16:47

If this managed to happen, then you are connecting manually from command line or in-game console. If you do that, then it's your responsibility to load the correct wads.
User avatar (0016655)
Filystea (reporter)
2017-01-18 19:03
edited on: 2017-01-18 19:21

" If this managed to happen, then you are connecting manually from command line or in-game console. If you do that, then it's your responsibility to load the correct wads. "

He used doomseeker. So this would be doomseeker fault.
Secondly again. The game let him in instead complaining about wrong IWAD version. ( I once hosted on some strange doom2.wad v. and had plenty of peopel rejected ).

Why block bad pwads and not bad iwad?

User avatar (0016656)
Dusk (reporter)
2017-01-18 21:05

Quote

He used doomseeker. So this would be doomseeker fault.

Hmm. Looks like it indeed is... so if the IWAD is not present, but all the pwads are, then the game is launched with the wrong IWAD.

Quote

Secondly again. The game let him in instead complaining about wrong IWAD version. ( I once hosted on some strange doom2.wad v. and had plenty of peopel rejected ).

Why block bad pwads and not bad iwad?

Because ZDoom lets you to play pwads with the iwads that it's not intended to run in, and it doesn't cause a desync (just otherwise weird behavior that also happens offline). Also, determining what's a good IWAD and what is not is non-trivial, because you have things like Freedoom and the BFG edition to factor.
User avatar (0016660)
Zalewa (developer)
2017-01-19 19:26

I have reworded the report so its clear what is the problem. I put the original report into "Additional Information" box. Thanks for bringing this to my attention.
User avatar (0016666)
Zalewa (developer)
2017-01-21 11:17

Fix:https://bitbucket.org/Doomseeker/doomseeker/commits/688f69eb6444a033c664918e86aee9c4660a764f [^]
User avatar (0016793)
Zalewa (developer)
2017-02-06 19:56

Version with fix is on the beta update channel. Please test.
User avatar (0016796)
Filystea (reporter)
2017-02-06 20:13

"beta update channel"

Duno where the download is so unless link given won't test it.
User avatar (0016797)
Kaminsky (reporter)
2017-02-06 20:20
edited on: 2017-02-06 20:21

Under the Auto Updates tab inside Doomseeker's configurations, change the update channel from "Stable" to "Beta" to download beta versions.

User avatar (0016798)
Filystea (reporter)
2017-02-06 20:33

I don't have that or I am blind. lol
User avatar (0016800)
Zalewa (developer)
2017-02-06 20:45

If you're on Linux you will have to compile it yourself. There's no auto-update there as we're releasing through an apt channel and only stable versions go there. Mac builds can be installed through auto-update but you'll have to ask Blzut3 to upload one.
User avatar (0016801)
Filystea (reporter)
2017-02-06 21:18
edited on: 2017-02-06 21:22

Ok I compiled it. I will check later the bug. Thx for help.

And first bug. Entering configuartion causes 100% cpu usage ( well i have multi core crap so less pain since it's only one of few but still this is definatly some bug imho. )

(leaving config panel causes it to stop that insane cpu eater.)

User avatar (0016811)
Filystea (reporter)
2017-02-07 09:58

I tested the new doomseeker on linux. It behaves properly (detecs there is no doom2 wad).

I advice to check that cpu problem I mentioned.
User avatar (0016814)
Zalewa (developer)
2017-02-07 17:38

Busy spin is fixed with this commit:https://bitbucket.org/Doomseeker/doomseeker/commits/f7ae972b3dc71a6ada87ad6c937754c497b1421e [^]

I'm closing this as resolved.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: Argentum mifu

- Issue History
Date Modified Username Field Change
2017-01-14 20:18 Filystea New Issue
2017-01-15 04:20 mifu Note Added: 0016635
2017-01-15 10:59 Filystea Note Added: 0016642
2017-01-15 11:00 Filystea Note Edited: 0016642 View Revisions
2017-01-15 11:15 Edward-san Note Added: 0016643
2017-01-15 11:15 Edward-san Assigned To => Edward-san
2017-01-15 11:15 Edward-san Status new => confirmed
2017-01-15 11:15 Edward-san Assigned To Edward-san =>
2017-01-15 11:15 Edward-san Note Edited: 0016643 View Revisions
2017-01-18 16:47 Dusk Note Added: 0016653
2017-01-18 16:47 Dusk Status confirmed => closed
2017-01-18 16:47 Dusk Resolution open => no change required
2017-01-18 19:03 Filystea Note Added: 0016655
2017-01-18 19:03 Filystea Status closed => feedback
2017-01-18 19:03 Filystea Resolution no change required => reopened
2017-01-18 19:21 Filystea Note Edited: 0016655 View Revisions
2017-01-18 21:05 Dusk Note Added: 0016656
2017-01-18 21:06 Dusk Status feedback => confirmed
2017-01-18 21:06 Dusk Product Version 3.0-beta =>
2017-01-18 21:06 Dusk Project Zandronum => Doomseeker
2017-01-19 19:22 Zalewa Assigned To => Zalewa
2017-01-19 19:22 Zalewa Status confirmed => assigned
2017-01-19 19:26 Zalewa Note Added: 0016660
2017-01-19 19:26 Zalewa Product Version => 1.0
2017-01-19 19:26 Zalewa Target Version => 1.1
2017-01-19 19:26 Zalewa Summary My mate doom2.wad from steam is completly broken. => Doomseeker allows to join the server even if IWAD is missing.
2017-01-19 19:26 Zalewa Description Updated View Revisions
2017-01-19 19:26 Zalewa Steps to Reproduce Updated View Revisions
2017-01-19 19:26 Zalewa Additional Information Updated View Revisions
2017-01-21 11:17 Zalewa Note Added: 0016666
2017-01-21 11:17 Zalewa Status assigned => needs review
2017-02-06 19:56 Zalewa Note Added: 0016793
2017-02-06 19:56 Zalewa Status needs review => needs testing
2017-02-06 20:13 Filystea Note Added: 0016796
2017-02-06 20:20 Kaminsky Note Added: 0016797
2017-02-06 20:21 Kaminsky Note Edited: 0016797 View Revisions
2017-02-06 20:33 Filystea Note Added: 0016798
2017-02-06 20:45 Zalewa Note Added: 0016800
2017-02-06 21:18 Filystea Note Added: 0016801
2017-02-06 21:20 Filystea Note Edited: 0016801 View Revisions
2017-02-06 21:20 Filystea Note Edited: 0016801 View Revisions
2017-02-06 21:22 Filystea Note Edited: 0016801 View Revisions
2017-02-07 09:58 Filystea Note Added: 0016811
2017-02-07 17:38 Zalewa Note Added: 0016814
2017-02-07 17:38 Zalewa Status needs testing => resolved
2017-02-07 17:38 Zalewa Fixed in Version => 1.1
2017-02-07 17:38 Zalewa Resolution reopened => fixed
2018-09-29 14:24 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker