Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003631Zandronum[All Projects] Epicpublic2019-04-16 14:512019-04-26 10:53
ReporterFilystea 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003631: Again somethign COMPLETLY BASIC IS BROKEN
Description    AM14 I 3 A_CustomRailgun( random( 15, 40 ), 0, "", "gold")
I should get no ring. with ""
Vide zdoom wiki:

ringcolor: The color of the particles that form the spiral "ring" of the beam. You can use "" to have no ring. The string can be a color defined in the X11R6RGB lump. If the string is invalid, the particles will be black.

I get BLUE RING!!!!!! DEFAULT BEHAVIOR !!!!! This is on offline gameplay.
Steps To ReproducePut in your monster

3 A_CustomRailgun( random( 15, 40 ), 0, "", "gold")
Additional InformationSick of how nothing ever gets tested here.
Attached Files? file icon railfail.pk3 [^] (507 bytes) 2019-04-24 16:04

- Relationships

-  Notes
User avatar (0020495)
Filystea (reporter)
2019-04-16 15:50

NONE fixes it but this still is broken according to wiki
User avatar (0020534)
Edward-san (developer)
2019-04-23 18:47
edited on: 2019-04-23 18:49

1) Was this broken also in previous versions of Zandronum?
2) What about GZDoom 1.8.6?
3) Please provide a test wad, we cannot check otherwise.

User avatar (0020535)
Filystea (reporter)
2019-04-23 20:36

1) Was this broken also in previous versions of Zandronum?

Which versions, source or binary must be provided.
User avatar (0020536)
Edward-san (developer)
2019-04-23 20:55

Quote

Which versions, source or binary must be provided.


Zandronum 2.1.2 is good enough.
User avatar (0020545)
Filystea (reporter)
2019-04-24 16:03
edited on: 2019-04-24 16:44

1) Same happens in 2.1.2
2) Same happens in 1.8.6
3) Wad example provided

User avatar (0020548)
Edward-san (developer)
2019-04-24 22:49
edited on: 2019-04-24 22:51

After discussing with ZDoom forum members, the wiki has been amended. For Decorate, "none" is the correct argument. Not a bug, I'd say.

User avatar (0020549)
Filystea (reporter)
2019-04-25 15:50

Ok, now it's legit. Thx for your duty. Lock this up.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2019-04-16 14:51 Filystea New Issue
2019-04-16 15:50 Filystea Note Added: 0020495
2019-04-23 18:47 Edward-san Note Added: 0020534
2019-04-23 18:47 Edward-san Status new => feedback
2019-04-23 18:49 Edward-san Note Edited: 0020534 View Revisions
2019-04-23 20:36 Filystea Note Added: 0020535
2019-04-23 20:36 Filystea Status feedback => new
2019-04-23 20:55 Edward-san Note Added: 0020536
2019-04-23 20:55 Edward-san Status new => feedback
2019-04-24 16:03 Filystea Note Added: 0020545
2019-04-24 16:03 Filystea Status feedback => new
2019-04-24 16:04 Filystea File Added: railfail.pk3
2019-04-24 16:44 Filystea Note Edited: 0020545 View Revisions
2019-04-24 22:49 Edward-san Note Added: 0020548
2019-04-24 22:51 Edward-san Note Edited: 0020548 View Revisions
2019-04-25 15:50 Filystea Note Added: 0020549
2019-04-26 10:53 Edward-san Status new => closed
2019-04-26 10:53 Edward-san Resolution open => no change required






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker