Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003965Doomseeker[All Projects] Documentationpublic2021-12-30 11:512021-12-30 23:32
ReporterWubTheCaptain 
Assigned ToWubTheCaptain 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionwon't fix 
PlatformOSOS Version
Product Version1.3.2 
Target VersionFixed in Version 
Summary0003965: Ubuntu 16.04 LTS support is missing a deprecation notice
Description0003824:0021716:
Quote from Blzut3
Given that we only really support Ubuntu 18.04+ and similar era distributions at this point (per policy of following Canonical's free support period)

End of Standard Support for 16.04 LTS was April 2021.
Steps To ReproduceCHANGELOG.md
Attached Filespatch file icon 0001-Document-deprecation-of-Ubuntu-16.04-LTS-support.patch [^] (1,449 bytes) 2021-12-30 12:06 [Show Content]
patch file icon v2-0001-Document-deprecation-of-Ubuntu-16.04-LTS-support.patch [^] (1,759 bytes) 2021-12-30 13:06 [Show Content]

- Relationships
child of 0003899resolvedBlzut3 Dockerfile uses Ubuntu 16.04 (which we don't support) 
child of 0003895needs testingBlzut3 Add support for Qt 6.2+ 

-  Notes
User avatar (0022054)
WubTheCaptain (developer)
2021-12-30 12:10

After I wrote this patch, I found out Canonical extended its extended security support until April 2026.
https://ubuntu.com/blog/ubuntu-14-04-and-16-04-lifecycle-extended-to-ten-years [^]
The standard support period has not been extended. The quote in the OP is from before the announcement by Canonical.
User avatar (0022056)
Zalewa (developer)
2021-12-30 12:26

I think this just adds noise to the changelog. Are we gonna mention all distros and their versions from now on? Ubuntu 16.04 ended, and Ubuntu 20.04 is the Ubuntu now (soon to be Ubuntu 22.04). By default all software should not support Ubuntu 16 anymore.
User avatar (0022060)
WubTheCaptain (developer)
2021-12-30 12:46

I've mainly done this due to the Dockerfile distributed with Doomseeker 1.3.2, but I don't oppose resolving this one as "won't fix" or "no change required" if you want.
User avatar (0022061)
WubTheCaptain (developer)
2021-12-30 12:57

Seeing 0003964 got merged, alternatively I could change the changelog entry from "Windows XP" to "Windows XP and Ubuntu 16.04 LTS".
User avatar (0022062)
WubTheCaptain (developer)
2021-12-30 13:06

Patch v2 available.
User avatar (0022064)
Blzut3 (administrator)
2021-12-30 22:13

Zalewa is right in that documenting drops of Ubuntu versions is pretty much just noise. The deb packages are built according to the DRD Team repo policy (which is to use the oldest supported LTS), so unsupported versions being dropped is implied by policy. What could make sense to document is bump of minimum supported Qt and compiler versions. The place to do this is COMPILE.txt although it probably wouldn't hurt to have a changelog entry as well. If we're recommending building with Qt 5.9+ (or experimentally Qt 6.2+), glibc 2.27+, and GCC 7+ then by definition full support of any distro based on older dependencies is at discretion.
User avatar (0022066)
WubTheCaptain (developer)
2021-12-30 23:31

Sounds good, although putting up deprecation notices for any of those dependencies is out of scope for this issue.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2021-12-30 11:51 WubTheCaptain New Issue
2021-12-30 11:51 WubTheCaptain Relationship added child of 0003899
2021-12-30 11:56 WubTheCaptain Assigned To => WubTheCaptain
2021-12-30 11:56 WubTheCaptain Status new => assigned
2021-12-30 12:06 WubTheCaptain File Added: 0001-Document-deprecation-of-Ubuntu-16.04-LTS-support.patch
2021-12-30 12:06 WubTheCaptain Target Version => 1.3.3
2021-12-30 12:06 WubTheCaptain Assigned To WubTheCaptain =>
2021-12-30 12:06 WubTheCaptain Status assigned => needs review
2021-12-30 12:10 WubTheCaptain Note Added: 0022054
2021-12-30 12:13 WubTheCaptain Relationship added child of 0003895
2021-12-30 12:26 Zalewa Note Added: 0022056
2021-12-30 12:46 WubTheCaptain Note Added: 0022060
2021-12-30 12:57 WubTheCaptain Note Added: 0022061
2021-12-30 13:06 WubTheCaptain File Added: v2-0001-Document-deprecation-of-Ubuntu-16.04-LTS-support.patch
2021-12-30 13:06 WubTheCaptain Note Added: 0022062
2021-12-30 22:13 Blzut3 Note Added: 0022064
2021-12-30 23:31 WubTheCaptain Note Added: 0022066
2021-12-30 23:31 WubTheCaptain Status needs review => resolved
2021-12-30 23:31 WubTheCaptain Resolution open => won't fix
2021-12-30 23:31 WubTheCaptain Assigned To => WubTheCaptain
2021-12-30 23:32 WubTheCaptain Target Version 1.3.3 =>
2021-12-30 23:32 WubTheCaptain Resolution won't fix => no change required
2021-12-30 23:32 WubTheCaptain Resolution no change required => won't fix






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2022 MantisBT Team
Powered by Mantis Bugtracker