Zandronum Chat on our Discord Server Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003895Doomseeker[All Projects] Epicpublic2021-08-08 21:402021-08-16 18:47
ReporterBlzut3 
Assigned ToBlzut3 
PrioritynormalSeverityfeatureReproducibilityN/A
Statusneeds testingResolutionopen 
PlatformOSOS Version
Product Version1.3.2 
Target Version1.4Fixed in Version 
Summary0003895: Add support for Qt 6.2+
DescriptionThe upcoming Qt 6.2 appears to include all the components that we need to support Qt 6.

Qt 5 will need to continue to be supported as popular Linux distros have yet to pick up packaging of Qt 6. At this time this means at least until the EOL of Ubuntu 20.04 in 2025, but it seems very likely that Qt 6's support in 22.04 may not be in good shape. It is likely we'd be looking at 2027 at the earliest for dropping Qt 5.
Attached Files

- Relationships
parent of 0003896needs testingBlzut3 Replace use of QRegExp with QRegularExpression 
parent of 0003824needs reviewBlzut3 No AUTOUIC, qt5_wrap_ui() macro is used 
parent of 0003821needs testingBlzut3 Replacing Eili Reilin's JSON library (qt-json) with JSON support in Qt 
parent of 0003897assignedBlzut3 QDirModel cannot be used to build with Qt 6 (needs to be replaced with QFileSystemModel) 
parent of 0003898needs testingBlzut3 QSound is no longer supported in Qt 6 Multimedia 
Not all the children of this issue are yet resolved or closed.

-  Notes
User avatar (0021727)
Blzut3 (administrator)
2021-08-15 03:21

Should be able to compile Doomseeker against Qt 6.2 now.

The core of 0003897 remains an issue and will result in completion suggestions on paths not working.

It appears that the way that we write settings makes migrating from a Qt 6 build back to a Qt 5 build not work. Can't imagine there's a whole lot we can do about that, and should be mostly irrelevant anyway.

At this point though I only assert that Doomseeker compiles and the binary runs. There are probably a number of bugs to be discovered.
User avatar (0021731)
WubTheCaptain (developer)
2021-08-16 18:47

Adjusting product version to 1.3.2, as it is the latest stable release affected by this issue (Qt6 isn't supported in 1.3.x series).

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2021-08-08 21:40 Blzut3 New Issue
2021-08-08 21:40 Blzut3 Status new => assigned
2021-08-08 21:40 Blzut3 Assigned To => Blzut3
2021-08-08 21:46 Blzut3 Relationship added parent of 0003896
2021-08-08 21:49 Blzut3 Relationship added parent of 0003824
2021-08-08 21:53 Blzut3 Relationship added parent of 0003821
2021-08-08 22:02 Blzut3 Relationship added parent of 0003897
2021-08-08 22:11 Blzut3 Relationship added parent of 0003898
2021-08-15 03:21 Blzut3 Note Added: 0021727
2021-08-15 03:21 Blzut3 Status assigned => needs testing
2021-08-16 18:47 WubTheCaptain Note Added: 0021731
2021-08-16 18:47 WubTheCaptain Product Version 1.4 => 1.3.2






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker