Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004000Doomseeker[All Projects] Bugpublic2022-05-18 15:562022-05-31 01:41
ReporterOceanboy06 
Assigned ToWubTheCaptain 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutioninvalid 
PlatformMicrosoftOSWindowsOS Version10
Product Version1.3.3 
Target VersionFixed in Version 
Summary0004000: Master Server Connections Timing Out
DescriptionEvery Master Server Connection I Try Keeps Timing Out for Some Reason.
Steps To Reproduce1. Launch Doomseeker
2. Try to Let it Connect to the Master Server
3. ???
Attached Filespatch file icon 0001-udpsocketpool-Always-bind-to-host-0.0.0.0.patch [^] (759 bytes) 2022-05-20 09:52 [Show Content]

- Relationships

-  Notes
User avatar (0022220)
WubTheCaptain (developer)
2022-05-19 10:52

I don't experience this issue on Debian GNU/Linux, and unfortunately there's not enough detail/logs in your original report about your environment to reproduce your issue.
  • Which game(s) for the master server connection are affected?
  • Is this Doomseeker in its default configuration? (Master server addresses set in configuration.)

If this issue is about Sonic Robo Blast 2, that upstream stopped maintaining their master server compatibility (0003958).
Unfortunately, I don't know how to guide you to post the standard output logs ("Starting Doomseeker. Hello World! :)") on Windows at this time.
User avatar (0022221)
WubTheCaptain (developer)
2022-05-19 10:57

Quote from WubTheCaptain
Unfortunately, I don't know how to guide you to post the standard output logs ("Starting Doomseeker. Hello World! :)") on Windows at this time.

View → Log (Ctrl + L) works in the graphical user interface.
User avatar (0022222)
Oceanboy06 (reporter)
2022-05-19 20:20

[13:17:48] Starting Doomseeker. Hello World! :)
[13:17:48] Setting up data directories.
[13:17:48] Cache directory: *Censored*/AppData/Local/doomseeker/cache
[13:17:48] Config directory: *Censored*/AppData/Local/doomseeker
[13:17:48] Data directory: *Censored*/AppData/Local/doomseeker
[13:17:48] Loading extra CA certificates from '*Censored*/cacerts.pem'.
[13:17:48] Appending 2 extra CA certificate(s).
[13:17:48] Attempting to load plugins from directory: *Censored*/engines
[13:17:48] Loaded plugin: "Chocolate Doom"!
[13:17:48] Loaded plugin: "Odamex"!
[13:17:48] Loaded plugin: "Sonic Robo Blast 2"!
[13:17:48] Loaded plugin: "Turok 2 Remaster"!
[13:17:48] Loaded plugin: "Zandronum"!
[13:17:48] Listening to Zandronum's LAN servers broadcasts on port 15101.
[13:17:48] Loaded plugin: "Q-Zandronum"!
[13:17:48] Listening to Q-Zandronum's LAN servers broadcasts on port 15102.
[13:17:48] Initializing configuration file.
[13:17:48] Setting INI file: *Censored*/AppData/Local/doomseeker/doomseeker.ini
[13:17:48] Loading translations definitions
[13:17:48] Reading localizations definitions file: translations.def
[13:17:48] Loading translation "system".
[13:17:48] Translation loaded.
[13:17:48] Initializing IP2C database.
[13:17:48] Initializing passwords configuration file.
[13:17:48] Initializing configuration for plugins.
[13:17:48] Initializing IRC configuration file.
[13:17:48] Setting IRC INI file: *Censored*/AppData/Local/doomseeker/doomseeker-irc.ini
[13:17:48] Starting refreshing thread.
[13:17:48] Preparing GUI.
[13:17:49] Checking if IP2C database at '*Censored*/AppData/Local/doomseeker/IpToCountry.dat' needs updating.
[13:17:49] Please wait. IP2C database is being read. This may take some time.
[13:17:49] Init finished.
================================
[13:17:49] Parsing IP2C database: *Censored*/AppData/Local/doomseeker/IpToCountry.dat
[13:17:49] Total refresh initialized!
[13:17:49] Removing old update packages from local temporary space.
[13:17:49] Checking for updates...
[13:17:49] IP2C database read in 78 ms; IP ranges: 196041
[13:17:49] IP2C parsing thread has finished.
[13:17:49] IP2C parsing finished.
[13:17:49] Comparing IP2C hashes: local = aeca013c6eb838531099b9727f2187a0, remote = aeca013c6eb838531099b9727f2187a0
[13:17:49] IP2C update not needed.
[13:17:49] No new program updates detected.
[13:17:49] Program update detection & download finished with status: [0] Ok
[13:17:59] Error: Master server for Zandronum: Connection timeout (45.56.67.39:15300).
[13:17:59] Reloading master server results from cache for Zandronum!
[13:17:59] Error: Master server for Q-Zandronum: Connection timeout (70.35.196.63:15300).
User avatar (0022223)
Zalewa (developer)
2022-05-19 21:43

It looks like something is blocking the UDP packets that communicate with the master servers, because the other connections that happen over HTTP work fine. The cause may be your anti-virus, firewall, router or the ISP. This is either a problem where the UDP packets never leave your computer/network, or they leave it but the incoming reply packets never reach your computer back.

It's difficult for me to guess where the packets may be getting blocked in your case, but maybe you can try temporarily disabling the anti-virus or maybe you recall changing something in the settings of the things I mentioned above?

You could also try checking if the problem is limited only to the master servers and if you can talk to servers directly, for example by trying to add this Zandronum server to the pinned servers: 88.198.7.58:10675. (Options -> Configure -> Pinned servers -> Select Zandronum -> Add -> double-click host and port and edit -> OK). Check if the server appears properly on the list as "[EB] Zombie Horde".
User avatar (0022224)
WubTheCaptain (developer)
2022-05-20 09:40

Zalewa: This issue looks like 0003494.
User avatar (0022225)
WubTheCaptain (developer)
2022-05-20 09:56

The attached patch 0001-udpsocketpool-Always-bind-to-host-0.0.0.0.patch is experimental. Please try it. It works on my Debian GNU/Linux machine. Zalewa, does it work for you on Windows?
Possibly the easiest for OP if Zalewa could publish a beta release binary (.exe) with that patch for OP, unless OP is also capable of compiling from source with the patch applied.
User avatar (0022226)
WubTheCaptain (developer)
2022-05-20 10:00

Also be mindful of 0003654 with the attached patch. I did not test for that one.
User avatar (0022227)
WubTheCaptain (developer)
2022-05-20 10:09

Note: The patch partially reverts commit 739b6821c25243ec401f1f0bcadd1b6e8bb40bc3. I would've reverted it outright with git revert, but it had two distinct changes squashed into one commit.
User avatar (0022228)
Oceanboy06 (reporter)
2022-05-20 14:31

Wait, Zalewa!? you're Thinking that it's the Same Issue as that RTC Connecting Error I Just Can't Fix on Discord!?
User avatar (0022229)
Zalewa (developer)
2022-05-20 20:08

@Wub I doubt that this issue is related to socket->bind(); It's more probable and apparent that the OP has networking issues.

@Oceanboy06 Well, I don't know the specifics of WebRTC but from what I see this protocol also relies on UDP. So if your Discord has problems with RTC then it's indicative that you may have a broader problem with UDP in general. If you don't mind setting up a remote desktop through TeamViewer I can take a look at your computer, just catch me on Discord: robikz#9390. I can't promise anything tho.
User avatar (0022230)
WubTheCaptain (developer)
2022-05-21 06:21

Resolving as invalid per OP's WebRTC issues: This ticket is unlikely to be a bug in Doomseeker, but seems like a support request.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2022-05-18 15:56 Oceanboy06 New Issue
2022-05-19 10:52 WubTheCaptain Note Added: 0022220
2022-05-19 10:52 WubTheCaptain Assigned To => WubTheCaptain
2022-05-19 10:52 WubTheCaptain Status new => feedback
2022-05-19 10:57 WubTheCaptain Note Added: 0022221
2022-05-19 20:20 Oceanboy06 Note Added: 0022222
2022-05-19 20:20 Oceanboy06 Status feedback => assigned
2022-05-19 21:43 Zalewa Note Added: 0022223
2022-05-20 09:40 WubTheCaptain Note Added: 0022224
2022-05-20 09:52 WubTheCaptain File Added: 0001-udpsocketpool-Always-bind-to-host-0.0.0.0.patch
2022-05-20 09:56 WubTheCaptain Note Added: 0022225
2022-05-20 09:56 WubTheCaptain Assigned To WubTheCaptain => Zalewa
2022-05-20 09:56 WubTheCaptain Status assigned => needs review
2022-05-20 10:00 WubTheCaptain Note Added: 0022226
2022-05-20 10:09 WubTheCaptain Note Added: 0022227
2022-05-20 14:31 Oceanboy06 Note Added: 0022228
2022-05-20 20:08 Zalewa Note Added: 0022229
2022-05-21 06:21 WubTheCaptain Note Added: 0022230
2022-05-21 06:21 WubTheCaptain Status needs review => resolved
2022-05-21 06:21 WubTheCaptain Resolution open => invalid
2022-05-21 06:22 WubTheCaptain Assigned To Zalewa => WubTheCaptain
2022-05-31 01:41 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2022 MantisBT Team
Powered by Mantis Bugtracker