Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003654Doomseeker[All Projects] Bugpublic2019-06-02 10:122019-07-30 10:13
ReporterPol M 
Assigned ToPol M 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSArchOS Versionx86-64
Product Version1.3 
Target Version1.3Fixed in Version1.3 
Summary0003654: LAN servers no longer works after OpenBSD hacky fix.
DescriptionSince commit a93587f, Doomseeker is not capable of receiving LAN servers. This may have something to do with local servers being interpreted as ipv6 servers.
Steps To ReproduceCreate a local server. Use Doomseeker compiled with any commit after a93587f, it won't work. Use a previous commit, it will.
Attached Files

- Relationships
related to 0003494closedPol M Master server connections timeout on OpenBSD (UDP packets not sent on Qt5) 
child of 0003499assignedPol M Port Doomseeker to OpenBSD 

-  Notes
User avatar (0020711)
Pol M (developer)
2019-06-02 13:00
edited on: 2019-06-02 15:07

Okay, I've been tinkering with this and I'm having trouble having something that works universally, and considering that there doesn't seem to be a way to compile Zandronum on OpenBSD (please correct me if I'm wrong) the simplest solution seems to be to roll back the implementation on the rest of platforms. If one day OpenBSD gets support for Zandronum, then local servers may not work (can't test, only Zandronum seems to have LAN servers detection).

PR I've also taken the opportunity to address the srb2 crash again.

User avatar (0020735)
Zalewa (developer)
2019-06-09 19:20

PR merged here:https://bitbucket.org/Doomseeker/doomseeker/commits/ae456aac888cb794ea3292f7f99cb87d6b22a555 [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: WubTheCaptain
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-06-02 10:12 Pol M New Issue
2019-06-02 10:12 Pol M Status new => assigned
2019-06-02 10:12 Pol M Assigned To => Pol M
2019-06-02 11:01 WubTheCaptain Relationship added related to 0003494
2019-06-02 11:02 WubTheCaptain Severity minor => major
2019-06-02 11:05 WubTheCaptain Priority normal => high
2019-06-02 12:37 Pol M Relationship added child of 0003499
2019-06-02 13:00 Pol M Note Added: 0020711
2019-06-02 15:07 Pol M Note Edited: 0020711 View Revisions
2019-06-02 15:07 Pol M Note Edited: 0020711 View Revisions
2019-06-02 15:07 Pol M Status assigned => needs review
2019-06-09 19:20 Zalewa Note Added: 0020735
2019-06-09 19:20 Zalewa Status needs review => needs testing
2019-07-20 01:18 Pol M Status needs testing => resolved
2019-07-20 01:18 Pol M Fixed in Version => 1.3
2019-07-20 01:18 Pol M Resolution open => fixed
2019-07-30 10:13 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker