Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003953DoomseekerUIpublic2021-12-21 13:432021-12-30 15:41
ReporterZalewa 
Assigned ToZalewa 
PrioritynormalSeveritytweakReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.3.2 
Target Version1.3.3Fixed in Version1.3.3 
Summary0003953: "Wadseeker - General" config page exists while "Wadseeker" is empty
DescriptionThe "File Paths" config node has both the "WAD Aliases" subnode and its own config page.

The "Wadseeker" config node only has 4 subnodes, one of them being "General". We could move the "General" page directly into the "Wadseeker" node and remove the "General" subnode.

Note that there is also the "Games" node which has subnodes for plugins and which doesn't have its own page because there's nothing to display on that page. Therefore if the "Wadseeker - General" page were to be moved, then "Games" would be the only node that behaves differently than the others.
Additional InformationThis is trivial to do, but makes something disappear from the GUI which can be surprising to the end-user.
Attached Filesjpg file icon wadseeker-general-move.jpg [^] (71,863 bytes) 2021-12-21 13:43


patch file icon 0001-CHANGELOG-Document-changes-to-config-nodes.patch [^] (1,012 bytes) 2021-12-30 12:37 [Show Content]

- Relationships

-  Notes
User avatar (0021964)
Zalewa (developer)
2021-12-21 13:43

Yay or nay?
User avatar (0021966)
WaTaKiD (updater)
2021-12-21 16:20

for my personal use, im indifferent, but wut u say does make sense

as for the games node, im also indifferent, but ideas:
should it just be the games node and the window to the right have all plugins listed together, and scroll if needed?
would each game get a tab to switch to?
would there be a dropdown to select the game?
User avatar (0021968)
Zalewa (developer)
2021-12-21 19:31

Quote from WaTaKiD
as for the games node

The current subnodes hierarchy works well there and I wouldn't change it.

Quote from WaTaKiD
should it just be the games node and the window to the right have all plugins listed together, and scroll if needed?

No, that would be a mish-mash. Everything glued together. It's also best to avoid having a scrollbar if you can avoid it.

Quote from WaTaKiD

would each game get a tab to switch to?

This works only for a limited amount of games. When you have 6 and they have such long names, it stops working.

Quote from WaTaKiD
would there be a dropdown to select the game?

That could work, but it's a poorer substitute to what there is there now.

If I would use the general "Games" page for something, it would be to completely disable specific plugins. Right now it's possible to disable the querying of master servers for all the plugins, but all the interface for this plugin is still there. The user can only get rid of that by deleting the plugin's DLL altogether. However, "Games" is a separate matter for a different ticket.
User avatar (0022022)
Zalewa (developer)
2021-12-27 23:54

I just went ahead and did it:https://bitbucket.org/Doomseeker/doomseeker/commits/7a19e49936a113a076727048c1d2f820ae98d5b1 [^]

The problem with clicking on "Games" that was doing nothing was resolved so that clicking on "Games" hides the current page and displays an empty one.
User avatar (0022055)
WubTheCaptain (developer)
2021-12-30 12:23

I'm okay with this. Works for me. Seems like an improvement in my usability testing.
User avatar (0022058)
WubTheCaptain (developer)
2021-12-30 12:37

I added a changelog patch.
User avatar (0022059)
WubTheCaptain (developer)
2021-12-30 12:41

Would be kind of cool to checkout a new branch off from 7a19e49936a113a076727048c1d2f820ae98d5b1, apply this patch to it, then create a visible merge commit to master so it creates a reference in git log to the previous. My patch has been rebased to the origin/master HEAD, however.
User avatar (0022063)
Zalewa (developer)
2021-12-30 15:41

Changelog patch added:https://bitbucket.org/Doomseeker/doomseeker/commits/76ad12dd1b246ffb692022911dce18253c3c5750 [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Zalewa
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2021-12-21 13:43 Zalewa New Issue
2021-12-21 13:43 Zalewa File Added: wadseeker-general-move.jpg
2021-12-21 13:43 Zalewa Note Added: 0021964
2021-12-21 16:20 WaTaKiD Note Added: 0021966
2021-12-21 19:31 Zalewa Note Added: 0021968
2021-12-22 04:22 WubTheCaptain Status new => acknowledged
2021-12-27 22:58 Zalewa Target Version => 1.3.3
2021-12-27 23:54 Zalewa Note Added: 0022022
2021-12-27 23:54 Zalewa Assigned To => Zalewa
2021-12-27 23:54 Zalewa Status acknowledged => needs review
2021-12-30 12:23 WubTheCaptain Note Added: 0022055
2021-12-30 12:23 WubTheCaptain Status needs review => resolved
2021-12-30 12:23 WubTheCaptain Fixed in Version => 1.3.3
2021-12-30 12:23 WubTheCaptain Resolution open => fixed
2021-12-30 12:28 WubTheCaptain Assigned To Zalewa => WubTheCaptain
2021-12-30 12:28 WubTheCaptain Status resolved => assigned
2021-12-30 12:28 WubTheCaptain Resolution fixed => reopened
2021-12-30 12:37 WubTheCaptain File Added: 0001-CHANGELOG-Document-changes-to-config-nodes.patch
2021-12-30 12:37 WubTheCaptain Note Added: 0022058
2021-12-30 12:37 WubTheCaptain Assigned To WubTheCaptain => Zalewa
2021-12-30 12:37 WubTheCaptain Status assigned => needs review
2021-12-30 12:38 WubTheCaptain Fixed in Version 1.3.3 =>
2021-12-30 12:41 WubTheCaptain Note Added: 0022059
2021-12-30 15:41 Zalewa Note Added: 0022063
2021-12-30 15:41 Zalewa Status needs review => resolved
2021-12-30 15:41 Zalewa Fixed in Version => 1.3.3
2021-12-30 15:41 Zalewa Resolution reopened => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2022 MantisBT Team
Powered by Mantis Bugtracker