Zandronum Chat on our Discord Server Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003866Doomseeker[All Projects] Suggestionpublic2020-11-10 18:002021-08-17 06:30
ReporterZalewa 
Assigned ToZalewa 
PrioritynoneSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3.1 
Target Version1.3.2Fixed in Version1.3.2 
Summary0003866: Add Q-Zandronum plugin
DescriptionQ-Zandronum is a Zandronum fork made and tailored specifically for the Quake Champions: Doom Edition mod. This fork uses a separate master server. Its team member, geNia, desires to have a plugin for Doomseeker for this fork.

Quote from "geNia"

We at QC:DE mod team have been working on a Zandronum fork called Q-Zandronum for the last two months. The goal for the fork is to improve QC:DE gameplay by adding Quake style movement and improve the netcode. However, that makes it incompatible with vanilla Zandronum, so we would like to separate Q-Zandronum servers in Doomseeker to not confuse people.
I think we need to make a new Doomseeker plugin [...]


The plugin has already been made, but hasn't been checked or even reviewed, yet. I'm attaching it as a patch file to this ticket.
Additional InformationI am unable to find any information about this fork online. Google returns nothing on "Q-Zandronum". There are no projects in geNia's profile on OSDN (https://osdn.net/users/genia/).
Attached Filespatch file icon 0001-Add-Q-Zandronum-plugin.patch [^] (1,032,106 bytes) 2020-11-10 18:00

- Relationships
related to 0003838new In Create Game, "Flags" tab does not have a disabled state; the tab either exists, or it doesn't – inconsistency 

-  Notes
User avatar (0021559)
geNia (reporter)
2020-11-10 18:31

> I am unable to find any information about this fork online. Google returns nothing on "Q-Zandronum". There are no projects in geNia's profile on OSDN (https://osdn.net/users/genia/).

That is because most of the discussion was happening in QC:DE Discord server.
Anyway, you can find the source code athttps://github.com/IgeNiaI/Q-Zandronum [^]
User avatar (0021560)
Pol M (developer)
2020-11-11 22:24

That's nice to see! I'll review it as soon as possible and check that everything is OK and works on Windows/Linux. I have been lurking on your discord for a while, but haven't had the courage to join any server :P (I wish I was at least as good at playing shooters as I am programming, aka competent enough XD). On the discussion on how this should be distributed (Whether this should be merged into doomseeker's repo, or hosted, compiled and distributed separately) I'm not going to say anything as I don't know what would be best.
User avatar (0021561)
WubTheCaptain (developer)
2020-11-14 02:54

Though I'm not a maintainer of Doomseeker, I would have no interest to maintain this in Doomseeker's repository unless every change for this plugin could be pulled from a remote Git repository for updates between releases. That would assume Q-Zandronum maintains and hosts its own plugin source.
User avatar (0021562)
geNia (reporter)
2020-11-14 03:34

I also think that there is no need to add this to official Doomseeker repo. At least not at this moment, because Q-Zandronum is new and doesn't have many players.
User avatar (0021563)
Pol M (developer)
2020-11-14 15:47
edited on: 2020-11-14 15:49

Ok! It seems like you guys basically did a rename of most files, I like the zandronumq name to disambiguate the Q of Qt! Some small notes though:
- You have kept the IRC url, which is a service that you do not have. You probably should disable that.
- You have kept the code for the betas of zandronum, which I think you maybe do not provide. If you do provide them, I haven't said anything! But you still would have to change the url because qzandronum.com/downloads/testing/ does not seem to contain that much info.
- There are some extra urls tohttps://qzandronum.com/ [^] which would need to be changed (either the context of the sentence or whatever you would prefer!) like "You may contact Q-Zandronum staff about this through "
        "IRC: irc.qzandronum.com #zandronumq or on "
        "the forum: <a href=\"https://qzandronum.com/forum\">https://qzandronum.com/forum.</a>"

Apart from such minor things, it works as expected :)

User avatar (0021564)
geNia (reporter)
2020-11-15 02:41

I pushed new commits and created a pull request athttps://bitbucket.org/Doomseeker/doomseeker/pull-requests/3/add-q-zandronum-plugin. [^] Please review the changes there.

I think it is pretty much done, except that translation files are pointing at wrong lines because I removed a lot of code (mostly Zandronum 2 support). Also I need to create a new icon for the plugin.
User avatar (0021567)
Zalewa (developer)
2020-11-23 18:19

I have merged the PR. I realize that the plugin in its current form mostly just duplicates the already existing Zandronum plugin but I assume that this is a faux-duplication and the plugins will soon diverge. The plugin still needs to be added to the auto-update system (hint hint: tools\updateinstaller\tools\win32-configs) and then propagated to the users somehow.
User avatar (0021707)
WubTheCaptain (developer)
2021-08-10 05:47

$ apt show doomseeker-zandronumq
Package: doomseeker-zandronumq
Version: 2
Priority: optional
Section: devel
Maintainer: Doomseeker Team <admin@maniacsvault.net>
Installed-Size: 744 kB
Depends: doomseeker, libc6 (>= 2.14), libgcc1 (>= 1:3.0), libqt5core5a (>= 5.9.0~beta), libqt5gui5 
(>= 5.0.2), libqt5network5 (>= 5.0.2), libqt5widgets5 (>= 5.2.0~alpha1), libstdc++6 (>= 4.1.1)

Homepage:https://doomseeker.drdteam.org [^]
Download-Size: 152 kB
APT-Sources:http://debian.drdteam.org [^] stable/multiverse amd64 Packages
Description: Doomseeker plugin providing support for zandronumq.
  Provides Doomseeker with an implementation for zandronumq
 protocols.
User avatar (0021744)
Zalewa (developer)
2021-08-17 06:30

Quote from "Zalewa"
The plugin still needs to be added to the auto-update system (hint hint: tools\updateinstaller\tools\win32-configs) and then propagated to the users somehow.

This was done as a part of 1.3.2 release. The plugin is a part of the official release and I added the auto-updater configs.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2020-11-10 18:00 Zalewa New Issue
2020-11-10 18:00 Zalewa File Added: 0001-Add-Q-Zandronum-plugin.patch
2020-11-10 18:31 geNia Note Added: 0021559
2020-11-11 22:24 Pol M Note Added: 0021560
2020-11-12 00:46 Pol M Assigned To => Pol M
2020-11-12 00:46 Pol M Status new => confirmed
2020-11-14 02:54 WubTheCaptain Note Added: 0021561
2020-11-14 03:34 geNia Note Added: 0021562
2020-11-14 15:47 Pol M Note Added: 0021563
2020-11-14 15:49 Pol M Note Edited: 0021563 View Revisions
2020-11-15 02:41 geNia Note Added: 0021564
2020-11-23 18:19 Zalewa Note Added: 0021567
2020-11-23 18:19 Zalewa Assigned To Pol M =>
2020-11-23 18:19 Zalewa Status confirmed => needs testing
2021-08-07 16:44 Blzut3 Fixed in Version => 1.3.2
2021-08-07 16:44 Blzut3 Target Version => 1.3.2
2021-08-08 10:34 Zalewa Status needs testing => resolved
2021-08-08 10:34 Zalewa Resolution open => fixed
2021-08-08 10:34 Zalewa Assigned To => Zalewa
2021-08-10 05:47 WubTheCaptain Note Added: 0021707
2021-08-10 05:47 WubTheCaptain Status resolved => closed
2021-08-16 19:54 WubTheCaptain Relationship added related to 0003838
2021-08-16 19:56 WubTheCaptain Product Version => 1.3.1
2021-08-17 06:30 Zalewa Note Added: 0021744






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker