Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003518Doomseeker[All Projects] Bugpublic2018-09-24 19:292018-10-27 22:54
ReporterWubTheCaptain 
Assigned ToWubTheCaptain 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOpenBSDOS Version6.4-current
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003518: /bin/bash is not portable for running Zandronum testing from Doomseeker; this doesn't work with OpenBSD's base operating system
Description/bin/bash is not POSIX-portable. This means running Zandronum testing binaries requires installing bash as a package, or manually changing Doomseeker's generated #!/bin/bash shell scripts to use a POSIX sh interpreter #!/bin/sh (or equivalent).

Changing Doomseeker's script generation code from #!/bin/bash to #!/bin/sh should remain compatible with bash and POSIX sh.
Steps To Reproducesrc/plugins/zandronum/zandronumbinaries.cpp creates the script.

// Create Unix script file
content  = "#!/bin/bash\n";
[...]


For this issue to occur in practice:

  1. Zandronum engine plugin needs to be loaded in Doomseeker.
  2. In Configuration (F5) → Zandronum, "Testing Releases" needs to be enabled and a valid path (configured correctly).
  3. A server running a testing release of Zandronum must be available in Doomseeker's server browser.
  4. The directory for Zandronum testing releases must be void of the specific Zandronum testing release run on the server, to download the release and (more importantly) generate the shell script to run this testing release from Doomseeker.
  5. The user must not have bash installed in their operating system (in example, from OpenBSD ports).
  6. Joining the Zandronum testing release server fails due to lack of bash dependency, unless /bin/bash is somehow symlinked to /bin/sh or another shell. (It isn't by default, and doesn't make much sense to do so.)
Additional InformationNot sure if this is a bug or a suggestion. The suggestion is "Remove /bin/bash dependency from Zandronum testing binary shell scripts", and this is the bug behind it.

I make assumptions Zandronum can be run on OpenBSD, and bash is not available on the operating system (although it is available as a package to install by the superuser/system administrator on OpenBSD).

OpenBSD uses Korn shell (ksh), which is POSIX sh compatible with additions.
Attached Filespatch file icon 0001-Use-POSIX-sh-scripts-for-Zandronum-testing-releases.patch [^] (1,157 bytes) 2018-09-29 15:42 [Show Content]

- Relationships
related to 0003499assignedPol M Port Doomseeker to OpenBSD 

-  Notes
User avatar (0019804)
Blzut3 (administrator)
2018-09-29 07:11

This is a trivial change so setting target to 1.2.
User avatar (0019824)
WubTheCaptain (developer)
2018-09-29 15:37

Patch attached, patch by me, needs testing if merged (not sure if this is all that's required).
User avatar (0019825)
WubTheCaptain (developer)
2018-09-29 15:43

Reattached patch with an additional commit message paragraph explaining /bin/sh can be symlinked somewhere else, and that's fine too.
User avatar (0019837)
Blzut3 (administrator)
2018-09-30 07:05

Merged and verified on Linux.

https://bitbucket.org/Doomseeker/doomseeker/commits/c6b9f46befb7528c4ad10adbaf22ca5088201dcb [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-09-24 19:29 WubTheCaptain New Issue
2018-09-24 19:32 WubTheCaptain Description Updated View Revisions
2018-09-24 19:35 WubTheCaptain Relationship added child of 0003499
2018-09-24 19:36 WubTheCaptain Relationship replaced related to 0003499
2018-09-24 19:41 Zalewa Status new => acknowledged
2018-09-24 19:42 WubTheCaptain Additional Information Updated View Revisions
2018-09-24 19:44 WubTheCaptain Additional Information Updated View Revisions
2018-09-24 20:13 WubTheCaptain Severity minor => tweak
2018-09-29 07:11 Blzut3 Note Added: 0019804
2018-09-29 07:11 Blzut3 Target Version => 1.2
2018-09-29 15:30 WubTheCaptain Assigned To => WubTheCaptain
2018-09-29 15:30 WubTheCaptain Status acknowledged => assigned
2018-09-29 15:37 WubTheCaptain File Added: 0001-Use-POSIX-sh-scripts-for-Zandronum-testing-releases.patch
2018-09-29 15:37 WubTheCaptain Note Added: 0019824
2018-09-29 15:37 WubTheCaptain Status assigned => needs review
2018-09-29 15:42 WubTheCaptain File Deleted: 0001-Use-POSIX-sh-scripts-for-Zandronum-testing-releases.patch
2018-09-29 15:42 WubTheCaptain File Added: 0001-Use-POSIX-sh-scripts-for-Zandronum-testing-releases.patch
2018-09-29 15:43 WubTheCaptain Note Added: 0019825
2018-09-30 07:05 Blzut3 Note Added: 0019837
2018-09-30 07:05 Blzut3 Status needs review => resolved
2018-09-30 07:05 Blzut3 Fixed in Version => 1.2
2018-09-30 07:05 Blzut3 Resolution open => fixed
2018-10-27 22:54 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker