Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003508Doomseeker[All Projects] Suggestionpublic2018-09-22 18:402018-10-27 22:55
ReporterWubTheCaptain 
Assigned ToPol M 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.0 
Target Version1.2Fixed in Version1.2 
Summary0003508: Update adherence of Change Log to "Keep a Changelog" version 1.0.0
DescriptionA CHANGELOG.md file was added in commit ca3a3ff665d2869ed64d90aabee35cee59d41796 by Zalewa, on 2015-06-07. The most recent version if "Keep a Changelog" recommendation back then was 0.0.8.

This has become outdated; There's now a version 1.0.0 of the recommendation available. If Doomseeker was to follow the recommendations of 1.0.0, issues with Doomseeker's current Change Log include at least:

  • "Mention whether you follow Semantic Versioning."
  • Calling it "Development", not "Unreleased".
  • Calling it a "Change Log", not "Changelog" (since KAC 1.0.0)


(Same as what I said in 0003507 notes.) Not sure if there's more issues, if following the recommendations pedantically.
Steps To ReproduceCHANGELOG.md as of time of creating this issue:https://bitbucket.org/Doomseeker/doomseeker/src/5b1b0ceebaaca850e72386f298216bb1b0db44aa/CHANGELOG.md?fileviewer=file-view-default [^]
Additional Informationhttps://github.com/olivierlacan/keep-a-changelog/blob/v0.0.8/index.html [^]
https://keepachangelog.com/en/1.0.0/ [^]
Attached Files

- Relationships
related to 0003507closedPol M Add adherence of "Keep a Changelog" version number to Change Log 
child of 0003517closedWubTheCaptain Doomseeker 1.2 changelog (meta) 

-  Notes
User avatar (0019694)
Pol M (developer)
2018-09-23 20:59

About Semantic Versioning:

I'm afraid we do not follow semantic versioning, as we don't follow the rule 2:
Quote

A normal version number MUST take the form X.Y.Z where X, Y, and Z are non-negative integers, and MUST NOT contain leading zeroes. X is the major version, Y is the minor version, and Z is the patch version. Each element MUST increase numerically. For instance: 1.9.0 -> 1.10.0 -> 1.11.0.


I'll add that we don't follow it. :)
User avatar (0019695)
Pol M (developer)
2018-09-23 21:09
edited on: 2018-09-23 21:09

Seems we're pretty okay, and we already use mostly "Change Log".

Reading all the changes done since 0.0.8, there's nothing else left to do (apart to what all Lisa listed), at least to my knowledge, and comparing our CHANGELOG.md to theirs has not revealed any other meaningful information.

If we changed our versioning, to adhere to Semantic versioning, a "does not adhere" can be changed to "adheres" from the CHANGELOG.md

User avatar (0019696)
Zalewa (developer)
2018-09-23 21:36

Semantic Versioning also requires to not break the API between the "Y" versions, which sadly happens every "Y" version.
User avatar (0019704)
WubTheCaptain (developer)
2018-09-24 17:45
edited on: 2018-09-24 17:57

https://bitbucket.org/Doomseeker/doomseeker/commits/8568482bbcc9ad02d1b35d501a6c1e2254e5d3db [^]

"change log" → "changelog", the opposite has been done there.

Quote from Keep a Changelog 1.0
### Changed
- Start using "changelog" over "change log" since it's the common usage.


Quote from Pol M
(apart to what all Lisa listed)


Lisa?

User avatar (0019708)
Pol M (developer)
2018-09-24 18:52
edited on: 2018-09-24 19:59

Quote from Wub

Lisa?

Whaaaat... I don't know how the Google keyboard changed that from Wub. 😂
Sorry for the confusion.
Quote

change log" → "changelog", the opposite has been done there.

That's embarrassing 🤦

User avatar (0019711)
Pol M (developer)
2018-09-24 19:48

pull request fixing fuckup
User avatar (0019712)
WubTheCaptain (developer)
2018-09-24 20:02

Quote from Pol M
Whaaaat... I don't know how the Google keyboard changed that from Wub. 😂


Close enough, my name is actually Linda. 😏
User avatar (0019713)
Pol M (developer)
2018-09-24 20:07
edited on: 2018-09-24 20:08

Ok, if you're okay with me referring to you as Linda, I'll probably use that also. :) (btw, that means beautiful in Spanish. 👌)
My name is no secret at this point 😂

Have a nice afternoon! 😋

User avatar (0019717)
Zalewa (developer)
2018-09-24 21:23

The issues that were pointed out look to be all fixed now. I'm closing this as resolved.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-09-22 18:40 WubTheCaptain New Issue
2018-09-22 18:41 WubTheCaptain Relationship added parent of 0003507
2018-09-22 18:42 WubTheCaptain Description Updated View Revisions
2018-09-22 18:44 WubTheCaptain Additional Information Updated View Revisions
2018-09-22 18:45 WubTheCaptain Product Version 1.1 => 1.0
2018-09-22 18:46 WubTheCaptain Steps to Reproduce Updated View Revisions
2018-09-22 19:58 WubTheCaptain Relationship replaced related to 0003507
2018-09-23 18:04 Pol M Assigned To => Pol M
2018-09-23 18:04 Pol M Status new => assigned
2018-09-23 20:59 Pol M Note Added: 0019694
2018-09-23 21:09 Pol M Note Added: 0019695
2018-09-23 21:09 Pol M Note Edited: 0019695 View Revisions
2018-09-23 21:36 Zalewa Note Added: 0019696
2018-09-24 00:40 Blzut3 Status assigned => needs review
2018-09-24 17:45 WubTheCaptain Note Added: 0019704
2018-09-24 17:45 WubTheCaptain Status needs review => assigned
2018-09-24 17:47 WubTheCaptain Note Edited: 0019704 View Revisions
2018-09-24 17:57 WubTheCaptain Note Edited: 0019704 View Revisions
2018-09-24 18:02 WubTheCaptain Target Version => 1.2
2018-09-24 18:21 WubTheCaptain Relationship added child of 0003517
2018-09-24 18:52 Pol M Note Added: 0019708
2018-09-24 18:53 Pol M Note Edited: 0019708 View Revisions
2018-09-24 19:48 Pol M Note Added: 0019711
2018-09-24 19:51 Pol M Status assigned => needs review
2018-09-24 19:59 Pol M Note Edited: 0019708 View Revisions
2018-09-24 20:02 WubTheCaptain Note Added: 0019712
2018-09-24 20:07 Pol M Note Added: 0019713
2018-09-24 20:08 Pol M Note Edited: 0019713 View Revisions
2018-09-24 21:23 Zalewa Note Added: 0019717
2018-09-24 21:23 Zalewa Status needs review => resolved
2018-09-24 21:23 Zalewa Fixed in Version => 1.2
2018-09-24 21:23 Zalewa Resolution open => fixed
2018-10-27 22:55 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker