Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003507Doomseeker[All Projects] Suggestionpublic2018-09-22 18:082018-10-27 22:55
ReporterWubTheCaptain 
Assigned ToPol M 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003507: Add adherence of "Keep a Changelog" version number to Change Log
DescriptionNoticing there's many non-compliance issues with "Keep a Changelog" website's 1.0.0 English version and Doomseeker's Change Log (CHANGELOG.md), I'm not sure which "recommendations in accordance" aims to fulfill.

Add the standards version number, please?
Steps To Reproducehttps://bitbucket.org/Doomseeker/doomseeker/src/5b1b0ceebaaca850e72386f298216bb1b0db44aa/CHANGELOG.md [^]
Additional Informationhttps://keepachangelog.com/en/1.0.0/ [^]
Attached Files

- Relationships
related to 0003508closedPol M Update adherence of Change Log to "Keep a Changelog" version 1.0.0 
child of 0003517closedWubTheCaptain Doomseeker 1.2 changelog (meta) 

-  Notes
User avatar (0019646)
WubTheCaptain (developer)
2018-09-22 18:13
edited on: 2018-09-22 18:21

Before I'll forget, the issues I noticed with compliance include:

  • "Mention whether you follow Semantic Versioning."
  • Calling it "Development", not "Unreleased".
  • Calling it a "Change Log", not "Changelog" (since KAC 1.0.0)


Probably worthy a few children of this ticket.

User avatar (0019705)
WubTheCaptain (developer)
2018-09-24 17:51

Fixed:https://bitbucket.org/Doomseeker/doomseeker/commits/8568482bbcc9ad02d1b35d501a6c1e2254e5d3db [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-09-22 18:08 WubTheCaptain New Issue
2018-09-22 18:13 WubTheCaptain Note Added: 0019646
2018-09-22 18:20 WubTheCaptain Note Edited: 0019646 View Revisions
2018-09-22 18:21 WubTheCaptain Note Edited: 0019646 View Revisions
2018-09-22 18:41 WubTheCaptain Relationship added child of 0003508
2018-09-22 18:48 WubTheCaptain Summary Add adherence of "Keep a Changelog" version to Change Log => Add adherence of "Keep a Changelog" version number to Change Log
2018-09-22 19:58 WubTheCaptain Relationship replaced related to 0003508
2018-09-23 18:04 Pol M Assigned To => Pol M
2018-09-23 18:04 Pol M Status new => assigned
2018-09-24 00:40 Blzut3 Status assigned => needs review
2018-09-24 17:51 WubTheCaptain Note Added: 0019705
2018-09-24 17:51 WubTheCaptain Resolution open => fixed
2018-09-24 17:51 WubTheCaptain Fixed in Version => 1.2
2018-09-24 17:51 WubTheCaptain Target Version => 1.2
2018-09-24 17:52 WubTheCaptain Status needs review => resolved
2018-09-24 18:21 WubTheCaptain Relationship added child of 0003517
2018-10-27 22:55 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker