Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003308Doomseeker[All Projects] Suggestionpublic2017-10-22 21:132017-10-23 12:50
ReporterWubTheCaptain 
Assigned ToWubTheCaptain 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version1.1 
Target Version1.2Fixed in Version 
Summary0003308: Include a copy of the GNU GPL license, regardless of release under the GNU LGPL
Description
Quote from The GNU Project
All programs, whether they are released under the GPL or LGPL, should include the text version of the GPL.


Quote from The GNU Project
If you are releasing your program under the Lesser GPL, you should also include the text version of the LGPL, usually in a file called COPYING.LESSER. Please note that, since the LGPL is a set of additional permissions on top of the GPL, it's crucial to include both licenses so users have all the materials they need to understand their rights.


Can I, please? The intent is GPLv2 text.
Steps To Reproduce

  1. wget -O COPYINGhttps://www.gnu.org/licenses/old-licenses/gpl-2.0.txt [^]

  2. hg add COPYING

  3. hg commit

  4. ...

Additional Informationhttps://www.gnu.org/licenses/gpl-howto.en.html [^]
Attached Filespatch file icon 0001-include-gplv2-license.patch [^] (19,548 bytes) 2017-10-22 21:43 [Show Content]

- Relationships
related to 0003295acknowledged Rename LICENSE files to COPYING 

-  Notes
User avatar (0018604)
WubTheCaptain (developer)
2017-10-22 21:43

Proposed patch attached.
User avatar (0018606)
WubTheCaptain (developer)
2017-10-22 21:57

I'll hold this off until 0003295 is resolved, because of Windows installs.
User avatar (0018607)
WubTheCaptain (developer)
2017-10-22 22:19
edited on: 2017-10-22 22:20

I'm going to refrain from doing this change after all, because the LGPLv2.1 license text is the full license. Only the LGPLv3 license (being a "slim" license) requires having a copy of GPLv3 handy, to understand what exceptions are being granted.

User avatar (0018610)
WubTheCaptain (developer)
2017-10-22 22:36

Actually, I can't decide for myself.

The LGPLv2.1 still talks a lot about "ordinary General Public License". Should we do it anyway, as courtesy?
User avatar (0018616)
Blzut3 (administrator)
2017-10-23 04:15

If we go back in time to when LGPLv2.1 was current they said to put the LGPL in COPYING and no mention of including the GPL:https://web.archive.org/web/20070428002817/http://www.gnu.org/licenses/gpl-howto.html [^]

I don't really see a point in distributing an extraneous license file and it's not like there aren't a million other places that one can get it if they really want it.

This also addresses the file name debate in 0003295.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-22 21:13 WubTheCaptain New Issue
2017-10-22 21:13 WubTheCaptain Status new => assigned
2017-10-22 21:13 WubTheCaptain Assigned To => WubTheCaptain
2017-10-22 21:14 WubTheCaptain Status assigned => new
2017-10-22 21:17 WubTheCaptain Status new => assigned
2017-10-22 21:17 WubTheCaptain Steps to Reproduce Updated View Revisions
2017-10-22 21:17 WubTheCaptain Status assigned => feedback
2017-10-22 21:18 WubTheCaptain Status feedback => new
2017-10-22 21:21 WubTheCaptain Relationship added related to 0003295
2017-10-22 21:43 WubTheCaptain File Added: 0001-include-gplv2-license.patch
2017-10-22 21:43 WubTheCaptain Note Added: 0018604
2017-10-22 21:43 WubTheCaptain Status new => needs review
2017-10-22 21:57 WubTheCaptain Note Added: 0018606
2017-10-22 21:57 WubTheCaptain Status needs review => assigned
2017-10-22 22:19 WubTheCaptain Note Added: 0018607
2017-10-22 22:19 WubTheCaptain Status assigned => closed
2017-10-22 22:19 WubTheCaptain Resolution open => no change required
2017-10-22 22:20 WubTheCaptain Note Edited: 0018607 View Revisions
2017-10-22 22:36 WubTheCaptain Note Added: 0018610
2017-10-22 22:36 WubTheCaptain Status closed => feedback
2017-10-22 22:36 WubTheCaptain Resolution no change required => reopened
2017-10-23 04:15 Blzut3 Note Added: 0018616
2017-10-23 12:50 WubTheCaptain Status feedback => closed
2017-10-23 12:50 WubTheCaptain Resolution reopened => no change required






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker