Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003295Doomseeker[All Projects] Suggestionpublic2017-10-07 09:402017-10-29 19:12
ReporterWubTheCaptain 
Assigned To 
PrioritynormalSeveritytrivialReproducibilityN/A
StatusacknowledgedResolutionreopened 
PlatformOSOS Version
Product Version1.1 
Target Version1.2Fixed in Version 
Summary0003295: Rename LICENSE files to COPYING
DescriptionCurrently, Doomseeker has license text in files named LICENSE and LICENSE.json.

It's a GNU release convention to have the license texts in a file called COPYING. Sometimes you also find the LGPL text in a file called COPYING.LESSER.

I propose Doomseeker to adopt GNU's terminology for the files to possibly satisfy both worlds/release practices.
Steps To Reproduce
$ mv LICENSE COPYING
$ mv LICENSE.json COPYING.json
$ # Commit to Mercurial, done.
Additional Informationhttps://www.gnu.org/prep/standards/standards.html#Releases [^]
Attached Filespatch file icon 0001-rename-license-files-to-copying.patch [^] (58,187 bytes) 2017-10-22 21:25 [Show Content]

- Relationships
related to 0003247confirmedWubTheCaptain Doomseeker's manual page (mdoc/nroff) is missing or incomplete 
related to 0003237assignedZalewa Non-free files and copyright issues in source archive 
related to 0003308closedWubTheCaptain Include a copy of the GNU GPL license, regardless of release under the GNU LGPL 
related to 0003309resolvedZalewa FixedFtpReply and FixedNetworkAccessManager have missing license files 

-  Notes
User avatar (0018457)
WubTheCaptain (developer)
2017-10-07 09:41

I've tagged this to target version 1.2 because I'd like to know which convention to follow with the manual pages and copyright notice.
User avatar (0018462)
Zalewa (developer)
2017-10-07 10:46

I have no objections.
User avatar (0018599)
WubTheCaptain (developer)
2017-10-22 21:26
edited on: 2017-10-22 21:26

Patch attached. First time using Mercurial.

User avatar (0018602)
Zalewa (developer)
2017-10-22 21:39

1. I think Mercurial needs to be explicitly told to track file renames:http://hgtip.com/tips/advanced/2009-09-30-detecting-renames-automatically/ [^] . If you don't do this, you'll lose history continuity for the renamed files.

2. The license files are actually being installed by CMakeLists.txt, at least for Windows builds. If you rename them without adjusting CMakeLists.txt, you essentially break 'make install'.

3. There's now interesting incosistency between COPYING.json and COPYING.LESSER. COPYING.LESSER is a standard name for a file containing LGPL license, however COPYING.json file contains a BSD license for the JSON library, which is baked into Doomseeker. Considering that COPYING.LESSER is a standard and COPYING.json follows the same naming pattern, even though it is something that we made up, then one, at a glance, could incorrectly assume that COPYING.json is some kind of a generic "json" license. I might be blowing the problem out of proportions, though.
User avatar (0018611)
WubTheCaptain (developer)
2017-10-22 22:43

Can we remove LICENSE.json from the root? We satisfy the conditions by including the copyright notice in the source file header and in the about dialog of Doomseeker. There's a distinction between "retaining" the copyright notice for source code and "reproducing" the copyright notice, so it should be fine in the about dialog.

If not, what do you propose the LICENSE.json file to be named?
User avatar (0018612)
WubTheCaptain (developer)
2017-10-22 22:51

I should read more and type less. The about dialog isn't the full copyright notice.

Do you still have a proposal for the filename?
User avatar (0018617)
Blzut3 (administrator)
2017-10-23 04:18

Per my comment in 0003308 the COPYING.LESSER convention is an LGPLv3 thing related to LGPLv3 referencing the GPLv3 vs including the full text. Since we're using v2.1 there's nothing that needs to be done there.
User avatar (0018618)
WubTheCaptain (developer)
2017-10-23 13:03

We could've named it lgpl-2.1.txt, but that's out of scope for this ticket's suggestion. I'm thinking the FDL license file (if adopted for manuals) may be called fdl-1.3.txt.

Per Blzut3, closing.
User avatar (0018620)
Blzut3 (administrator)
2017-10-24 00:42

Were all other points in the ticket addressed? I was only referring to LICENSE -> COPYING.LESSER instead of just COPYING.
User avatar (0018622)
WubTheCaptain (developer)
2017-10-25 00:07
edited on: 2017-10-25 00:23

If I somehow renamed the LGPLv2.1 license file to COPYING, but later there was LGPLv3 or GPLv3 introduced, it would create a bigger conflict with GNU's conventions.

If anything, I'd name it lgpl-2.1.txt but that's an idea for another suggestive ticket. I also plan on doing AUTHORS, Copyright, README and maybe other more descriptive files.

PS: 0003309 for the header problem.

User avatar (0018623)
WubTheCaptain (developer)
2017-10-25 00:16
edited on: 2017-10-25 00:19

We could name it COPYING.LIB.https://web.archive.org/web/20070626172140/https://www.gnu.org/prep/standards/standards.html [^]

Quote from GNU Coding Standards (2007)
The README file should also refer to the file which contains the copying conditions. The GNU GPL, if used, should be in a file called COPYING. If the GNU LGPL is used, it should be in a file called COPYING.LIB.


Thoughts?

User avatar (0018641)
Blzut3 (administrator)
2017-10-29 01:12

Personally I still find it more relevant to note what part of the software is covered by the license rather than what license it is in the filename. So I'm more partial to just string replace LICENSE to COPYING and leave the extensions (or lack thereof) as is.
User avatar (0018660)
WubTheCaptain (developer)
2017-10-29 19:12

Unassigning myself from this for a while.

A possible problem I see with one file called "COPYING" with all licenses concatenated inside is referencing from a file such as a manual page, which would not be under LGPLv2.1+ or qt-json's BSD or GPL license. Would a manual page then have to reference to, let's say, a file named "fdl-1.3.txt"?

If we still did name LICENSE (LGPLv2.1) to COPYING (LGPLv2.1 and BSD), I feel like it'd not be exactly up to GNU's current practices or conventions (COPYING = GPLv3, COPYING.LESSER = LGPLv3) but on contrary a potential conflict.

I can't think what the right solution is. If COPYING.LIB is not the right way to call it (and referencing from README or COPYING to it for LGPLv2.1 text), then I'd close this ticket as denied or invalid.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-07 09:40 WubTheCaptain New Issue
2017-10-07 09:41 WubTheCaptain Note Added: 0018457
2017-10-07 09:41 WubTheCaptain Relationship added related to 0003247
2017-10-07 10:46 Zalewa Note Added: 0018462
2017-10-22 21:21 WubTheCaptain Relationship added related to 0003308
2017-10-22 21:25 WubTheCaptain File Added: 0001-rename-license-files-to-copying.patch
2017-10-22 21:26 WubTheCaptain Note Added: 0018599
2017-10-22 21:26 WubTheCaptain Assigned To => WubTheCaptain
2017-10-22 21:26 WubTheCaptain Status new => needs review
2017-10-22 21:26 WubTheCaptain Note Edited: 0018599 View Revisions
2017-10-22 21:30 WubTheCaptain Note Added: 0018600
2017-10-22 21:33 WubTheCaptain Note Added: 0018601
2017-10-22 21:34 WubTheCaptain Relationship added related to 0003237
2017-10-22 21:39 Zalewa Note Added: 0018602
2017-10-22 21:41 Zalewa Note Added: 0018603
2017-10-22 21:46 WubTheCaptain Status needs review => assigned
2017-10-22 21:49 WubTheCaptain Note Added: 0018605
2017-10-22 22:10 WubTheCaptain Relationship added related to 0003309
2017-10-22 22:43 WubTheCaptain Note Added: 0018611
2017-10-22 22:43 WubTheCaptain Status assigned => feedback
2017-10-22 22:51 WubTheCaptain Note Added: 0018612
2017-10-22 22:51 WubTheCaptain Status feedback => assigned
2017-10-22 23:47 WubTheCaptain Status assigned => feedback
2017-10-23 04:18 Blzut3 Note Added: 0018617
2017-10-23 13:03 WubTheCaptain Note Added: 0018618
2017-10-23 13:03 WubTheCaptain Status feedback => assigned
2017-10-23 13:03 WubTheCaptain Status assigned => closed
2017-10-23 13:03 WubTheCaptain Resolution open => denied
2017-10-24 00:42 Blzut3 Note Added: 0018620
2017-10-25 00:07 WubTheCaptain Note Added: 0018622
2017-10-25 00:10 WubTheCaptain Note Edited: 0018622 View Revisions
2017-10-25 00:12 WubTheCaptain Note Edited: 0018622 View Revisions
2017-10-25 00:16 WubTheCaptain Note Added: 0018623
2017-10-25 00:16 WubTheCaptain Status closed => feedback
2017-10-25 00:16 WubTheCaptain Resolution denied => reopened
2017-10-25 00:19 WubTheCaptain Note Edited: 0018623 View Revisions
2017-10-25 00:23 WubTheCaptain Note Edited: 0018622 View Revisions
2017-10-25 00:23 WubTheCaptain Note Edited: 0018622 View Revisions
2017-10-29 01:12 Blzut3 Note Added: 0018641
2017-10-29 19:12 WubTheCaptain Note Added: 0018660
2017-10-29 19:12 WubTheCaptain Status feedback => assigned
2017-10-29 19:12 WubTheCaptain Assigned To WubTheCaptain =>
2017-10-29 19:12 WubTheCaptain Status assigned => acknowledged
2017-10-29 19:38 WubTheCaptain Note Deleted: 0018600
2017-10-29 19:39 WubTheCaptain Note Deleted: 0018601
2017-10-29 19:39 WubTheCaptain Note Deleted: 0018603
2017-10-29 19:39 WubTheCaptain Note Deleted: 0018605






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker