Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003191Zandronum[All Projects] Bugpublic2017-07-17 19:382017-07-27 21:08
Reporterfr-blood 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target VersionFixed in Version 
Summary0003191: Thing Thrust Z(Ladder) Not Working From "Bumps" on Zandronum 3.0
DescriptionUsing 128 : Thing Thrust Z with "bump" activator on a line separated from a solid actor won't work on Zandronum 3.0 when it worked on 2.1.2(previous versions).
Steps To Reproduce- Launch thingthrustZmapbug.wad MAP01 and just try to go on the second sector.
- You will be able to climb the right ladder on both Zandronums because the solid line is the one with the script.
- You will be able to climb the left ladder on Zandronum 2.1.2 but not on 3.0 because here it's a separate line which use the script.
Additional InformationI've tried it on GZDoom and it doesn't work as well, but that problem should be fixed because many project which were done only for zandronum are also using that way of scripting for ladders and then it would make all of them not working.
Attached Files? file icon thingthrustZmapbug.wad [^] (4,136 bytes) 2017-07-17 19:38

- Relationships
duplicate of 0003115feedback 3.0 breaks ladders on some maps 

-  Notes
User avatar (0018057)
Korshun (reporter)
2017-07-17 19:43
edited on: 2017-07-17 19:50

I reported a duplicate of this bug:https://zandronum.com/tracker/view.php?id=3115 [^]

To fix it, Zandronum needs to backport compat_pushwindow, which is not present in GZDoom 1.8.6.

It seems to have been agreed that it will be backported if affected projects other than HvM Mappack are listed.

User avatar (0018058)
fr-blood (reporter)
2017-07-17 20:40

Alright then let's hope they will backport it.
User avatar (0018059)
Dusk (developer)
2017-07-17 21:28

Do you know of any additional released projects that suffer from this problem?
User avatar (0018060)
fr-blood (reporter)
2017-07-17 21:46

Well mine which forced me to rework on 16 maps because of it.

And probably Zombie Horde and Ghoul vs Human, Delta Invasion.
User avatar (0018071)
fr-blood (reporter)
2017-07-21 20:22

Alright you can close that ticket if the one "0003115" related to it has been solved.
User avatar (0018072)
Korshun (reporter)
2017-07-21 20:31
edited on: 2017-07-21 20:31

It wasn't backported. 3115 is solved because becase HvM Mappack has been edited to fix the ladders.

User avatar (0018101)
TGminer (reporter)
2017-07-26 23:45

tbh the compatflag should be implemented, especially because the ZH maps that use the bumping ladder mechanism breaks, and the mappack hasn't been updated for who knows how long.

shouldn't take that long to implement.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Korshun TGminer
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-07-17 19:38 fr-blood New Issue
2017-07-17 19:38 fr-blood File Added: thingthrustZmapbug.wad
2017-07-17 19:43 Korshun Note Added: 0018057
2017-07-17 19:43 Korshun Note Edited: 0018057 View Revisions
2017-07-17 19:45 Korshun Note Edited: 0018057 View Revisions
2017-07-17 19:46 Korshun Note Edited: 0018057 View Revisions
2017-07-17 19:47 Korshun Note Edited: 0018057 View Revisions
2017-07-17 19:50 Korshun Note Edited: 0018057 View Revisions
2017-07-17 20:05 Dusk Relationship added duplicate of 0003115
2017-07-17 20:05 Dusk Status new => closed
2017-07-17 20:05 Dusk Resolution open => duplicate
2017-07-17 20:15 Dusk Status closed => feedback
2017-07-17 20:15 Dusk Resolution duplicate => reopened
2017-07-17 20:40 fr-blood Note Added: 0018058
2017-07-17 20:40 fr-blood Status feedback => new
2017-07-17 21:28 Dusk Note Added: 0018059
2017-07-17 21:28 Dusk Status new => feedback
2017-07-17 21:46 fr-blood Note Added: 0018060
2017-07-17 21:46 fr-blood Status feedback => new
2017-07-21 20:22 fr-blood Note Added: 0018071
2017-07-21 20:31 Korshun Note Added: 0018072
2017-07-21 20:31 Korshun Note Edited: 0018072 View Revisions
2017-07-26 23:45 TGminer Note Added: 0018101
2017-07-27 21:08 Dusk Status new => closed
2017-07-27 21:08 Dusk Resolution reopened => duplicate






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker