Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003115Zandronum[All Projects] Bugpublic2017-04-30 16:032017-07-28 13:10
ReporterKorshun 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target VersionFixed in Version 
Summary0003115: 3.0 breaks ladders on some maps
DescriptionSome maps have ladders made out of a single line with ThingThrustZ and repeatable player bump trigger. They worked fine in 2.1.2 but are broken in 3.0.

Testing in ZDoom shows that they became broken between 2.5.0 and 2.6.0.

Some ladders that use seemingly the same design are not affected. I can't figure out the difference between broken and non-broken ladders.

Attached Files? file icon brokenladders.wad [^] (6,493 bytes) 2017-04-30 16:03

- Relationships
related to 0003073resolvedTorr Samaho 3.0-alpha-r170416-0710 broke exit portal broken in super skulltag 
has duplicate 0003191closed Thing Thrust Z(Ladder) Not Working From "Bumps" on Zandronum 3.0 

-  Notes
User avatar (0017452)
Torr Samaho (administrator)
2017-04-30 17:03

How is it in GZDoom 1.8.6 and 2.4.0?
User avatar (0017455)
Korshun (reporter)
2017-04-30 17:14

Broken and broken. Everything after ZDoom 2.6.0 is broken.
User avatar (0017457)
jdagenet (reporter)
2017-04-30 17:49

You're using the bumping activation method on a passable linedef. The player never bumps the linedef, he only walks through it.
Changing the activation method to something like "player walks through" and pulling the linedefs out a bit will allow the function to actually execute.

This is intended behavior so there's nothing broken here.
User avatar (0017458)
Korshun (reporter)
2017-04-30 17:57
edited on: 2017-04-30 18:05

> This is intended behavior so there's nothing broken here.

The maps that use these ladders are now broken.

Also, the proposed fix doesn't keep the behavior of pushing the player upwards as long as he is trying to move towards the ladder. It only launches the player upwards once.

User avatar (0017459)
jdagenet (reporter)
2017-04-30 18:01

The ladders in your example wad are defined incorrectly as mentioned above.

I have ladders in my mod and they work perfectly fine.
User avatar (0017460)
Korshun (reporter)
2017-04-30 18:06

These ladders are copied from real maps that have the same bug and became less playable in Zandronum 3.0.
User avatar (0017461)
WaTaKiD (updater)
2017-04-30 18:09

which maps?
User avatar (0017462)
Korshun (reporter)
2017-04-30 18:11
edited on: 2017-04-30 18:14

I found out that the REAL fix is to set "3D Midtex" flag on ladder textures.

For now it's at least all maps with ladders in HvM Mappack. These can be fixed easily. But there might be more maps like that.

User avatar (0017463)
jdagenet (reporter)
2017-04-30 18:23

The "3D Mid Texture" flag will make the mid texture solid, hence satisfying the "player bumps" activation method since the player can actually bump into the linedef.

It's a fix in your case, but in terms of functionality everything is performing the way it should.
User avatar (0017464)
Korshun (reporter)
2017-04-30 18:25
edited on: 2017-04-30 19:26

Formerly, ZDoom treated walking through a two-sided line as bumping into it. Now it doesn't. This caused backwards compatibility problems. There might actually be non-ladder lines that are broken.

EDIT: I see GZDoom has added a compatflag for that, compat_pushwindow. But it's not present in Zandronum 3.0.

EDIT: not present in GZDoom 1.8.6 either.

EDIT: the compatflag was added to GZDoom in this commit in 2016:https://github.com/coelckers/gzdoom/commit/b4e712ab019f13a33f718c95b7d1afcc5fb54acf [^]

User avatar (0017466)
Torr Samaho (administrator)
2017-04-30 19:33

How many existing maps need this? If this are not too many, we can simply add them to compatibility list, like it did with sstmap34:https://bitbucket.org/Torr_Samaho/zandronum/commits/9679b9b67f46e7a2e1285fad036b0c08c6888f60 [^]
User avatar (0017467)
Korshun (reporter)
2017-04-30 19:39

The HvM Mappack has a lot of versions and a lot of maps. It's best to fix the mappack. And I don't know of more broken wads.
User avatar (0017468)
Torr Samaho (administrator)
2017-04-30 19:47

If there are many different maps and that even in different versions, I guess we need to expose that compat flag also in Zandronum.
User avatar (0017469)
Korshun (reporter)
2017-04-30 19:51

Yeah but only the latest version is used and HvM Mappack is my project, I can release a new version. There is no need for a compatflag yet. But more broken wads might pop up once 3.0 is released.
User avatar (0017483)
Torr Samaho (administrator)
2017-05-01 17:34
edited on: 2017-05-01 17:35

Ok. Let me know if it turns out that we need the compatflag.

EDIT: I'll close the ticket for now, but you should be able to re-open it by posting a note in here.

User avatar (0018114)
Korshun (reporter)
2017-07-28 13:10

A duplicate of this bug was openedhttps://zandronum.com/tracker/view.php?id=3191 [^] and closed due to being a duplicate.

It requests backporting the compatflag due to several other projects breaking:

> forced me to rework on 16 maps because of it.
> And probably Zombie Horde and Ghoul vs Human, Delta Invasion.

> tbh the compatflag should be implemented, especially because the ZH maps that use the bumping ladder mechanism breaks, and the mappack hasn't been updated for who knows how long.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: Korshun Monsterovich JC Tenton MazterQyoun-ae
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-04-30 16:03 Korshun New Issue
2017-04-30 16:03 Korshun File Added: brokenladders.wad
2017-04-30 17:03 Torr Samaho Note Added: 0017452
2017-04-30 17:03 Torr Samaho Status new => feedback
2017-04-30 17:14 Korshun Note Added: 0017455
2017-04-30 17:14 Korshun Status feedback => new
2017-04-30 17:49 jdagenet Note Added: 0017457
2017-04-30 17:57 Korshun Note Added: 0017458
2017-04-30 18:01 jdagenet Note Added: 0017459
2017-04-30 18:05 Korshun Note Edited: 0017458 View Revisions
2017-04-30 18:06 Korshun Note Added: 0017460
2017-04-30 18:09 WaTaKiD Note Added: 0017461
2017-04-30 18:11 Korshun Note Added: 0017462
2017-04-30 18:14 Korshun Note Edited: 0017462 View Revisions
2017-04-30 18:23 jdagenet Note Added: 0017463
2017-04-30 18:25 Korshun Note Added: 0017464
2017-04-30 18:37 Korshun Note Edited: 0017464 View Revisions
2017-04-30 18:38 Korshun Note Edited: 0017464 View Revisions
2017-04-30 18:43 Korshun Note Edited: 0017464 View Revisions
2017-04-30 18:44 Korshun Note Edited: 0017464 View Revisions
2017-04-30 19:25 Korshun Note Edited: 0017464 View Revisions
2017-04-30 19:26 Korshun Note Edited: 0017464 View Revisions
2017-04-30 19:33 Torr Samaho Note Added: 0017466
2017-04-30 19:39 Korshun Note Added: 0017467
2017-04-30 19:47 Torr Samaho Note Added: 0017468
2017-04-30 19:51 Korshun Note Added: 0017469
2017-05-01 17:34 Torr Samaho Note Added: 0017483
2017-05-01 17:34 Torr Samaho Note Edited: 0017483 View Revisions
2017-05-01 17:34 Torr Samaho Note Revision Dropped: 17483: 0010507
2017-05-01 17:35 Torr Samaho Note Edited: 0017483 View Revisions
2017-05-01 17:36 Torr Samaho Status new => closed
2017-05-01 17:36 Torr Samaho Resolution open => no change required
2017-05-01 17:36 Torr Samaho Relationship added related to 0003073
2017-07-17 20:05 Dusk Relationship added has duplicate 0003191
2017-07-17 20:05 Dusk Status closed => resolved
2017-07-28 13:10 Korshun Note Added: 0018114
2017-07-28 13:10 Korshun Status resolved => feedback
2017-07-28 13:10 Korshun Resolution no change required => reopened






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker