Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002934Zandronum[All Projects] Bugpublic2016-11-25 22:402018-09-30 21:57
ReporterZalewa 
Assigned ToTorr Samaho 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002934: Crash with 'map' ccmd from client while automap is open
DescriptionCrash occured in a survival game in dmp15b.wad

1. There were 2 players in the game.
2. We were on MAP15
3. Player 2 disconnected.
4. I typed in MAP MAP19.
5. Game crashed.

Crash report attached.
Steps To Reproduce1. Host a simple doom 2 game;
2. Connect a client;
3. Let the client open the automap;
3. 'map map01' from the client console.
Additional InformationGame version: 3.0-alpha-r161030-2038
Attached Fileszip file icon dmp2015b_CrashReport.zip [^] (19,085 bytes) 2016-11-25 22:40

- Relationships
child of 0002232closedTorr Samaho [b678038] Game crashed on the map start 

-  Notes
User avatar (0016321)
WaTaKiD (updater)
2016-11-25 23:52
edited on: 2016-11-25 23:53

this is the call stack of the provided crash report:

> zandronum.exe!AM_drawPlayers() Line 2520 C++
     zandronum.exe!AM_Drawer() Line 2959 C++
     zandronum.exe!D_Display() Line 995 C++
     zandronum.exe!D_DoomLoop() Line 1329 C++
     zandronum.exe!D_DoomMain() Line 3255 C++

also, ive found that to reproduce the crash, one simply needs to host a server, connect to it, open automap, then do map map01 (no additional pwads or clients needed)

and lastly, this is the culprit: https://bitbucket.org/Torr_Samaho/zandronum/commits/1951844030f7d572a4d1fcdf53a85a9ca448c231 [^]

User avatar (0016328)
Torr Samaho (administrator)
2016-11-26 16:04

Should be fixed now.
User avatar (0016434)
Ru5tK1ng (updater)
2016-12-08 01:58

I pulled the latest changes and couldn't crash as described.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-11-25 22:40 Zalewa New Issue
2016-11-25 22:40 Zalewa File Added: dmp2015b_CrashReport.zip
2016-11-25 23:52 WaTaKiD Note Added: 0016321
2016-11-25 23:53 WaTaKiD Note Edited: 0016321 View Revisions
2016-11-25 23:53 Edward-san Relationship added child of 0002232
2016-11-26 00:19 Edward-san Reproducibility unable to reproduce => always
2016-11-26 00:19 Edward-san Status new => confirmed
2016-11-26 00:19 Edward-san Summary Crash when doing MAP MAP19 from netgame when playing dmp15b.wad => Crash with 'map' ccmd from client while automap is open
2016-11-26 00:20 Edward-san Steps to Reproduce Updated View Revisions
2016-11-26 00:21 Edward-san Steps to Reproduce Updated View Revisions
2016-11-26 15:38 Torr Samaho Assigned To => Torr Samaho
2016-11-26 15:38 Torr Samaho Product Version 3.0 => 3.0-beta
2016-11-26 15:38 Torr Samaho Target Version => 3.0
2016-11-26 16:04 Torr Samaho Note Added: 0016328
2016-11-26 16:04 Torr Samaho Status confirmed => needs testing
2016-12-08 01:58 Ru5tK1ng Note Added: 0016434
2016-12-08 01:58 Ru5tK1ng Status needs testing => resolved
2016-12-08 01:58 Ru5tK1ng Resolution open => fixed
2016-12-08 01:58 Ru5tK1ng Fixed in Version => 3.0
2018-09-30 21:57 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker