Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002690Zandronum[All Projects] Suggestionpublic2016-03-30 19:582018-09-30 22:05
ReporterTiger 
Assigned ToTorr Samaho 
PrioritylowSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformDesktop (x86_64)OSWindowsOS Version6.3
Product Version3.0-beta 
Target VersionFixed in Version3.0 
Summary0002690: [Backport Request] Camera Texture Fix
DescriptionSome of the two sided camera textures will simply not render at all. Using the demonstration PWAD provided below, there exists some camera textures that outlines this bug. I will also provide images on this ticket as well.

I have originally reported this bug to Graf Zahl at DRDTeam [http://forum.drdteam.org/viewtopic.php?p=58017#p58017 [^] ], this fix never made it to GZDoom 2.1, however. Could it be possible that this can make it into Zandronum 3.0, as this issue also exists in Zandronum?

I think this is the fix (NOTE: I AM NOT SURE OF ANY DEPENDENCIES THAT THIS MAY REQUIRE!):https://github.com/coelckers/gzdoom/commit/141065c3d5e8ffb237a5823766ace7621adae723 [^]

Demonstration PWAD Coordinates of bug: [21, 2360, ~ 41)
Demonstration PWAD:https://www.doomworld.com/idgames/levels/doom2/deathmatch/Ports/a-c/amisery [^]
Attached Filespng file icon GZDoom 2.0.png [^] (720,482 bytes) 2016-03-30 19:58
png file icon GZDoom 2.2pre.png [^] (765,180 bytes) 2016-03-30 19:59

- Relationships

-  Notes
User avatar (0014654)
Torr Samaho (administrator)
2016-04-03 12:16

I transplanted the fix you linked to 3.0.
User avatar (0014664)
Tiger (reporter)
2016-04-03 17:02

Amazing! Thank you!
User avatar (0014675)
Tiger (reporter)
2016-04-07 03:20

Using build 3.0-alpha @ 160403-1900 - Commit 96e0e5e40e46, (credit to WaTaKiD), this seems to be working just fine for me. Thank you for adding this! :)

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-03-30 19:58 Tiger New Issue
2016-03-30 19:58 Tiger File Added: GZDoom 2.0.png
2016-03-30 19:59 Tiger File Added: GZDoom 2.2pre.png
2016-03-30 20:04 Tiger Note Added: 0014621
2016-03-30 20:10 Dusk Description Updated View Revisions
2016-03-30 20:11 Dusk Note Deleted: 0014621
2016-04-03 12:16 Torr Samaho Note Added: 0014654
2016-04-03 12:16 Torr Samaho Assigned To => Torr Samaho
2016-04-03 12:16 Torr Samaho Status new => needs testing
2016-04-03 17:02 Tiger Note Added: 0014664
2016-04-07 03:20 Tiger Note Added: 0014675
2016-04-08 19:12 Dusk Status needs testing => resolved
2016-04-08 19:12 Dusk Fixed in Version => 3.0
2016-04-08 19:12 Dusk Resolution open => fixed
2018-09-30 22:05 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker