Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002687Zandronum[All Projects] Bugpublic2016-03-30 18:052018-09-30 22:04
ReporterTiger 
Assigned ToTorr Samaho 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDesktop (x86_64)OSWindowsOS Version6.3
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002687: BotEpisode Does not Work
DescriptionWhen a Episode uses the 'BotEpisode' property, Zandronum 3.0 (160229-1221) will ignore the property and not prompt the end-user with a 'Bot Skill Level'. This works fine in Zandronum 2.1.2, however, it seems the issue occurred somewhere in Zandronum 3.0.

Attached to this ticket is a demonstration PWAD for this issue.
Attached Files7z file icon BotEpisode.7z [^] (5,357 bytes) 2016-03-30 18:05

- Relationships

-  Notes
User avatar (0014645)
cobalt (updater)
2016-04-02 18:14

Issue addressed by commit fb056f043a73: Restored support for Skulltag's bot episode menus (configured by the MAPINFO episode properties botepisode, botskillname and botskillpicname), addresses 2687.
Committed by Benjamin Berkels [Torr Samaho] on Wednesday 31 December 1969 23:59:57

Changes in files:

 src/g_level.h | 4 ++++
 src/g_mapinfo.cpp | 18 ++++--------------
 src/menu/menu.cpp | 43 ++++++++++++++++++++++++++++++++++++++++++-
 src/namedef.h | 3 +++
 wadsrc/static/menudef.za | 19 ++++++++++++++++++-
 5 files changed, 71 insertions(+), 16 deletions(-)

User avatar (0014677)
Tiger (reporter)
2016-04-07 03:33

Using build 3.0-alpha @ 160403-1900 - Commit 96e0e5e40e46, (credit to WaTaKiD), this seems to be fixed for me. However, in contrast, when the user is already playing, the user can not start a new game. Instead, they'll receive this message "You can't start a new game while in a network game.". In order to start a new game while having the CMPGINF, the end-user must completely restart the zandronum engine.

For example, if at first the player was already playing with the Bot Skill set as 'Nightmare', but later changed their minds and tried to start a new game - it'll be impossible. The user must first restart Zandronum and then set the botskill accordingly to their preference.
User avatar (0014678)
Dusk (developer)
2016-04-08 19:11

The problem regarding that is in menu.cpp:465: the if statement tests network state against NETSTATE_SINGLE when it should be using NETWORK_InClientMode().
User avatar (0014680)
Torr Samaho (administrator)
2016-04-09 11:39

I replaced the check you mentioned with
NETWORK_GetState( ) == NETSTATE_CLIENT

Using "New game" when playing a client side demo seemed to work fine at first glance, so I didn't use NETWORK_InClientMode(). Needs further testing if it's ok to keep it like it is now, or if starting a new game while playing a demo causes unforeseen side effects.
User avatar (0014682)
cobalt (updater)
2016-04-09 11:44

Issue addressed by commit 5947ceecd7d3: Fixed: It was not possible to start a new game with the menu while the fake multiplayer mode was active.
Committed by Benjamin Berkels [Torr Samaho] on Wednesday 31 December 1969 23:59:57

Changes in files:

 src/menu/menu.cpp | 4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

User avatar (0014715)
Ru5tK1ng (updater)
2016-04-15 03:28

Tested this with r160410-1037. I played a demo and was able to bring up the bot episode menu without restarting the client.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-03-30 18:05 Tiger New Issue
2016-03-30 18:05 Tiger File Added: BotEpisode.7z
2016-04-02 16:38 Torr Samaho Assigned To => Torr Samaho
2016-04-02 16:38 Torr Samaho Status new => assigned
2016-04-02 18:14 cobalt Status assigned => needs testing
2016-04-02 18:14 cobalt Target Version => 3.0
2016-04-02 18:14 cobalt Description Updated View Revisions
2016-04-02 18:14 cobalt Note Added: 0014645
2016-04-07 03:33 Tiger Note Added: 0014677
2016-04-08 19:11 Dusk Note Added: 0014678
2016-04-08 19:12 Dusk Status needs testing => assigned
2016-04-09 11:39 Torr Samaho Note Added: 0014680
2016-04-09 11:44 cobalt Status assigned => needs testing
2016-04-09 11:44 cobalt Note Added: 0014682
2016-04-15 03:28 Ru5tK1ng Note Added: 0014715
2016-04-15 03:29 Ru5tK1ng Status needs testing => resolved
2016-04-15 03:29 Ru5tK1ng Resolution open => fixed
2016-04-15 03:29 Ru5tK1ng Fixed in Version => 3.0
2016-04-15 03:29 Ru5tK1ng Description Updated View Revisions
2018-09-30 22:04 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker