Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002580Zandronum[All Projects] Bugpublic2016-01-16 21:452018-09-30 21:40
ReporterIvan 
Assigned ToEdward-san 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target Version2.2Fixed in Version2.2 
Summary0002580: SetMugshotState crashes online game
DescriptionThis thing crashes all online games whereas in singleplayer no crashes occur.

Minimal example wad:https://www.dropbox.com/s/1r1d123v0n6adq9/grintest.pk3?dl=0 [^]
Steps To Reproduce- Join a local server, I think any game mode will cause crash.
- As soon as you join, you crash.
Attached Files? file icon grintestdelayed.pk3 [^] (528 bytes) 2016-01-17 17:07

- Relationships

-  Notes
User avatar (0014101)
Edward-san (developer)
2016-01-17 12:04

This happens also in zandronum 2.x.
User avatar (0014106)
Edward-san (developer)
2016-01-17 16:42

https://bitbucket.org/Torr_Samaho/zandronum-stable/pull-requests/19 [^]
User avatar (0014107)
Edward-san (developer)
2016-01-17 17:05
edited on: 2016-01-17 17:08

Keep in mind that ZDoom multiplayer changes the mugshot to all the players, so this fix respects that. If you want to change the mugshot only for specific players, you must ask the ZDoom forum as a suggestion (verified this using the attached pk3, which changes the mugshot 4 seconds after entering the map/joining the game).

User avatar (0014110)
Ivan (reporter)
2016-01-17 19:13

Wait, so I can't just set the mugshot of the player that's running the script? That's totally useless in this case... My use case is the following:

- Replaced all weapons with custom inventories, and I made my own pickup stuff. The player's face doesn't change when he picks these items, so that's a problem. A minor one, but still, it's a use case.
User avatar (0014118)
cobalt (updater)
2016-01-17 20:53

Issue addressed by commit c4b9e45e68df: - Fixed: The ACS function SetMugshotState was not handled properly online (fixes 2580).
Committed by Edoardo Prezioso [edward-san] on Wednesday 31 December 1969 23:59:57

Changes in files:

 docs/zandronum-history.txt | 1 +
 src/cl_main.cpp | 11 +++++++++++
 src/network_enums.h | 1 +
 src/p_acs.cpp | 11 ++++++++++-
 src/sv_commands.cpp | 9 +++++++++
 src/sv_commands.h | 1 +
 6 files changed, 33 insertions(+), 1 deletions(-)

User avatar (0014128)
Torr Samaho (administrator)
2016-01-18 07:03

Edward-san, please see my comment in the commit:https://bitbucket.org/crimsondusk/zandronum-sandbox-stable/commits/7b3ea27e9f961bad5ed3c102264d6446e34d9628?at=default [^]

If I address this, then one could have (albeit somewhat hackish) per player mug shots with client side scripts and a ConsolePlayerNumber check.
User avatar (0014272)
Ru5tK1ng (updater)
2016-01-31 23:19

I couldn't get the client to crash with 160131-2023 like I could with 2.x. Seems to be fixed.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-01-16 21:45 Ivan New Issue
2016-01-17 00:50 Arco Severity minor => crash
2016-01-17 00:50 Arco Status new => confirmed
2016-01-17 12:04 Edward-san Note Added: 0014101
2016-01-17 12:04 Edward-san Assigned To => Edward-san
2016-01-17 12:04 Edward-san Status confirmed => assigned
2016-01-17 12:04 Edward-san Product Version 3.0-beta => 2.1
2016-01-17 16:42 Edward-san Note Added: 0014106
2016-01-17 16:42 Edward-san Status assigned => needs review
2016-01-17 17:05 Edward-san Note Added: 0014107
2016-01-17 17:07 Edward-san File Added: grintestdelayed.pk3
2016-01-17 17:08 Edward-san Note Edited: 0014107 View Revisions
2016-01-17 19:13 Ivan Note Added: 0014110
2016-01-17 20:53 cobalt Status needs review => needs testing
2016-01-17 20:53 cobalt Target Version => 2.2
2016-01-17 20:53 cobalt Description Updated View Revisions
2016-01-17 20:53 cobalt Steps to Reproduce Updated View Revisions
2016-01-17 20:53 cobalt Note Added: 0014118
2016-01-18 07:03 Torr Samaho Note Added: 0014128
2016-01-18 07:05 Torr Samaho Status needs testing => feedback
2016-01-24 21:15 Edward-san Status feedback => needs testing
2016-01-31 23:19 Ru5tK1ng Note Added: 0014272
2016-01-31 23:27 Dusk Status needs testing => resolved
2016-01-31 23:27 Dusk Fixed in Version => 2.2
2016-01-31 23:27 Dusk Resolution open => fixed
2018-09-30 21:40 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker