Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001793Zandronum[All Projects] Suggestionpublic2014-05-04 02:052018-09-30 23:14
ReporterDusk 
Assigned ToDusk 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0-beta 
Target Version2.0Fixed in Version2.0 
Summary0001793: Conversion of sv_commands.cpp to NetCommand
Descriptionlast time on Zandronum Developer Network (cue theme music):

Quote from Dusk

As a collaboration between Water and I we're going through sv_commands.cpp right now and updating the server commands to NetCommand.


Quote from Dusk

It's done, I think. I tested it as well as I could, played some russian overkill against bots and ran some zpack and tested the manipulator function stuff more intricately. I can't really test it myself any better than that.


Quote from Torr Samaho

Thanks! That's definitely massive. I'll skim through the diff, make some local tests and then (assuming all goes well) pull it.


old pull request:https://bitbucket.org/Torr_Samaho/zandronum/pull-request/34/dusk-watermelon-converted-all-server [^] (warning, mega-lag page)
basically, stuff still needed to be done.
Attached Files

- Relationships
child of 0001777newDusk Serverside demos 

-  Notes
User avatar (0008682)
Dusk (developer)
2014-05-04 02:09

These commits should address the concerns mentioned in the initial bitbucket pull request
https://bitbucket.org/CrimsonDusk/zandronum/commits/74654d7b33cc92baf0ea09454b55daa06dd295e8 [^]
https://bitbucket.org/CrimsonDusk/zandronum/commits/90aa9ea5f9b58516576168230efa35ed72247ec7 [^]
User avatar (0008683)
Torr Samaho (administrator)
2014-05-04 08:28

Great, I think that's much nicer than the manipulators!

I briefly went through the whole diff and only noticed minor things:
- SERVERCOMMANDS_SetPlayerStatus, SERVERCOMMANDS_UpdatePlayerPing and SERVERCOMMANDS_UpdatePlayerTime also lost their validity check.
- You added sendCommandToOneClient, but at some places you still added "command.sendCommandToClients ( ulClient, SVCF_ONLYTHISCLIENT )". I suggest to search for SVCF_ONLYTHISCLIENT and use sendCommandToOneClient where possible.

Other than that the patch looks fine (at least from a brief diff, the changes are way too massive to be read in full detail).
User avatar (0008690)
Dusk (developer)
2014-05-04 12:31

https://bitbucket.org/CrimsonDusk/zandronum/commits/77199858b4be06c002765852041c96963869c13a [^]
https://bitbucket.org/CrimsonDusk/zandronum/commits/595cb981581c1e706fa513927e8d7cff2684b956 [^]
https://bitbucket.org/CrimsonDusk/zandronum/commits/dc00a1b8f2e1160b5897e233a35e6257097da6a0 [^]
User avatar (0008691)
Torr Samaho (administrator)
2014-05-04 13:05

Looks good!
User avatar (0009913)
StrikerMan780 (reporter)
2014-07-09 02:05

What specifically needs to be tested here?
User avatar (0009915)
Konar6 (reporter)
2014-07-09 07:37

I assume a normal client/server gameplay is to be thoroughly tested here, since the fundamental server-to-clients command sending system was modified.
User avatar (0009917)
StrikerMan780 (reporter)
2014-07-09 11:53

As in console commands, or sending/receiving data? (General Netcode)
User avatar (0009922)
Torr Samaho (administrator)
2014-07-09 20:38

The general net code that handles sending information from the server to the clients.
User avatar (0009925)
StrikerMan780 (reporter)
2014-07-09 20:45
edited on: 2014-07-09 20:45

Alrighty. Sounds pretty cool. Gonna guess this really helps clean up/simplify the netcode? I'll see about hosting some games perhaps.

User avatar (0009976)
Arco (updater)
2014-07-15 23:57

I tested all the server commands available in v2.0 r140712-0929 and below and nothing seems broken.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2014-05-04 02:05 Dusk New Issue
2014-05-04 02:05 Dusk Status new => assigned
2014-05-04 02:05 Dusk Assigned To => Dusk
2014-05-04 02:09 Dusk Note Added: 0008682
2014-05-04 02:09 Dusk Status assigned => needs review
2014-05-04 02:16 Dusk Relationship added parent of 0001777
2014-05-04 02:16 Dusk Relationship replaced child of 0001777
2014-05-04 08:28 Torr Samaho Note Added: 0008683
2014-05-04 08:31 Torr Samaho Status needs review => feedback
2014-05-04 12:31 Dusk Note Added: 0008690
2014-05-04 12:31 Dusk Status feedback => assigned
2014-05-04 12:31 Dusk Status assigned => needs review
2014-05-04 13:05 Torr Samaho Note Added: 0008691
2014-05-04 13:34 Dusk Status needs review => needs testing
2014-07-09 02:05 StrikerMan780 Note Added: 0009913
2014-07-09 07:37 Konar6 Note Added: 0009915
2014-07-09 11:53 StrikerMan780 Note Added: 0009917
2014-07-09 20:38 Torr Samaho Note Added: 0009922
2014-07-09 20:45 StrikerMan780 Note Added: 0009925
2014-07-09 20:45 StrikerMan780 Note Edited: 0009925 View Revisions
2014-07-15 23:57 Arco Note Added: 0009976
2014-07-15 23:57 Arco Status needs testing => resolved
2014-07-15 23:57 Arco Resolution open => fixed
2014-07-15 23:57 Arco Product Version => 2.0-beta
2014-07-15 23:57 Arco Fixed in Version => 2.0
2018-09-30 23:14 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker