Zandronum Chat on our Discord Server Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001383Zandronum[All Projects] Bugpublic2013-06-25 18:532018-09-30 21:34
Reporterbluewizard 
Assigned ToTorr Samaho 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.0 
Target VersionFixed in Version1.3 
Summary0001383: Clients don't fully reset effects of client side scripts during a map reset
Description-This only bugs out if done online-
1. Start server with just that wad.
2. Set the game mode to survival.
3. Join the game.

During the countdown you'll notice that "clientside: test = 1", however after the countdown is finished, it will say "clientside: test = 2" when it actually should be 1.

Interestingly enough, this does -not- happen if you do an offline survival skirmish.

If you'd like an actual mod is broken by this bug, try this:http://speedy.sh/P9d3v/DeathRace.pk3 [^] (Needs actors/data)

If you load this in single player and do an offline last man standing skirmish on race01, the clientside camera works just fine after the countdown. However, if you host this online and try to play, the camera will break after the countdown is finished.
Attached Files? file icon testbug.wad [^] (409 bytes) 2013-06-25 18:54

- Relationships
child of 0001331acknowledged New GAMEMODE flag: COUNTDOWN 

-  Notes
User avatar (0006510)
Torr Samaho (administrator)
2013-06-25 18:58

The client is missing the part of the map reset logic that handles these ACS script effects. I can fix this, but this needs thorough testing, so I'm unsure whether I should include the fix in 1.1. Would anybody volunteer to do thorough testing of the fix on a range of mods that use ACS scripts?
User avatar (0006512)
bluewizard (reporter)
2013-06-25 20:43

Yes I would like this in 1.1. As for wads, I have two mods I was working on that was affected by this bug. (Yes I'll test)
User avatar (0006513)
Torr Samaho (administrator)
2013-06-26 19:59

This contains a first attempt on a fix. It would be very important to test how OPEN and ENTER scripts behave, both client side and normal scripts.
User avatar (0006514)
bluewizard (reporter)
2013-06-27 01:10

This is working perfectly online/offline with bots.
User avatar (0006519)
ibm5155 (reporter)
2013-06-28 21:36

Didn´t fixed for me on (void) scripts =/
User avatar (0006520)
Edward-san (developer)
2013-06-28 22:19

can you upload an example wad with this problem, ibm?
User avatar (0006521)
Torr Samaho (administrator)
2013-06-29 08:19

Quote from ibm5155
Didn´t fixed for me on (void) scripts =/

Without further information I can't say anything about this. Please elaborate exactly the problem you are having and, as Edward-san already said, include a minimal example wad.
User avatar (0006528)
ibm5155 (reporter)
2013-06-30 12:41
edited on: 2013-06-30 13:56

hmm ok I´ll elaborate an minimal example (with the lava bug and the clientside weather/red map)
Ok done.
On that wad i can show 3 bugs
1 switch: it´s a clientside script that actives when white face kills you, you´ll be teleported and the map´ll be red (when map restarts it´ll be the same color and not the original map color)
2 switch (not clientside): when the lava come up and u died, the map restart and the lava still there but invisible =/

3 (not with switches): when the rainfall actives on the prepare to fight, and when the map really start and it´s disabled, I´ll sometimes see the rain and the rainfall even if it´s now disabled.

http://www.mediafire.com/download/44dpue5msp1516y/ZM09_LE.wad, [^] tested online, map zm09 (almost all the scripts are there, just the textures was reduced to the minimal, wads to run:doom2.wad, skulltag_actors, skulltag_data126)

I wanted to show the portal bug too but it´s rare/random so I can´t =/

User avatar (0006538)
Torr Samaho (administrator)
2013-07-01 17:39

The map still has more than 1400 lines of script code. Please condense this to only the scripts that are necessary to reproduce the bugs.
User avatar (0006544)
ibm5155 (reporter)
2013-07-01 21:38
edited on: 2013-07-01 22:10

Ok here´s the map with only the short scripts (only the problematics one)
first bug:lava spawn on 3d floor (it doesn´t fully affect normal sectors), if you look, the "floor" texture from the 3d floor'll disapear on the restart of the map, and if you go down of it, you´ll die...

second:clientside script change the light and dynamic lights on the map, but when the map restart it doesn´t go back as it was.

third: while you see the prepare to fight mensage and the rainfall is selected, then after the map is "playable" and the rainfall is disabled, you see the rain.

Download:https://mega.co.nz/#!j9QViDxQ!IKFh5G0Ul1fwwcywBMt_FD9kwa4lNn_i2GK4dSZJHio [^]

(not on mediafire because he wasn´t uploading =/)

User avatar (0006545)
Dusk (developer)
2013-07-01 22:10

I think these should be separate tickets, based off the description they don't seem related to this one.
User avatar (0006546)
ibm5155 (reporter)
2013-07-01 22:30
edited on: 2013-07-01 22:43

Ok I´ll do it (I just thinked that it could put here because one of the problens are clientside related)

EDIT:
 http://zandronum.com/tracker/view.php?id=1388

User avatar (0011395)
Edward-san (developer)
2015-01-15 23:39
edited on: 2015-01-15 23:40

So, what's the problem which isn't fixed in this ticket yet?

User avatar (0011401)
Dusk (developer)
2015-01-16 10:39

The issue presented in the ticket appears fixed for me.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2013-06-25 18:53 Torr Samaho New Issue
2013-06-25 18:53 Torr Samaho Status new => assigned
2013-06-25 18:53 Torr Samaho Assigned To => Torr Samaho
2013-06-25 18:54 Torr Samaho File Added: testbug.wad
2013-06-25 18:58 Torr Samaho Note Added: 0006510
2013-06-25 19:10 Dusk Relationship added child of 0001331
2013-06-25 20:43 bluewizard Note Added: 0006512
2013-06-26 19:59 Torr Samaho Note Added: 0006513
2013-06-26 21:14 Torr Samaho Status assigned => needs testing
2013-06-27 01:10 bluewizard Note Added: 0006514
2013-06-27 18:56 Torr Samaho Product Version => 1.0
2013-06-28 21:36 ibm5155 Note Added: 0006519
2013-06-28 22:19 Edward-san Note Added: 0006520
2013-06-29 08:19 Torr Samaho Note Added: 0006521
2013-06-30 12:41 ibm5155 Note Added: 0006528
2013-06-30 13:56 ibm5155 Note Edited: 0006528 View Revisions
2013-07-01 17:39 Torr Samaho Note Added: 0006538
2013-07-01 17:40 Torr Samaho Status needs testing => feedback
2013-07-01 21:38 ibm5155 Note Added: 0006544
2013-07-01 22:10 Dusk Note Edited: 0006544 View Revisions
2013-07-01 22:10 Dusk Note Added: 0006545
2013-07-01 22:30 ibm5155 Note Added: 0006546
2013-07-01 22:43 ibm5155 Note Edited: 0006546 View Revisions
2015-01-15 23:39 Edward-san Note Added: 0011395
2015-01-15 23:40 Edward-san Note Edited: 0011395 View Revisions
2015-01-16 10:39 Dusk Note Added: 0011401
2015-01-16 10:39 Dusk Status feedback => resolved
2015-01-16 10:39 Dusk Fixed in Version => 1.3
2015-01-16 10:39 Dusk Resolution open => fixed
2015-01-16 10:39 Dusk Reporter Torr Samaho => bluewizard
2015-01-16 10:39 Dusk Description Updated View Revisions
2018-09-30 21:34 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker