Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000796Zandronum[All Projects] Bugpublic2012-04-21 00:532024-02-04 22:33
ReporterDusk 
Assigned ToDusk 
PrioritynormalSeveritymajorReproducibilityalways
Statusneeds testingResolutionreopened 
PlatformOSOS Version
Product Version1.0-beta 
Target Version3.2Fixed in Version 
Summary0000796: [Hexen] Flechettes lack netcode altogether
DescriptionWOO ANOTHER ONE
Steps To ReproduceJoin an online game as a fighter and grab a flechette and cast it. The flechette flies through trees... and even appears to explode where the client percieves the flechette to have landed. They normally bounce off them.
Attached Filesdiff file icon flechettefixpatch.diff [^] (2,213 bytes) 2024-01-09 20:31 [Show Content]
diff file icon flechettefixpatch2.diff [^] (2,326 bytes) 2024-01-29 04:13 [Show Content]

- Relationships
parent of 0002948new SetThingFlags: couldn't find actor 
parent of 0002949new MoveThingExact: couldn't find actor 
Not all the children of this issue are yet resolved or closed.

-  Notes
User avatar (0003352)
Dusk (developer)
2012-04-21 01:46

I went over the flechette code and added network handling where appropriate:
'https://bitbucket.org/CrimsonDusk/notebola/changeset/e4934b53af72 [^]'

But I guess something of this magnitude needs to be tested on NE first before it can be even considered to be ported. And I still can't make windows builds of that...
User avatar (0003359)
Torr Samaho (administrator)
2012-04-21 16:46

Small remark: SERVERCOMMANDS_SetThingState should be called before the state is actually set on the server. This is consistently done everywhere so far.
User avatar (0003363)
Dusk (developer)
2012-04-21 17:30

Corrected:
'https://bitbucket.org/CrimsonDusk/notebola/changeset/d0cac35282c0 [^]'
User avatar (0014918)
Ru5tK1ng (updater)
2016-05-14 18:49

<WaTaKiD> the fighter flechettes should bounce off trees
<WaTaKiD> as is, they appear to explode on contact with a tree, however they actually desync and bounce elsewhere
User avatar (0022982)
Ru5tK1ng (updater)
2024-01-09 20:32

I have uploaded a patch that fixes the remaining issue here as well as the ones outlined in 2948 and 2949.
User avatar (0022997)
Torr Samaho (administrator)
2024-01-23 19:50

I had a quick look at the patch and wonder whether NETWORK_InClientMode() needs to be replaced with NETWORK_InClientModeAndActorNotClientHandled( this ). Otherwise, this will not work for client side actors.
User avatar (0023002)
Ru5tK1ng (updater)
2024-01-24 22:13

Wouldn't it still work with client side actors since the actual actor being spawned is ThrowingBomb? In this example code, the projectile is clientsided and scaled by 2.0:

ACTOR NewBomb : ThrowingBomb replaces ThrowingBomb
{
    +CLIENTSIDEONLY
    Scale 2.0
}

I tested this online and it seemed to work fine.
User avatar (0023019)
Torr Samaho (administrator)
2024-01-28 20:03
edited on: 2024-01-28 21:04

The problem would only occur if the actor calling AArtiPoisonBag3::Use is CLIENTSIDEONLY.

User avatar (0023027)
Ru5tK1ng (updater)
2024-01-29 04:13

I have uploaded a version 2 of the patch that considers client-side inventory use items.
User avatar (0023055)
Torr Samaho (administrator)
2024-02-04 20:24

Thanks! I added the updated patch.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: Combinebobnt
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2012-04-21 00:53 Dusk New Issue
2012-04-21 00:53 Dusk Status new => assigned
2012-04-21 00:53 Dusk Assigned To => Dusk
2012-04-21 00:54 Dusk Steps to Reproduce Updated View Revisions
2012-04-21 00:54 Dusk Steps to Reproduce Updated View Revisions
2012-04-21 01:46 Dusk Note Added: 0003352
2012-04-21 01:46 Dusk Status assigned => feedback
2012-04-21 16:46 Torr Samaho Note Added: 0003359
2012-04-21 17:30 Dusk Note Added: 0003363
2012-04-21 17:30 Dusk Status feedback => assigned
2012-04-21 17:30 Dusk Status assigned => feedback
2012-06-09 13:22 Torr Samaho Category General => Bug
2013-09-27 10:39 Dusk Status feedback => confirmed
2016-05-14 18:20 Ru5tK1ng Note Added: 0014913
2016-05-14 18:21 Ru5tK1ng Status confirmed => resolved
2016-05-14 18:21 Ru5tK1ng Resolution open => fixed
2016-05-14 18:49 Ru5tK1ng Note Added: 0014918
2016-05-14 18:49 Ru5tK1ng Status resolved => feedback
2016-05-14 18:49 Ru5tK1ng Resolution fixed => reopened
2016-05-14 18:49 Ru5tK1ng Note Deleted: 0014913
2016-05-14 19:08 Ru5tK1ng Status feedback => confirmed
2024-01-09 20:31 Ru5tK1ng File Added: flechettefixpatch.diff
2024-01-09 20:32 Ru5tK1ng Note Added: 0022982
2024-01-09 20:32 Ru5tK1ng Status confirmed => needs review
2024-01-09 20:32 Ru5tK1ng Target Version => 3.2
2024-01-23 19:50 Torr Samaho Note Added: 0022997
2024-01-24 22:13 Ru5tK1ng Note Added: 0023002
2024-01-28 20:03 Torr Samaho Note Added: 0023019
2024-01-28 21:04 Torr Samaho Note Edited: 0023019 View Revisions
2024-01-29 04:13 Ru5tK1ng File Added: flechettefixpatch2.diff
2024-01-29 04:13 Ru5tK1ng Note Added: 0023027
2024-02-04 20:24 Torr Samaho Note Added: 0023055
2024-02-04 20:24 Torr Samaho Status needs review => needs testing
2024-02-04 22:33 Ru5tK1ng Relationship added parent of 0002948
2024-02-04 22:33 Ru5tK1ng Relationship added parent of 0002949






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2024 MantisBT Team
Powered by Mantis Bugtracker