Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003954Doomseeker[All Projects] Bugpublic2021-12-21 20:002021-12-30 11:41
ReporterZalewa 
Assigned ToZalewa 
PrioritylowSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version1.3.2 
Target Version1.3.3Fixed in Version1.3.3 
Summary0003954: cacerts.pem contains expired certificate for Let's Encrypt - affects Windows XP
DescriptionThe Let's Encrypt certificate that is distributed with Doomseeker has expired in September:
Quote

# Issuer: O=Digital Signature Trust Co., CN=DST Root CA X3
# Validity
# Not Before: Sep 30 21:12:19 2000 GMT
# Not After : Sep 30 14:01:15 2021 GMT
# Subject: O=Digital Signature Trust Co., CN=DST Root CA X3
# Note: verifies "Let's Encrypt"


If we still want to support Windows XP, we need to update that.

Additional InformationWithout this the following features don't work:
1. Auto-updates
2. IP2C auto-updates
3. WAD downloads (most likely)
Attached Files

- Relationships

-  Notes
User avatar (0021973)
Blzut3 (administrator)
2021-12-22 03:29

The XP user base is small enough that I think if it starts giving you trouble it may be time to consider dropping it. I'm guessing that updating the cacerts isn't a huge deal so this probably isn't the reason to do it, but at some point it will probably become a hassle to update OpenSSL and certainly by the time we switch to Qt 6 (which sadly only supports Windows 10/11).
User avatar (0021974)
WubTheCaptain (developer)
2021-12-22 04:30

0003267:0018459. Drop it.
Off-topic:https://wiki.guildwars.com/wiki/Feedback:Developer_updates/20201109 [^]
User avatar (0022050)
Zalewa (developer)
2021-12-29 15:01
edited on: 2021-12-29 15:01

Since it's not a big trouble, I decided to do this (even if it's for the last time).

https://bitbucket.org/Doomseeker/doomseeker/commits/9a5a35b2efd7adabb0d9fab970349253bf11ef86 [^]

I already tested that on my Win XP VM and adding this cert repairs "Install Freedoom", "Update IP2C" and Wadseeker.

User avatar (0022053)
WubTheCaptain (developer)
2021-12-30 11:41

Re: commit, counter-proposal to deprecate Windows XP support at 0003964.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2021-12-21 20:00 Zalewa New Issue
2021-12-22 03:29 Blzut3 Note Added: 0021973
2021-12-22 04:30 WubTheCaptain Note Added: 0021974
2021-12-22 04:38 WubTheCaptain Status new => acknowledged
2021-12-27 22:58 Zalewa Target Version => 1.3.3
2021-12-28 11:08 WubTheCaptain Status acknowledged => confirmed
2021-12-29 15:01 Zalewa Note Added: 0022050
2021-12-29 15:01 Zalewa Status confirmed => resolved
2021-12-29 15:01 Zalewa Fixed in Version => 1.3.3
2021-12-29 15:01 Zalewa Resolution open => fixed
2021-12-29 15:01 Zalewa Assigned To => Zalewa
2021-12-29 15:01 Zalewa Note Edited: 0022050 View Revisions
2021-12-30 11:41 WubTheCaptain Note Added: 0022053






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2022 MantisBT Team
Powered by Mantis Bugtracker