Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003778Doomseeker[All Projects] Suggestionpublic2020-04-09 07:082020-05-20 05:28
Reporterauratoostronk 
Assigned ToWubTheCaptain 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutioninvalid 
PlatformPCOSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0003778: Double ammo set to "true" by default in Offline Skirmishes
DescriptionAny reason for this? As a mod developer, this has caused me a lot of issues, as my cooldown system needs to use ammo child classes to show cooldown bars on the status bar, or I get a bunch of error codes in the console while the game loads up. With the option on, it messes with the cooldown system, and somewhat breaks the balance of the mod. Wouldn't it make sense to keep it off by default, and allow people to turn it on if they want?
Attached Filespng file icon 2020-04-28-035822_maim.png [^] (66,508 bytes) 2020-04-28 04:01

- Relationships

-  Notes
User avatar (0021288)
WubTheCaptain (developer)
2020-04-28 04:00

Do you mean the "create game" dialog? With a new Doomseeker configuration, it is disabled by default.

I also tried launching an offline game, sv_doubleammo is "false" as intended.
User avatar (0021290)
auratoostronk (reporter)
2020-04-28 16:14

Offline games have it set to true for me. Is there any reason this might be?
User avatar (0021292)
WubTheCaptain (developer)
2020-04-29 10:43

Which Doomseeker release and which engine/game plugin?
User avatar (0021293)
WubTheCaptain (developer)
2020-04-29 10:45

(For the record, the screenshot shows server hosting but I had actually checked it to be the same with singleplayer games in Create Game.)
User avatar (0021330)
WubTheCaptain (developer)
2020-05-10 17:29

Please re-open if you can find reproducible steps for the issue.
User avatar (0021331)
WubTheCaptain (developer)
2020-05-10 17:30

For the record, Create Game remembers your last option in the window until you start a game/server with a different option IIRC.
User avatar (0021339)
auratoostronk (reporter)
2020-05-19 02:49

Sorry for the late reply. I'm not referring to Doomseeker, but Zandronum's built-in offline skirmish option in Multiplayer Options. It sets double ammo to true, as well as some other weird things like jumping being enabled but crouching being disabled. I did find a workaround for my mod, however.
User avatar (0021340)
WubTheCaptain (developer)
2020-05-20 05:28

Though I could move this issue to the Zandronum project, the comprehension is not great so I suggest to report another issue to the right project.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2020-04-09 07:08 auratoostronk New Issue
2020-04-28 04:00 WubTheCaptain Note Added: 0021288
2020-04-28 04:00 WubTheCaptain Assigned To => WubTheCaptain
2020-04-28 04:00 WubTheCaptain Status new => feedback
2020-04-28 04:01 WubTheCaptain File Added: 2020-04-28-035822_maim.png
2020-04-28 16:14 auratoostronk Note Added: 0021290
2020-04-28 16:14 auratoostronk Status feedback => assigned
2020-04-29 10:43 WubTheCaptain Note Added: 0021292
2020-04-29 10:43 WubTheCaptain Status assigned => feedback
2020-04-29 10:45 WubTheCaptain Note Added: 0021293
2020-05-10 17:29 WubTheCaptain Note Added: 0021330
2020-05-10 17:29 WubTheCaptain Status feedback => resolved
2020-05-10 17:29 WubTheCaptain Resolution open => unable to reproduce
2020-05-10 17:30 WubTheCaptain Note Added: 0021331
2020-05-19 02:49 auratoostronk Note Added: 0021339
2020-05-19 02:49 auratoostronk Status resolved => feedback
2020-05-19 02:49 auratoostronk Resolution unable to reproduce => reopened
2020-05-20 05:28 WubTheCaptain Note Added: 0021340
2020-05-20 05:28 WubTheCaptain Status feedback => resolved
2020-05-20 05:28 WubTheCaptain Resolution reopened => invalid






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker