Zandronum Chat on our Discord Server Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003727Zandronum[All Projects] Suggestionpublic2019-12-13 09:202021-07-23 21:31
ReporterCinfinity 
Assigned Todoomjoshuaboy 
PrioritynormalSeverityminorReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformLinuxOSCinfinityOS Version4.x
Product Version3.0 
Target Version3.1Fixed in Version3.1 
Summary0003727: patch for sv_unblockdoors
DescriptionThis patch adds a cvar that prevents manual door closing, in order to
prevent large numbers of players from blocking a door by continuously
opening and closing it.

Eg.https://www.youtube.com/watch?v=Rx3qsnDmMs8&t=2807s [^]
Attached Filespatch file icon zandronum_3.0.1_unblockdoors.patch [^] (1,666 bytes) 2019-12-13 09:20 [Show Content]

- Relationships

-  Notes
User avatar (0021264)
mifu (reporter)
2020-04-11 03:51

I can confirm this is an issue, especially with large survival servers if many players try and open one door at the same time.
User avatar (0021271)
doomjoshuaboy (developer)
2020-04-19 21:38

this was added but made a better CVAR name for it. Thanks for the help.
User avatar (0021274)
Cinfinity (reporter)
2020-04-20 01:46

No worries. :)
User avatar (0021276)
Torr Samaho (administrator)
2020-04-20 19:54

I added the latest version of the patch.
User avatar (0021545)
Kaminsky (developer)
2020-09-29 18:46

I wanted to mention that this feature works as intended in 3.1-alpha-200501-1847. If "sv_nodoorclose" is set to true, doors can only be opened and never closed again; if set to false, they can be opened and closed.
User avatar (0021636)
Kaminsky (developer)
2021-07-23 21:31

Based on my comment from a few months ago, and the lack of any update since then, I consider this ticket to be resolved now.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: eagle mifu Kaminsky
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-12-13 09:20 Cinfinity New Issue
2019-12-13 09:20 Cinfinity File Added: zandronum_3.0.1_unblockdoors.patch
2020-04-11 03:51 mifu Note Added: 0021264
2020-04-19 21:25 doomjoshuaboy Assigned To => doomjoshuaboy
2020-04-19 21:25 doomjoshuaboy Status new => assigned
2020-04-19 21:38 doomjoshuaboy Note Added: 0021271
2020-04-19 21:38 doomjoshuaboy Status assigned => resolved
2020-04-19 21:38 doomjoshuaboy Fixed in Version => 3.1-beta
2020-04-19 21:38 doomjoshuaboy Resolution open => fixed
2020-04-19 22:58 Edward-san Status resolved => needs review
2020-04-19 22:58 Edward-san Resolution fixed => open
2020-04-19 22:58 Edward-san Fixed in Version 3.1-beta =>
2020-04-20 01:46 Cinfinity Note Added: 0021274
2020-04-20 19:54 Torr Samaho Note Added: 0021276
2020-04-20 19:54 Torr Samaho Status needs review => needs testing
2020-04-20 19:54 Torr Samaho Product Version 3.1-beta => 3.0
2020-04-20 19:54 Torr Samaho Target Version => 3.1
2020-09-29 18:46 Kaminsky Note Added: 0021545
2021-07-23 21:31 Kaminsky Note Added: 0021636
2021-07-23 21:31 Kaminsky Status needs testing => resolved
2021-07-23 21:31 Kaminsky Fixed in Version => 3.1
2021-07-23 21:31 Kaminsky Resolution open => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker