Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003657DoomseekerWadseeker sitespublic2019-06-10 19:562019-07-30 10:15
ReporterHiM 
Assigned ToWubTheCaptain 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutioninvalid 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version1.2 
Target Version1.3Fixed in Version 
Summary0003657: Doomseeker Wadseeker missing TSPG Painkiller wad path
DescriptionDoomseeker Wadseeker missing TSPG Painkiller wad path:
https://allfearthesentinel.net/zandronum/wads.php [^]

Wad path needs to be added to Doomseeker Wadseeker inorder to be able automatically download files.
Additional InformationTSPG Painkiller is major Zandronum doom hosting site/server farm.
Having automatic wad download with Doomseeker would ease process for novice users (need manual wad site add to site list).
Attached Files

- Relationships
duplicate of 0002881closedZalewa Add TSPG to default Wadseeker list 
related to 0003661closedWubTheCaptain Updates to default Wadseeker sites in code are not migrated to existing (not new) configurations 

-  Notes
User avatar (0020739)
HiM (reporter)
2019-06-10 20:13

The correct wad path: http://static.allfearthesentinel.net/wads [^]
User avatar (0020740)
AOSP (reporter)
2019-06-10 20:36

But it's already there:https://bitbucket.org/Doomseeker/doomseeker/src/ae456aac888cb794ea3292f7f99cb87d6b22a555/src/wadseeker/wadseeker.cpp#lines-45 [^]
User avatar (0020741)
HiM (reporter)
2019-06-10 20:52

Hmm, but it was not working until readded in 1.2 Doomseeker.
Maybe HTTP vs HTTPS is a cause? In Bitbucket is HTTPS.

Shouldnt it be coded as "http://static.allfearthesentinel.net/wads/" ?
User avatar (0020742)
Pol M (developer)
2019-06-10 22:21

Tested in a clean config, the default link works properly and can download wads. Https should always be preferred since it adds a layer of encryption that is always appreciated (you know, last thing we want is a man in the middle ;) ). Could you describe a reproducible environment where https does not work? If you test it on a clean config and it works, then this ticket may be set as resolved.
User avatar (0020748)
WubTheCaptain (developer)
2019-06-12 00:56

I believe this works as intended.
User avatar (0020749)
WubTheCaptain (developer)
2019-06-12 00:58

Specifically, I don't think we do config migrations from 1.0 to 1.2 with Wadseeker sites. But the site is there, since 1.1.

If this is an issue, report a new issue.
User avatar (0020751)
WubTheCaptain (developer)
2019-06-12 01:07

Quote from WubTheCaptain
If this is an issue, report a new issue.


...now 0003661.
User avatar (0020754)
WubTheCaptain (developer)
2019-06-12 01:31

(Setting this issue's status back to invalid, since OP reported the issue in Doomseeker 1.2 originally. I'll keep the duplicate tracker.)
User avatar (0020757)
Zalewa (developer)
2019-06-13 14:56

There's a "Always use Wadseeker's default sites" checkbox in the "Wadseeker/Sites" config page. If it's checked, Wadseeker will always use the up-to-date hardcoded sites, no matter what's on the list in the config page. If the checkbox is unchecked, only the sites listed on the page are used.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-06-10 19:56 HiM New Issue
2019-06-10 20:13 HiM Note Added: 0020739
2019-06-10 20:36 AOSP Note Added: 0020740
2019-06-10 20:52 HiM Note Added: 0020741
2019-06-10 22:21 Pol M Note Added: 0020742
2019-06-10 22:22 Pol M Status new => feedback
2019-06-12 00:56 WubTheCaptain Note Added: 0020748
2019-06-12 00:56 WubTheCaptain Status feedback => resolved
2019-06-12 00:56 WubTheCaptain Resolution open => invalid
2019-06-12 00:56 WubTheCaptain Assigned To => WubTheCaptain
2019-06-12 00:58 WubTheCaptain Note Added: 0020749
2019-06-12 01:01 WubTheCaptain Fixed in Version => 1.1
2019-06-12 01:05 WubTheCaptain Relationship added related to 0003661
2019-06-12 01:07 WubTheCaptain Note Added: 0020751
2019-06-12 01:09 WubTheCaptain Resolution invalid => fixed
2019-06-12 01:09 WubTheCaptain Product Version 1.2 => 1.0
2019-06-12 01:19 WubTheCaptain Relationship added duplicate of 0002881
2019-06-12 01:19 WubTheCaptain Resolution fixed => duplicate
2019-06-12 01:31 WubTheCaptain Note Added: 0020754
2019-06-12 01:31 WubTheCaptain Resolution duplicate => invalid
2019-06-12 01:31 WubTheCaptain Product Version 1.0 => 1.2
2019-06-13 14:56 Zalewa Note Added: 0020757
2019-06-14 03:55 WubTheCaptain Target Version => 1.3
2019-06-19 00:29 WubTheCaptain Fixed in Version 1.1 =>
2019-07-30 10:15 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker