Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003626Doomseeker[All Projects] Cleanuppublic2019-03-31 22:532019-04-18 19:37
ReporterWubTheCaptain 
Assigned ToPol M 
PrioritynormalSeverityminorReproducibilityhave not tried
Statusneeds reviewResolutionreopened 
PlatformOSOS Version
Product Version1.2 
Target Version1.3Fixed in Version1.3 
Summary0003626: Zandronum plugin's "Allow servers to display my country" option requires a restart for changes and/or is plain obsolete
DescriptionDoomseeker has a checkbox toggle for "Allow servers to display my country" in the Zandronum game engine plugin. Once enabled, on next restart it seems to set "+cl_hidecountry 0" to join command line. Toggle it off and it simply removes the option from join command line (your country is still broadcasted!), until you next time restart and it comes back alive as "+cl_hidecountry 1". The UI never tells you a restart is required, unlike with localization settings since Doomseeker 1.2 or so.

At least Zandronum 3.0 has the option "Hide country" in multiplayer settings, do we really need to configure this option from Doomseeker or support any earlier version? There are the hundreds of other client configuration knobs in Zandronum its we don't touch from Doomseeker, but this.
Steps To Reproduce
  1. Install Doomseeker with the Zandronum plugin.
  2. Run Doomseeker executable.
  3. Options → Configure (F5).
  4. Under game engines (at the top) is Zandronum. See there to find the option.
  5. Optional: Toggle at will and see how it does (or doesn't) affect "show join command line" of servers right clicked from the server browser.
Attached Files

- Relationships

-  Notes
User avatar (0020463)
WubTheCaptain (developer)
2019-03-31 22:57

I'm also saying, Zandronum can manage its own client configuration (zandronum.ini) just fine I'd guess.
User avatar (0020492)
Zalewa (developer)
2019-04-15 05:21

I'm inclined to say that this option can be removed altogether from Doomseeker to save us any trouble with maintaining it whatsoever. Pol, do with it what you think is best at your own discretion.

Since the game has been open-sourced the option is more of a "polite request" rather than requirement as everyone can just alter their servers to completely ignore it. Client's IP is still known to the server at all times and the country can always be derived from that. I actually think that's exactly what's already happening with cl_hidecountry 0 and I doubt that the country is broadcasted by the client.
User avatar (0020493)
Pol M (developer)
2019-04-15 09:54
edited on: 2019-04-15 11:05

If the parameter can be set in the ini, I'll certainly be inclined to removing it. Generally it's better to have all the configs in one place, so having this one set separately is no longer necessary.
EDIT: it's saved in the "cl_connect_flags", with a value of 4.

User avatar (0020494)
WubTheCaptain (developer)
2019-04-16 03:12
edited on: 2019-04-16 03:13

Someone could check if the "Hide country" option is available in Zandronum 2.1's multiplayer options, since we still do support Zandronum 2.1 in "Create game" while those old versioned servers are rare.

I'm still inclined to remove this feature from the plugin in Doomseeker, due to how Zandronum 3.0 handles it in its INI settings file and per Zalewa above.

User avatar (0020502)
Pol M (developer)
2019-04-18 16:02
edited on: 2019-04-18 16:25

Zandronum 2 does not give a gui way to hide your code country (I've looked at all the sections offered), and it's still saved in the .ini as cl_connect_flags with a value of 4. I still would remove it, since it's becoming more of an edge case (and when doomseeker 1.3 gets released Zandronum 2.0 servers may even no longer exist). You can always add the "+cl_hidecountry" parameter to your custom parameters.
PR if we all agree

User avatar (0020503)
Pol M (developer)
2019-04-18 16:51

approved
User avatar (0020505)
WubTheCaptain (developer)
2019-04-18 19:37

Needs changelog?

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-03-31 22:53 WubTheCaptain New Issue
2019-03-31 22:57 WubTheCaptain Note Added: 0020463
2019-03-31 22:58 WubTheCaptain Reproducibility always => have not tried
2019-04-14 23:07 Pol M Assigned To => Pol M
2019-04-14 23:07 Pol M Status new => assigned
2019-04-15 05:21 Zalewa Note Added: 0020492
2019-04-15 09:54 Pol M Note Added: 0020493
2019-04-15 11:05 Pol M Note Edited: 0020493 View Revisions
2019-04-15 11:05 Pol M Note Edited: 0020493 View Revisions
2019-04-16 02:57 WubTheCaptain Priority none => normal
2019-04-16 03:12 WubTheCaptain Note Added: 0020494
2019-04-16 03:13 WubTheCaptain Note Edited: 0020494 View Revisions
2019-04-18 16:02 Pol M Note Added: 0020502
2019-04-18 16:25 Pol M Note Edited: 0020502 View Revisions
2019-04-18 16:26 Pol M Status assigned => needs review
2019-04-18 16:51 Pol M Note Added: 0020503
2019-04-18 16:52 Pol M Status needs review => resolved
2019-04-18 16:52 Pol M Fixed in Version => 1.3
2019-04-18 16:52 Pol M Resolution open => fixed
2019-04-18 18:05 Pol M Target Version => 1.3
2019-04-18 19:37 WubTheCaptain Note Added: 0020505
2019-04-18 19:37 WubTheCaptain Status resolved => needs review
2019-04-18 19:37 WubTheCaptain Resolution fixed => reopened






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker