Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003546Doomseeker[All Projects] Bugpublic2018-10-08 09:192018-10-13 18:59
ReporterWubTheCaptain 
Assigned ToBlzut3 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003546: DRD Team's Debian Package Repository: Lintian warning package-name-doesnt-match-sonames libwadseeker1
Descriptionlibwadseeker package from debian.drdteam.org should be called libwadseeker1, not libwadseeker. This would fix a Lintian "package-name-doesnt-match-sonames libwadseeker1".

More importantly, users may experience a conflict with Debian and my packaging efforts of 0003246 if both libwadseeker and libwadseeker1 would end up installed with library code under two different package names.
Steps To Reproduce
$ dpkg -l libwadseeker*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  libwadseeker   1.1          amd64        Mod fetching library for Doom.
Additional InformationThis is just a heads up to you, Blzut3. I will be packaging Wadseeker as "libwadseeker1", matching the SONAME.

https://lintian.debian.org/tags/package-name-doesnt-match-sonames.html [^]
Attached Files

- Relationships
related to 0003242closedBlzut3 libwadseeker: Doesn't distinguish version from ELF shared object filename, ABI cannot safely change 
related to 0003246confirmedWubTheCaptain Debian packaging 

-  Notes
User avatar (0020002)
WubTheCaptain (developer)
2018-10-08 09:22
edited on: 2018-10-08 09:56

My proposal: Make libwadseeker a transitional package to libwadseeker1 on debian.drdteam.org.

This takes a trivial modification to the Debian build files in the existing libwadseeker package at debian.drdteam.org to move it. Then you'd create another transitional package, which just depends on libwadseeker1?

User avatar (0020003)
WubTheCaptain (developer)
2018-10-08 09:30
edited on: 2018-10-08 09:31

Fyi: libwadseeker 1.1 is unaffected, because it has no SONAME at all. But we still face this issue in the future, irregardless.

User avatar (0020004)
WubTheCaptain (developer)
2018-10-08 09:52

Here's also some guidance on how to make a transitional package:

https://wiki.debian.org/RenamingPackages [^]
https://wiki.debian.org/PackageTransition [^]
User avatar (0020036)
Blzut3 (administrator)
2018-10-08 21:04
edited on: 2018-10-08 21:07

This is already taken care of behind the scenes.

You can run `make package` and then `../releasescripts/cpackpostprocess.sh` to get the 1.2 release format. (Requires CMake 3.11 or newer for best results.)

User avatar (0020042)
WubTheCaptain (developer)
2018-10-08 22:05

...more if-else-fi soup, yuck. I don't understand the CPack stuff anyway, and I certainly don't understand the script despite reading the description and simplistic bash language code.

Anyway, mind explaining to me if the transitional packaging issue has been resolved?
User avatar (0020046)
Blzut3 (administrator)
2018-10-08 23:42

I was going to manually create a transition package as you suggested. This is also a transition from me hand jamming files into a deb to using CPack, so this will just happen behind the scenes for the DRD Team repo.
User avatar (0020048)
WubTheCaptain (developer)
2018-10-09 10:18

Resolving as "fixed" for 1.1 in 1.2, but only because of CPack stuff changes (and well, SONAME). There's no good resolution to use here.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-10-08 09:19 WubTheCaptain New Issue
2018-10-08 09:19 WubTheCaptain Status new => assigned
2018-10-08 09:19 WubTheCaptain Assigned To => Blzut3
2018-10-08 09:22 WubTheCaptain Note Added: 0020002
2018-10-08 09:23 WubTheCaptain Relationship added related to 0003242
2018-10-08 09:24 WubTheCaptain Note Edited: 0020002 View Revisions
2018-10-08 09:24 WubTheCaptain Relationship added related to 0003246
2018-10-08 09:25 WubTheCaptain Status assigned => new
2018-10-08 09:30 WubTheCaptain Note Added: 0020003
2018-10-08 09:31 WubTheCaptain Note Edited: 0020003 View Revisions
2018-10-08 09:31 WubTheCaptain Note Edited: 0020003 View Revisions
2018-10-08 09:52 WubTheCaptain Note Added: 0020004
2018-10-08 09:56 WubTheCaptain Note Edited: 0020002 View Revisions
2018-10-08 10:10 WubTheCaptain Status new => assigned
2018-10-08 10:10 WubTheCaptain Steps to Reproduce Updated View Revisions
2018-10-08 10:18 WubTheCaptain Priority normal => low
2018-10-08 10:18 WubTheCaptain Status assigned => new
2018-10-08 10:22 WubTheCaptain Note Added: 0020009
2018-10-08 10:29 WubTheCaptain Note Deleted: 0020009
2018-10-08 21:04 Blzut3 Note Added: 0020036
2018-10-08 21:07 Blzut3 Note Edited: 0020036 View Revisions
2018-10-08 22:05 WubTheCaptain Note Added: 0020042
2018-10-08 22:05 WubTheCaptain Status new => needs review
2018-10-08 23:42 Blzut3 Note Added: 0020046
2018-10-09 10:18 WubTheCaptain Note Added: 0020048
2018-10-09 10:18 WubTheCaptain Status needs review => resolved
2018-10-09 10:18 WubTheCaptain Resolution open => fixed
2018-10-09 10:18 WubTheCaptain Product Version 1.2 => 1.1
2018-10-09 10:18 WubTheCaptain Fixed in Version => 1.2
2018-10-13 18:59 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker