Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003543Doomseeker[All Projects] Bugpublic2018-10-07 10:462018-10-13 19:04
ReporterWubTheCaptain 
Assigned ToWubTheCaptain 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version1.2 
Target Version1.2Fixed in Version 
Summary0003543: "This program uses GeoLite2 database..." is displayed in the About dialog regardless if the database is loaded or not
Description0003512:0019976:

Quote from Zalewa
One last thing that concerns me:

With this commit the database has become an optional component. However, the "This program uses GeoLite2 database..." remains in the About dialog regardless if the database is loaded or not. Furthermore, there's an unrealistic but still possible chance of someone using some other data source to build IpToCountry.dat, which would make this statement even more false.

Should the statement be removed from the dialog if there's no database loaded?
Attached Files

- Relationships
child of 0003512closedZalewa MaxMind GeoLite2: Update from CC BY-SA 3.0 licensed dataset to newer CC BY-SA 4.0 licensed work 
child of 0003537closedZalewa Unbake IpToCountry.dat from executable (resources.qrc), make it optional 

-  Notes
User avatar (0019989)
WubTheCaptain (developer)
2018-10-07 10:46

I'm currently undecided.
User avatar (0019990)
WubTheCaptain (developer)
2018-10-07 10:47

0003512:0019977:

Quote from Blzut3
While I'm curious on Wub's opinion on the subject, I would say that trying to make the about dialog perfectly accurate is basically impossible. For example Qt5 versions of Doomseeker are technically LGPLv3 or GPLv3 since it's impossible to distribute the combined work otherwise. Similarly Qt4 builds would be LGPLv2.1 or LGPLv3 (not "or later"). And of course this all changes if someone paid for the commercial license for Qt where suddenly the Qt5 version can probably be LGPLv2.1 again.

And as you say technically some one could replace the third party files with ones from wherever which has more implications on the license text. So in my opinion I'd rather just leave it there and overstate.
User avatar (0019993)
WubTheCaptain (developer)
2018-10-07 11:14

There's too much work compared to a benefit of fixing this. It could be that this can also never be fixed. Perhaps it could be removed from the about dialog; but I'm undecided on that?

There could be hacks like loading a dummy game/engine plugin with the appropriate copyright notice for IP2C database. I'm not going to bother for the benefits.

Distributors may supply their own patches to the "About Doomseeker" dialog if they so desire.

The correct copyright notice, if anything, would be on GNU/Linux in the IP2C package for Doomseeker, whether the geolite packages directly or one converted from source package of that (or from doomseeker-blobs repository). I don't think this MaxMind copyright notice would even be included in the Doomseeker package for GNU/Linux, unless it also combined the works of two packages into one package.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-10-07 10:46 WubTheCaptain New Issue
2018-10-07 10:46 WubTheCaptain Note Added: 0019989
2018-10-07 10:46 WubTheCaptain Status new => confirmed
2018-10-07 10:47 WubTheCaptain Note Added: 0019990
2018-10-07 10:47 WubTheCaptain Relationship added related to 0003512
2018-10-07 10:52 WubTheCaptain Relationship added child of 0003537
2018-10-07 10:53 WubTheCaptain Assigned To => WubTheCaptain
2018-10-07 11:05 WubTheCaptain Relationship replaced child of 0003512
2018-10-07 11:14 WubTheCaptain Note Added: 0019993
2018-10-07 11:14 WubTheCaptain Status confirmed => resolved
2018-10-07 11:14 WubTheCaptain Resolution open => won't fix
2018-10-09 11:18 WubTheCaptain Target Version => 1.2
2018-10-13 19:04 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker