Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003510Doomseeker[All Projects] Suggestionpublic2018-09-22 23:072018-10-13 19:01
ReporterWubTheCaptain 
Assigned ToWubTheCaptain 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version1.1 
Target VersionFixed in Version 
Summary0003510: Remove SRB2 engine plugin distribution
DescriptionSRB2 is a legal minefield I wouldn't want any of the Doomseeker developers to be directly involved with. I suggest to let the SRB2 team to take responsibility of distributing (and developing) their engine plugin if they so desire, while Doomseeker could still support the required APIs for functionality. Doomseeker already supports loading plugins from an "engines" directory.

This is not about Debian policy; It's weighting the risks to rights of Sega and stuff.

More of my personal reasoning is available in ticket 0003237. Moving conversation to this ticket here.

I say: Sad game.
Additional InformationThis ticket partially contradicts 0002540.
Attached Filesdiff file icon optional-plugins.diff [^] (1,308 bytes) 2018-09-24 00:20 [Show Content]

- Relationships
related to 0002540closedZalewa Add Support for SRB2 . 
related to 0003532closedBlzut3 Missing game plugins in source distribution, though optional for use, are still mandatory to exist to build from source 
child of 0003237closedWubTheCaptain Non-free files and copyright issues in source archive 

-  Notes
User avatar (0019672)
WubTheCaptain (developer)
2018-09-22 23:13

Quote from WubTheCaptain
risks to rights of Sega and stuff.


risks to rights of Sega and liability to Doomseeker's developers*
User avatar (0019673)
Blzut3 (administrator)
2018-09-22 23:18

SRB2 has been around, and relatively well known, for long enough that I'm not concerned about any risk to us. Remember that this is also a community well known for illegally transplanting textures from one game into another, so I think ostracizing SRB2 is a little silly.

That said we can look into making the plugin easy to delete.
User avatar (0019684)
Zalewa (developer)
2018-09-23 07:33

Quote from Blzut3
That said we can look into making the plugin easy to delete.

Shift+DEL/`rm` on the lib is not easy enough?


Quote from Wub
Remove SRB2 engine plugin distribution

No. Only if we receive C&D from Sega then yes.
User avatar (0019697)
Blzut3 (administrator)
2018-09-24 00:21

I was thinking something like the attached patch so that it would not be necessary to redist the potentially offending sources. I don't know if it would help. The farthest I would be willing to go though is making them a subrepo.
User avatar (0019702)
Zalewa (developer)
2018-09-24 15:47

The patch is a good and harmless addition, I think we can merge it in.
User avatar (0019814)
Zalewa (developer)
2018-09-29 10:31
edited on: 2018-09-29 10:33

My initial response was too laconic in my vain hope to save time on something that I believe should never be considered (that said, it's saturday and I've already spent 2.5 hours just responding to tickets and having written no actual code at all, ie. Doomseeker is still stuck where it was and my free-free time today is running out). I'd like to reiterate so that we can conclude this matter.

First things first: complete removal of a feature is the last thing that should be considered when there is a problem with said feature. Our first approach should be to seek how to remedy the problems and keep the feature. I'm not very fond of tickets that outright state "Remove X".

Of course, there are valid reasons to remove features, delete their whole code and forget they ever existed. Let's try to state some events when such action should be considered:

* When we know that the feature is useless. However, in our case we don't collect any data on user behavior (and that's the way it should be), so we can't be truly sure that we know such thing.

* When the reason the feature was implemented is no longer valid. In this case: if SRB2 dies off, there will be no reason to keep the plugin and it should be either removed altogether or moved to the legacy section as has happened to the Vavoom plugin. We don't spend time on maintaining the legacy plugins. Another example is the ZDaemon plugin which was completely removed after ZDaemon devs encrypted their protocol to block our plugin off.

* When the maintenance cost vastly outweights the benefits this feature brings. We had a multi-threaded server refresh mechanism once. While it was nice to utilize the whole CPU and not just one core, it brought in some concurrency issues that were hard to deal with. Server refresh is now single-threaded.

* When we have a superior feature that effectively replaces the outdated one, even if it means that users will have to adjust.

* Soft but valid reasons for removal are when an affected party directly asks us to do so. Examples: default Chocolate Doom IRC channel removed on Fraggle's request, Wadseeker URLs were altered or removed on their webmaster's request, ZDaemon plugin was removed after the devs got pissed off at us for reverse-engineering their protocol.


Getting back to the issue at hand, Wub, let me quote you:

Quote from Wub
[on legal issues] SRB2: It's complicated. Not okay with me personally by legal hunch.

[...]

I am not a lawyer. Not legal advice. No warranties.


As you said, this is a hunch. My hunch is that we didn't do nothing wrong by implementing a piece of code that runs and communicates with someone else's software. Normally, companies will issue a C&D before taking legal action to court. Upon compliance with such C&D, the C&D'd party is left alone. I will not take any action until we have a direct request from the interested party (Sega).

Blzut's patch can be merged as it is harmless and it makes it easy for anyone to redistribute the code without any of the plugins which is a good feature in overall and not just in regard to the potential legal issues it may or may not help to solve.

User avatar (0019913)
WubTheCaptain (developer)
2018-10-05 06:54

Okay, I finally had some time to read Zalewa's note. Fair point, though I personally still disagree.

Blzut3's patch is reasonable, although out of scope for this ticket's summary – merging that patch does not mark this ticket as "fixed", since the SRB2 plugin would've not been actually removed from distribution. I'll create another ticket and assign it to Blzut3.

(I expect this ticket to be closed in about a week from this resolution.)

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: Zalewa

- Issue History
Date Modified Username Field Change
2018-09-22 23:07 WubTheCaptain New Issue
2018-09-22 23:07 WubTheCaptain Relationship added child of 0003237
2018-09-22 23:08 WubTheCaptain Relationship added related to 0002540
2018-09-22 23:13 WubTheCaptain Note Added: 0019672
2018-09-22 23:18 Blzut3 Note Added: 0019673
2018-09-22 23:35 WubTheCaptain Status new => acknowledged
2018-09-22 23:46 WubTheCaptain Status acknowledged => feedback
2018-09-22 23:51 WubTheCaptain Priority normal => high
2018-09-23 07:33 Zalewa Note Added: 0019684
2018-09-24 00:20 Blzut3 File Added: optional-plugins.diff
2018-09-24 00:21 Blzut3 Note Added: 0019697
2018-09-24 15:47 Zalewa Note Added: 0019702
2018-09-29 10:31 Zalewa Note Added: 0019814
2018-09-29 10:31 Zalewa Note Edited: 0019814 View Revisions
2018-09-29 10:33 Zalewa Note Edited: 0019814 View Revisions
2018-09-29 13:16 WubTheCaptain Status feedback => new
2018-10-05 06:54 WubTheCaptain Note Added: 0019913
2018-10-05 06:54 WubTheCaptain Status new => resolved
2018-10-05 06:54 WubTheCaptain Resolution open => no change required
2018-10-05 06:54 WubTheCaptain Assigned To => WubTheCaptain
2018-10-05 06:55 WubTheCaptain Assigned To WubTheCaptain =>
2018-10-05 07:03 WubTheCaptain Relationship added related to 0003532
2018-10-13 19:01 WubTheCaptain Status resolved => closed
2018-10-13 19:01 WubTheCaptain Assigned To => WubTheCaptain






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker