Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003503Doomseeker[All Projects] Bugpublic2018-09-21 14:102018-10-06 09:24
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.2 
Target Version1.2Fixed in Version1.2 
Summary0003503: Qt4's assumption of Latin-1 encoding decodes UTF-8 characters in Doomseeker built with Qt4 incorrectly (about dialog)
DescriptionOne obvious place for incorrect decoding is Doomseeker's "About Doomseeker" dialog, accessible from Help → About navigation. For example: The copyright symbol, ©, shows up as Å© as in the attached screenshot, in Doomseeker built with Qt4.
Steps To ReproduceTo build Doomseeker with Qt4, use:

cmake -DFORCE_QT4=YES $DOOMSEEKER_SRC
make -j$(nproc)


where $DOOMSEEKER_SRC is the location of source code.
Additional InformationNot reproducible in Qt5, because Qt5 expects UTF-8 and UTF-8 only. The above issue with "About dialog" is not reproducible in Doomseeker 1.1.

https://wiki.qt.io/index.php?title=Strings_and_encodings_in_Qt&oldid=23630 [^]
Attached Filespng file icon 2018-09-21-134347_1280x745_scrot-75%.png [^] (218,822 bytes) 2018-09-21 14:10

- Relationships
related to 0003534closedZalewa Qt4's assumption of Latin-1 encoding decodes UTF-8 characters in Doomseeker built with Qt4 incorrectly (language configuration) 

-  Notes
User avatar (0019593)
WubTheCaptain (developer)
2018-09-21 14:10
edited on: 2018-09-21 14:10

This is the likely cause of code not using QString::fromUtf8(), trUtf8():

Quote from src/core/gui/aboutdialog.cpp
QString AboutDialog::copyrightVerboseNotice() const {
    [...]
    // License
    paragraphs << tr("Copyright © %1 The Doomseeker Team").arg(Version::yearSpan());
    
[...]
}


Introduced in commit 8024bf89f4ccd6455ed1d1f8c907e0b668eb7f98.

User avatar (0019594)
AOSP (reporter)
2018-09-21 14:22

To be honest, why does Doomseeker still support Qt4? As far as I can tell Qt4 itself hasn't been supported for three years now, and it hasn't received a major features update for much longer.
User avatar (0019596)
WubTheCaptain (developer)
2018-09-21 14:34
edited on: 2018-09-21 14:36

Quote from AOSP
To be honest, why does Doomseeker still support Qt4?


I was thinking the same while creating this ticket. The only reason I support Qt4 for is issue 0003494 making Qt5 unviable on OpenBSD, until resolved.

Make a new issue for suggestion to remove Qt4 support in Doomseeker, if you'd like. But I guess that might mean Doomseeker 2.0.0 release in semantic versioning, not 1.2. (No big deal.)

I think the commit above is a hack, anyway.

User avatar (0019656)
Blzut3 (administrator)
2018-09-22 21:17

Qt4 is technically no longer supported (per 1.1 release announcement), but nothing has been a big enough effort to warrant actually going out of the way to remove it.

As of right now the main thing we'd get from dropping Qt4 out right would be better ability to use C++11/14. Last I checked (1.1 release) Zalewa wasn't super interested in bumping compiler requirements due to complexities with how we distribute Doomseeker and modern Visual Studio's universal CRT.

So until the time comes that it's worth removing it we might as well take the additional niche platform support that Qt4 provides.
User avatar (0019657)
Zalewa (developer)
2018-09-22 21:34

With newer Visual Studio CRTs this is how many DLLs (as opposed to the current 2) we'd need to add to the archive in order to be able to maintain the "unzip & run" installation model that we've been using so far. I'd rather reasses the performance of executables generated by modern versions of MinGW and be inclined to return to that compiler if there is no major performance drop. We'd also probably get back support for Windows 98 and just as v120_xp toolset only needs 2 CRT DLLs, so does MinGW.

For the time being and at this point in development, I'd rather be stuck with C++03 than go through the hassle of switching the compiler.
User avatar (0019671)
Zalewa (developer)
2018-09-22 23:05

© Qt4 problem should be fixed here:https://bitbucket.org/Doomseeker/doomseeker/commits/071c9899d89474cd5b99d74b5f695bdb725f1a2b [^]
User avatar (0019679)
WubTheCaptain (developer)
2018-09-23 00:23

Zalewa's commit fixes the © Unicode character issue.

Side-note: AOSP, dropping Qt4 support has ticket 0003514 now.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2018-09-21 14:10 WubTheCaptain New Issue
2018-09-21 14:10 WubTheCaptain File Added: 2018-09-21-134347_1280x745_scrot-75%.png
2018-09-21 14:10 WubTheCaptain Note Added: 0019593
2018-09-21 14:10 WubTheCaptain Note Edited: 0019593 View Revisions
2018-09-21 14:14 WubTheCaptain Description Updated View Revisions
2018-09-21 14:14 WubTheCaptain Additional Information Updated View Revisions
2018-09-21 14:22 AOSP Note Added: 0019594
2018-09-21 14:34 WubTheCaptain Note Added: 0019596
2018-09-21 14:35 WubTheCaptain Note Edited: 0019596 View Revisions
2018-09-21 14:36 WubTheCaptain Note Edited: 0019596 View Revisions
2018-09-22 15:53 WubTheCaptain Target Version 1.2 =>
2018-09-22 16:00 Zalewa Assigned To => Zalewa
2018-09-22 16:00 Zalewa Status new => assigned
2018-09-22 21:17 Blzut3 Note Added: 0019656
2018-09-22 21:34 Zalewa Note Added: 0019657
2018-09-22 23:05 Zalewa Note Added: 0019671
2018-09-22 23:05 Zalewa Status assigned => needs testing
2018-09-23 00:15 Blzut3 Target Version => 1.2
2018-09-23 00:23 WubTheCaptain Note Added: 0019679
2018-09-23 00:23 WubTheCaptain Status needs testing => resolved
2018-09-23 00:23 WubTheCaptain Fixed in Version => 1.2
2018-09-23 00:23 WubTheCaptain Resolution open => fixed
2018-09-29 14:17 WubTheCaptain Status resolved => closed
2018-10-06 09:24 WubTheCaptain Relationship added related to 0003534






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker