Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003444Doomseeker[All Projects] Bugpublic2018-07-31 10:252018-10-27 22:54
ReporterPol M 
Assigned ToZalewa 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSArchOS Versionx64
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003444: Since qt5-5.11 it's necessary to declare some #import to be able to compile Doomseeker
Descriptionthe latest version requires some #imports. I'll upload a .patch with the changes I've made.
Steps To ReproduceIn an Archlinux distro, the app Doomseeker fails to compile.
Attached Filespatch file icon doomseeker.qt5.11.patch [^] (1,898 bytes) 2018-07-31 10:25 [Show Content]

- Relationships
has duplicate 0003648closedWubTheCaptain FTBFS: Doomseeker 1.1+0730f71a8c12 on Qt 5.11 

-  Notes
User avatar (0019297)
Pol M (developer)
2018-07-31 10:43

In case you need to test the patch, the AUR package now uses it.
User avatar (0019298)
Zalewa (developer)
2018-08-01 21:53

There's no author info in the patch. How would you like to be credited?

I need

 nickname <email>
User avatar (0019299)
Pol M (developer)
2018-08-01 22:46

Thanks!
if you can use utf-8:
Pol Marcet Sardà <polmarcetsarda@gmail.com>
if not:
Pol Marcet Sarda <polmarcetsarda@gmail.com>
if it also has to be one word:
Pol_M <polmarcetsarda@gmail.com>
User avatar (0019300)
Zalewa (developer)
2018-08-02 20:08
edited on: 2018-08-02 20:10

Pushed:https://bitbucket.org/Doomseeker/doomseeker/commits/e53ca17a4e1443580d7645808c5a4ed07a24c443 [^]

I took the liberty of adjusting the statements to match the patterns used throughout the program. If you're happy, we can consider this as resolved.

I also tried to use the 'à' letter in the username but I gave up after it got converted to 'ŕ' or just plain 'a' depending on if I used GUI or command interface... I even tried to use the msysgit console from git-bash.exe.

User avatar (0019301)
Pol M (developer)
2018-08-03 01:02
edited on: 2018-08-03 15:38

Oh don't worry about that at all :D but thank you for trying. :P (it's just a spelling of the word that changes slightly)
Tomorrow I'll check it, but definitely, it can be closed.
Thank you so much for your time and this amazing program!

EDIT: Can confirm that it works. I will wait until some more changes are made to push an update to the AUR since there are no differences. I don't want to spam updates

User avatar (0019305)
Zalewa (developer)
2018-08-04 13:10

Quote
Can confirm that it works. I will wait until some more changes are made to push an update to the AUR since there are no differences. I don't want to spam updates


Doomseeker's development has stalled for the past 5 months and I'm not sure when will it resume. I recently have less free time that I can spend on computer.
User avatar (0019307)
Pol M (developer)
2018-08-04 13:22

Oh, I'm sorry to hear this.
I'd love to help, but since I started programming in C++ a month ago (Maybe a little more) and I also have tons of stuff to do (I'm writing tons of pages for my institute final project), I probably wouldn't be of a lot of help. is there a list of objectives or something for the release of 1.2? I guess that taking a look wouldn't hurt.
User avatar (0019308)
Zalewa (developer)
2018-08-04 13:33

If you'd like to help then that will be more than welcome. Some basic instructions to start you off would be:

1. If you wish to see a "TODO" list, you can browse unassigned tickets here on this Mantis page. This should be the direct link to the view:https://zandronum.com/tracker/view_all_bug_page.php?filter=60418 [^]

To narrow the filter down to Doomseeker, you need to pick Doomseeker project from the top-right combobox first, if you haven't already, before going to that link.

Pick something that looks easy and try to fix it :)


2. All code that you'd like to contribute to the repository would be best pushed through bitbucket's pull requests rather than through patch files. You will have to fork Doomseeker's repository and learn how to do those pull requests. In the long run it's a better tool for the job, and it'll pay off to learn it as the more popular GitHub uses a very similar system.

In any case, pull requests are pending code that is not yet merged in to the main repository and I will be able to review the code, give you pointers on what to adjust and you'll be able to update your pull request with subsequent commits. Once your code is ready it will be my job to get it merged properly.

Since you have the compilation procedures figured out already, I'd say you're at least half-way through :) .
User avatar (0019309)
Pol M (developer)
2018-08-04 13:37

OK, if I fix something, I'll do as you said. thanks for the quick response! Since I don't have any windows machine that is easily accessible, so in case I make a pull request test it for me please.
User avatar (0019310)
Zalewa (developer)
2018-08-04 13:38

Will do.

Also, I'm changing the status of this ticket to resolved.
User avatar (0019787)
WubTheCaptain (developer)
2018-09-27 03:35

Postscript note: Since no log of the issue was attached, I've reproduced this issue with Qt 5.11 today on GNU/Linux by undoing the patch. The patch in the commit resolves the issue.

The issue was:

[ 48%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/ip2cupdatebox.cpp.o
[ 48%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/irc/ircdock.cpp.o
[ 49%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/irc/ircdocktabcontents.cpp.o
[ 49%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/irc/ircignoresmanager.cpp.o
[ 49%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/irc/ircnetworkselectionbox.cpp.o
[ 49%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/irc/ircsounds.cpp.o
[ 49%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/logdock.cpp.o
[ 50%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/mainwindow.cpp.o
/tmp/doomseeker-hg-copy/src/core/gui/irc/ircdock.cpp: In member function ‘void IRCDock::tabCurrentChanged(int)’:

/tmp/doomseeker-hg-copy/src/core/gui/irc/ircdock.cpp:204:31: error: invalid use of incomplete type ‘class 
QTabBar’
   d->tabWidget->tabBarPublic()->setTabTextColor(index, "");
                               ^~
In file included from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/QTabWidget:1,
                 from /tmp/doomseeker-hg-copy/src/core/gui/widgets/qtabwidgetext.h:26,
                 from /tmp/doomseeker-hg-copy/build/src/core/ui_ircdock.h:18,
                 from /tmp/doomseeker-hg-copy/src/core/gui/irc/ircdock.cpp:24:
/usr/include/x86_64-linux-gnu/qt5/QtWidgets/qtabwidget.h:51:7: note: forward declaration of ‘class 
QTabBar’
 class QTabBar;
       ^~~~~~~
/tmp/doomseeker-hg-copy/src/core/gui/irc/ircdock.cpp: In member function ‘void IRCDock::titleChangeWithColorOfSenderIfNotFocused()’:

/tmp/doomseeker-hg-copy/src/core/gui/irc/ircdock.cpp:240:31: error: invalid use of incomplete type ‘class 
QTabBar’
   d->tabWidget->tabBarPublic()->setTabTextColor(tabIndex, caller->titleColor());
                               ^~
In file included from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/QTabWidget:1,
                 from /tmp/doomseeker-hg-copy/src/core/gui/widgets/qtabwidgetext.h:26,
                 from /tmp/doomseeker-hg-copy/build/src/core/ui_ircdock.h:18,
                 from /tmp/doomseeker-hg-copy/src/core/gui/irc/ircdock.cpp:24:
/usr/include/x86_64-linux-gnu/qt5/QtWidgets/qtabwidget.h:51:7: note: forward declaration of ‘class 
QTabBar’
 class QTabBar;
       ^~~~~~~
[ 50%] Building CXX object src/core/CMakeFiles/doomseeker.dir/gui/missingwadsdialog.cpp.o
/tmp/doomseeker-hg-copy/src/core/gui/logdock.cpp: In constructor ‘LogDock::LogDock(QWidget*)’:
/tmp/doomseeker-hg-copy/src/core/gui/logdock.cpp:40:26: error: invalid use of incomplete type ‘class 
QAction’
  this->toggleViewAction()->setIcon(QIcon(":/icons/log.png"));
                          ^~
In file included from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/qdockwidget.h:44,
                 from /usr/include/x86_64-linux-gnu/qt5/QtWidgets/QDockWidget:1,
                 from /tmp/doomseeker-hg-copy/src/core/gui/logdock.h:28,
                 from /tmp/doomseeker-hg-copy/src/core/gui/logdock.cpp:25:
/usr/include/x86_64-linux-gnu/qt5/QtWidgets/qwidget.h:68:7: note: forward declaration of ‘class QAction’
 
class QAction;
       ^~~~~~~
make[2]: *** [src/core/CMakeFiles/doomseeker.dir/build.make:1304: src/core/CMakeFiles/doomseeker.dir/gui/irc/ircdock.cpp.o] 
Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [src/core/CMakeFiles/doomseeker.dir/build.make:1369: src/core/CMakeFiles/doomseeker.dir/gui/logdock.cpp.o] 
Error 1
make[1]: *** [CMakeFiles/Makefile2:184: src/core/CMakeFiles/doomseeker.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-07-31 10:25 Pol M New Issue
2018-07-31 10:25 Pol M File Added: doomseeker.qt5.11.patch
2018-07-31 10:43 Pol M Note Added: 0019297
2018-08-01 21:53 Zalewa Note Added: 0019298
2018-08-01 21:53 Zalewa Assigned To => Zalewa
2018-08-01 21:53 Zalewa Status new => feedback
2018-08-01 22:46 Pol M Note Added: 0019299
2018-08-01 22:46 Pol M Status feedback => assigned
2018-08-02 20:08 Zalewa Note Added: 0019300
2018-08-02 20:08 Zalewa Status assigned => needs review
2018-08-02 20:10 Zalewa Note Edited: 0019300 View Revisions
2018-08-03 01:02 Pol M Note Added: 0019301
2018-08-03 15:38 Pol M Note Edited: 0019301 View Revisions
2018-08-04 13:10 Zalewa Note Added: 0019305
2018-08-04 13:22 Pol M Note Added: 0019307
2018-08-04 13:33 Zalewa Note Added: 0019308
2018-08-04 13:37 Pol M Note Added: 0019309
2018-08-04 13:38 Zalewa Note Added: 0019310
2018-08-04 13:38 Zalewa Status needs review => resolved
2018-08-04 13:38 Zalewa Fixed in Version => 1.2
2018-08-04 13:38 Zalewa Resolution open => fixed
2018-09-27 03:21 WubTheCaptain Product Version => 1.1
2018-09-27 03:21 WubTheCaptain Target Version => 1.2
2018-09-27 03:35 WubTheCaptain Note Added: 0019787
2018-09-29 15:05 WubTheCaptain Severity minor => block
2018-10-27 22:54 WubTheCaptain Status resolved => closed
2019-05-03 16:39 WubTheCaptain Relationship added has duplicate 0003648






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker