Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003393Doomseeker[All Projects] Suggestionpublic2018-03-03 18:382018-10-06 10:26
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionduplicate 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.2 
Target Version1.2Fixed in Version 
Summary0003393: RCon client: Hide remote console password by default
DescriptionDoomseeker 1.2 introduced a "Hide" checkbox to the an RCon client. This is not checked by default.

I propose the default to be changed to "checked", to hide the password by default.
Steps To Reproduce
  1. Start Doomseeker from command line with the rcon option: doomseeker --rcon
  2. Notice how the "Hide" checkbox is unchecked.
Additional InformationQt 5.9.2
Attached Files

- Relationships
duplicate of 0000114resolvedBlzut3 When logging into a server using the RCON utility, the password is not hidden when you type. 

-  Notes
User avatar (0019109)
WubTheCaptain (developer)
2018-03-03 18:39

The checkbox option does not persist between starts, so maybe that's the core issue here anyway.
User avatar (0019110)
Zalewa (developer)
2018-03-03 18:42

The option can be changed permanently by running the main program and going to the Appearance settings box. Check there "Hide password" and it will also change the default in --rcon.
User avatar (0019111)
WubTheCaptain (developer)
2018-03-03 19:09
edited on: 2018-03-03 19:13

I did not know that. Thank you, Zalewa.

It also looks like the "Hide passwords" checkbox there is disabled by default for first time starts, and was disabled in my current user configuration. (Note: I had to delete both $HOME/.doomseeker and $HOME/.config/doomseeker for this.) Should this be changed to "checked" by default? (Affects 0003394)

Also a bit off-topic for this ticket: Should toggling the checkbox in the RCon client be persistent and change the config, too? Currently, it is temporary and doesn't change the configuration. If the answer is "yes", please create a new ticket.

User avatar (0019406)
Zalewa (developer)
2018-08-26 10:17

Quote
Should this be "checked" by default?

No.

Quote
Should toggling the checkbox in the RCon client be persistent and change the config, too?

Let's be consistent with Create Game box. So: no.
User avatar (0019820)
WubTheCaptain (developer)
2018-09-29 14:58

Surprisingly, duplicate. (Re-closing in a while.)

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-03-03 18:38 WubTheCaptain New Issue
2018-03-03 18:39 WubTheCaptain Note Added: 0019109
2018-03-03 18:42 Zalewa Note Added: 0019110
2018-03-03 19:09 WubTheCaptain Note Added: 0019111
2018-03-03 19:09 WubTheCaptain Status new => feedback
2018-03-03 19:10 WubTheCaptain Note Edited: 0019111 View Revisions
2018-03-03 19:13 WubTheCaptain Note Edited: 0019111 View Revisions
2018-08-26 10:17 Zalewa Note Added: 0019406
2018-08-26 10:20 Zalewa Status feedback => resolved
2018-08-26 10:20 Zalewa Fixed in Version => 1.2
2018-08-26 10:20 Zalewa Resolution open => fixed
2018-08-26 10:20 Zalewa Assigned To => Zalewa
2018-08-27 01:07 WubTheCaptain Resolution fixed => no change required
2018-09-27 03:26 WubTheCaptain Status resolved => closed
2018-09-27 03:26 WubTheCaptain Fixed in Version 1.2 =>
2018-09-27 03:45 WubTheCaptain Target Version => 1.2
2018-09-29 14:58 WubTheCaptain Note Added: 0019820
2018-09-29 14:58 WubTheCaptain Status closed => resolved
2018-09-29 14:58 WubTheCaptain Resolution no change required => duplicate
2018-09-29 14:58 WubTheCaptain Relationship added duplicate of 0000114
2018-10-06 10:26 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker