Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003385Doomseeker[All Projects] Bugpublic2018-02-26 08:052018-02-26 08:56
ReporterWubTheCaptain 
Assigned ToBlzut3 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusresolvedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.1Fixed in Version1.2 
Summary0003385: FTBFS with Doomseeker 1.1 source tarball: template with C linkage
DescriptionDoomseeker 1.1 fails to build from source to a compiler error.
Steps To ReproduceDownload and extracthttp://doomseeker.drdteam.org/files/doomseeker-1.1_src.tar.bz2 [^] then follow COMPILE.txt instructions.
Additional Information
  • cmake 3.10.2
  • Qt5 5.9.2
  • GNU Make 4.2.1
  • g++ (Debian 7.3.0-5) 7.3.0
  • libc6 2.26 (GNU C Library)


Doomseeker 1.2-beta is unaffected. This issue is recent, as I've been able to build 1.1 from source tarball previously.
Attached Filestxt file icon cmake-stdout.txt [^] (1,836 bytes) 2018-02-26 08:05 [Show Content]
txt file icon cmake-stderr.txt [^] (9,033 bytes) 2018-02-26 08:05 [Show Content]
txt file icon make-j8-stdout.txt [^] (11,663 bytes) 2018-02-26 08:06 [Show Content]
txt file icon make-j8-stderr.txt [^] (1,711,269 bytes) 2018-02-26 08:06

- Relationships

-  Notes
User avatar (0019093)
Blzut3 (administrator)
2018-02-26 08:23

This is fixed by 0730f71a8c12. Doomseeker 1.1 requires glibc less than 2.26 for building.
User avatar (0019094)
WubTheCaptain (developer)
2018-02-26 08:32
edited on: 2018-02-26 08:32

How should this ticket be closed/resolved, then? Resolved as-is, or will there be a patch release for 1.1?

User avatar (0019095)
Blzut3 (administrator)
2018-02-26 08:52

I would rather just focus on getting 1.2 out which includes massive improvements in the build process on top of this particular fix. While there are a few other tickets that should be resolved before doing so the big thing that I want to find time to do for 1.2 is 0003294 since as it stands currently the Mac version is very poorly packaged.

Since Qt is ABI stable this just makes Doomseeker 1.1 difficult to build on the latest distros, but doesn't prevent it from being run. Given the feature additions in 1.2 are relatively minor I'd suggest the few users affected by this simply grab the latest Mercurial in the mean time.
User avatar (0019096)
WubTheCaptain (developer)
2018-02-26 08:56

Okay, thank you. I'll tag the target version to 1.1 anyway, for ticket searchability (should anyone need to patch this for 1.1 themselves).

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-02-26 08:05 WubTheCaptain New Issue
2018-02-26 08:05 WubTheCaptain File Added: cmake-stdout.txt
2018-02-26 08:05 WubTheCaptain File Added: cmake-stderr.txt
2018-02-26 08:06 WubTheCaptain File Added: make-j8-stdout.txt
2018-02-26 08:06 WubTheCaptain File Added: make-j8-stderr.txt
2018-02-26 08:23 Blzut3 Note Added: 0019093
2018-02-26 08:30 WubTheCaptain Additional Information Updated View Revisions
2018-02-26 08:32 WubTheCaptain Note Added: 0019094
2018-02-26 08:32 WubTheCaptain Status new => confirmed
2018-02-26 08:32 WubTheCaptain Note Edited: 0019094 View Revisions
2018-02-26 08:34 WubTheCaptain Fixed in Version => 1.2
2018-02-26 08:37 WubTheCaptain Assigned To => Blzut3
2018-02-26 08:52 Blzut3 Note Added: 0019095
2018-02-26 08:52 Blzut3 Status confirmed => resolved
2018-02-26 08:52 Blzut3 Resolution open => fixed
2018-02-26 08:56 WubTheCaptain Note Added: 0019096
2018-02-26 08:56 WubTheCaptain Target Version => 1.1






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker