Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003244Doomseeker[All Projects] Bugpublic2017-09-01 16:252018-10-27 22:55
ReporterWubTheCaptain 
Assigned ToBlzut3 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003244: /usr/bin is configured as default IWAD and PWAD path
DescriptionA default configuration (or lack of) in Doomseeker adds /usr/bin by default to file paths to scan for IWAD and PWAD files.

The /usr/bin directory is reserved in the Filesystem Hierarchy Standard for user "executable commands on the system". WAD files do not meet this criteria, they belong under the /usr/share directory as architecture-independent data files.
Steps To Reproduce

  1. Ensure no existing user-specific configuration is present (e.g. remove $HOME/.doomseeker).

  2. Run Doomseeker. A message should popup about first-time configuration check.

  3. Check the File Paths tab in configuration.
Additional Informationhttp://www.pathname.com/fhs/pub/fhs-2.3.html#USRBINMOSTUSERCOMMANDS [^]
Attached Files

- Relationships
related to 0001417closedBlzut3 Have Doomseeker find files in the binary directory first 
child of 0003246confirmedWubTheCaptain Debian packaging. 

-  Notes
User avatar (0018213)
WubTheCaptain (developer)
2017-09-01 16:29

On a related matter, /usr/share/games/doom/ is not included in the default list. (0003245)
User avatar (0018233)
Blzut3 (administrator)
2017-09-06 02:33

Default list is the directory that the binary is located in and the configuration directory. The former is primarily for Windows where that may be a sane location, but this issue is honestly an oversight on my part since I always tested in my build directory which would be a relatively sane directory for such files.
User avatar (0018810)
Blzut3 (administrator)
2017-11-06 04:12

Directories named bin and MacOS are no longer added by default.

Note: I didn't guard the change in OS ifdefs since the odds of someone actually installing Doomseeker into directories with those names are so tiny that it's not worth making the code ugly over. Especially since the user can just go and manually add the directory if they're so inclined to.
User avatar (0019709)
WubTheCaptain (developer)
2018-09-24 18:58

https://bitbucket.org/Doomseeker/doomseeker/commits/d0b7adc6d1dc3b50f2883ae8a5bb10ebbad5cb2d [^]
https://bitbucket.org/Doomseeker/doomseeker/commits/334d6a04aa1897b084b12bf64658220106bb816a [^]

As far as I'm concerned, this ticket is resolved for GNU/Linux and OpenBSD (Unices) in my testing... to the limitation I did not "install" it as a package on those operating systems, but I have a belief it works as intended.

The changes in code are so simple to understand, I'm inclined to say this is resolved without doing any testing on Windows or OS X.

Only one thing surprised me:

if(progBinDirName != "bin" && progBinDirName != "MacOS")


is not written with a logical OR operator, since a directory name ought to not be both at the same time:

if(progBinDirName != "bin" || progBinDirName != "MacOS")


But a logical AND works...
User avatar (0019710)
WubTheCaptain (developer)
2018-09-24 19:01

Logical OR/AND: Heh, I get it now. :)

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-09-01 16:25 WubTheCaptain New Issue
2017-09-01 16:29 WubTheCaptain Note Added: 0018213
2017-09-01 16:31 Zalewa Relationship added child of 0003246
2017-09-06 02:31 Blzut3 Assigned To => Blzut3
2017-09-06 02:31 Blzut3 Status new => assigned
2017-09-06 02:31 Blzut3 Target Version => 1.2
2017-09-06 02:33 Blzut3 Note Added: 0018233
2017-09-28 00:21 WubTheCaptain Relationship added related to 0001417
2017-11-06 04:12 Blzut3 Note Added: 0018810
2017-11-06 04:12 Blzut3 Status assigned => needs testing
2017-11-06 04:12 Blzut3 Fixed in Version => 1.2
2018-09-24 18:58 WubTheCaptain Note Added: 0019709
2018-09-24 18:58 WubTheCaptain Status needs testing => resolved
2018-09-24 18:58 WubTheCaptain Resolution open => fixed
2018-09-24 19:01 WubTheCaptain Note Added: 0019710
2018-10-27 22:55 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker