Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003184Zandronum[All Projects] Bugpublic2017-07-12 07:182017-07-13 18:57
Reportereagle 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutioninvalid 
PlatformWindowsOSWindows Server 2012 R2OS Version
Product Version3.0-beta 
Target VersionFixed in Version 
Summary0003184: ClassifyActor - not work in online
Descriptionthis script has to delete any actor except the player, but often it turns out differently.

script "Hem_RemoveThingImmediatelly" (void)
{
    if(ClassifyActor(0) & ACTOR_PLAYER)
    {
        delay(1);
        terminate;
    }
    int target = ActivatorTID();
    if ((target == 0) && (!(ClassifyActor(target) & ACTOR_PLAYER)))
    {
        target = UniqueTID();
        Thing_ChangeTID(0,target);
    }
    if ((!(ClassifyActor(target) & ACTOR_PLAYER)) && (ClassifyActor(target) != ACTOR_NONE))
    {
        Thing_Remove(target);
        terminate;
    }
    terminate;
}
Attached Files? file icon ClassifyActorTest.wad [^] (11,805 bytes) 2017-07-12 09:46

- Relationships

-  Notes
User avatar (0018007)
Dusk (developer)
2017-07-12 08:09
edited on: 2017-07-12 08:10

Your code is just plain wrong. Use something like this instead:

script "Hem_RemoveThingImmediatelly" (void)
{
    if (PlayerNumber() == -1)
        Thing_Remove(0);
}


User avatar (0018008)
eagle (reporter)
2017-07-12 08:29

Alas, your code will also delete everything, including the player's actor.
User avatar (0018009)
eagle (reporter)
2017-07-12 09:06

and with it how to be? Nevertheless ClassifyActor(0) works not correctly in online.

script "Hem_RemoveItemDelayed" (void)
{
    if((ClassifyActor(0) & ACTOR_PLAYER) || (ClassifyActor(0) & ACTOR_MONSTER))
    {
        delay(1);
        terminate;
    }
    int target = ActivatorTID();
    if ((target == 0) && (!(ClassifyActor(target) & ACTOR_PLAYER)))
    {
        target = UniqueTID();
        Thing_ChangeTID(0,target);
    }
    int counter = 0;
    while ((counter < 3150) && (ClassifyActor(target) != ACTOR_NONE) && (!(ClassifyActor(target) & ACTOR_MONSTER)))//delay 15 min
    {
        delay(10);
        counter++;
    }
    if ((!(ClassifyActor(target) & ACTOR_PLAYER)) && (ClassifyActor(target) != ACTOR_NONE) && (!(ClassifyActor(target) & ACTOR_MONSTER)))
    {
        StopSound(target,CHAN_WEAPON);
        StopSound(target,CHAN_VOICE);
        StopSound(target,CHAN_ITEM);
        StopSound(target,CHAN_BODY);
        StopSound(target,5);
        StopSound(target,6);
        StopSound(target,7);
        Thing_Remove(target);
        terminate;
    }
    terminate;
}
User avatar (0018010)
TheMisterCat (reporter)
2017-07-12 09:40

https://www.dropbox.com/s/8rb7lh1oah6g9g8/ClassifyActorTest.wad?dl=0 [^]

The problem is not classifyactor, it works fine multiplayer, as this demonstration wad shows. Your script is just wrong. Don't make bug reports without confirming the bugs please.
User avatar (0018011)
Dusk (developer)
2017-07-12 09:43

And my script won't delete the player because PlayerNumber() returns -1 if it's not a player.
User avatar (0018012)
eagle (reporter)
2017-07-12 09:47

What isn't correct? Everything is made according to descriptions from zdoom.org
Despite all checks the script begins to carry out removal of the actor with TID of the actor of the player.
It is tested within many hours of a game in online.
User avatar (0018013)
Konda (reporter)
2017-07-12 09:50

eagle, please try Dusk's version of the script. If it still doesn't work (after you've actually tried to run the mod with Dusk's script), explain from where, when, and how you are calling this script.
User avatar (0018014)
TheMisterCat (reporter)
2017-07-12 09:53

Do NOT reopen this report. The problem is NOT classifyactor, it works as intended.
User avatar (0018015)
eagle (reporter)
2017-07-12 10:04
edited on: 2017-07-12 10:05

Inscribed the offered Dusk in scripts, but it isn't enough as it seems to me as loss by the player of a body and other unclear actuatings sometimes nevertheless happen. In several hours I will be able to check it in online on the real server.

User avatar (0018016)
Ru5tK1ng (updater)
2017-07-12 15:18

I don't particularly care if it works or not because the tracker isn't for help and support.

Please use the forums: http://zandronum.com/forum/viewforum.php?f=39 [^]

There are plenty of people who can help you with your ACS.
User avatar (0018017)
eagle (reporter)
2017-07-12 17:23

Я проверил предложенное Dusk на сервере в реаьной игре, не работает это, не определяет игрока.

I checked the offered Dusk on the server in a reany game, it does not work, does not define the player.
User avatar (0018018)
jdagenet (reporter)
2017-07-12 17:53

Not sure why this was reopened, ClassifyActor does what it's intended to do. The issue here is what he's trying to do with it that isn't working, which like Rust said, belongs on the forums -- not here.
User avatar (0018019)
Korshun (reporter)
2017-07-13 13:59

>Я проверил предложенное Dusk на сервере в реаьной игре, не работает это, не определяет игрока.

Translation: I tested the solution that Dusk suggested on a server in a real game, it doesn't work, doesn't determine the player.
User avatar (0018020)
Korshun (reporter)
2017-07-13 14:17
edited on: 2017-07-13 14:19

Автор, иди спроси на форуме или у друзей, как написать нормальный работающий скрипт. Я тестил ClassifyActor в мультиплеере и он нормально работает. Твои скрипты переусложнены и местами бред.

Translation:
Author, go ask your friends or on the forums how to make a working script. I tested ClassifyActor in multiplayer and it works fine. Your scripts are overcomplicated and sometimes nonsense.

User avatar (0018021)
Dusk (developer)
2017-07-13 14:47
edited on: 2017-07-13 18:57

Okay this has gone on for long enough. There is clearly no bug here but the provided script is just broken.

As has been said before already, please use the forums for editing issues. This is not a bug and therefore does not belong to the tracker.

Do NOT open this ticket again or I will consider deleting it. If you find an actual bug with ClassifyActor (as unlikely as that is), please post a new ticket.


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Konda
Opponents: AOSP TheMisterCat Korshun

- Issue History
Date Modified Username Field Change
2017-07-12 07:18 eagle New Issue
2017-07-12 08:09 Dusk Note Added: 0018007
2017-07-12 08:09 Dusk Status new => closed
2017-07-12 08:09 Dusk Resolution open => invalid
2017-07-12 08:10 Dusk Note Edited: 0018007 View Revisions
2017-07-12 08:29 eagle Note Added: 0018008
2017-07-12 08:29 eagle Status closed => feedback
2017-07-12 08:29 eagle Resolution invalid => reopened
2017-07-12 09:06 eagle Note Added: 0018009
2017-07-12 09:06 eagle Status feedback => new
2017-07-12 09:40 TheMisterCat Note Added: 0018010
2017-07-12 09:43 Dusk Note Added: 0018011
2017-07-12 09:45 Dusk Status new => closed
2017-07-12 09:45 Dusk Resolution reopened => invalid
2017-07-12 09:46 Dusk File Added: ClassifyActorTest.wad
2017-07-12 09:47 eagle Note Added: 0018012
2017-07-12 09:47 eagle Status closed => feedback
2017-07-12 09:47 eagle Resolution invalid => reopened
2017-07-12 09:50 Konda Note Added: 0018013
2017-07-12 09:53 TheMisterCat Note Added: 0018014
2017-07-12 10:04 eagle Note Added: 0018015
2017-07-12 10:04 eagle Status feedback => new
2017-07-12 10:05 eagle Note Edited: 0018015 View Revisions
2017-07-12 15:18 Ru5tK1ng Note Added: 0018016
2017-07-12 15:18 Ru5tK1ng Status new => closed
2017-07-12 16:08 Dusk Resolution reopened => invalid
2017-07-12 17:23 eagle Note Added: 0018017
2017-07-12 17:23 eagle Status closed => feedback
2017-07-12 17:23 eagle Resolution invalid => reopened
2017-07-12 17:53 jdagenet Note Added: 0018018
2017-07-13 13:59 Korshun Note Added: 0018019
2017-07-13 14:17 Korshun Note Added: 0018020
2017-07-13 14:19 Korshun Note Edited: 0018020 View Revisions
2017-07-13 14:47 Dusk Note Added: 0018021
2017-07-13 14:47 Dusk Status feedback => closed
2017-07-13 14:47 Dusk Resolution reopened => invalid
2017-07-13 18:57 Dusk Note Edited: 0018021 View Revisions






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker