Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003049Zandronum[All Projects] Bugpublic2017-04-08 00:102018-09-30 22:33
ReporterKorshun 
Assigned ToTorr Samaho 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version 
Summary0003049: TeamGame removes all monsters
DescriptionIn Zandronum 3.0, TeamGame mode removes all actors with +ISMONSTER flag set, even if sv_nomonsters is false. That didn't happen in 2.1.2.
Steps To Reproduce1) Create a game with TeamGame gamemode and sv_nomonsters set to false.
2) Observe that there are no monsters.
Additional InformationA workaround is to add -ISMONSTER to monsters.
Attached Files? file icon NoMonstersInTeamGame.wad [^] (2,696 bytes) 2017-04-08 13:50

- Relationships

-  Notes
User avatar (0017089)
Korshun (reporter)
2017-04-08 00:13
edited on: 2017-04-08 00:14

Adding -ISMONSTER breaks a few rarely used features (see https://zdoom.org/wiki/Monster [^]) but is otherwise playable.

User avatar (0017092)
Edward-san (developer)
2017-04-08 10:12

Can you check which beta broke this?
User avatar (0017100)
Torr Samaho (administrator)
2017-04-08 13:12

Please also supply a minimal example wad.
User avatar (0017105)
Korshun (reporter)
2017-04-08 13:52
edited on: 2017-04-08 13:57

The example wad contains a room with some team spawns, monsters and a coop spawn.

The bug forces sv_nomonsters to true on map change in teamgame regardless of its current value.

This bug is present since the first Zandronum 3.0 build (Zandronum 3.0-alpha-150819-2351), but is not present in 2.1.2.

User avatar (0017106)
Torr Samaho (administrator)
2017-04-08 14:42

I had a look and this doesn't seem to be a bug of 3.0, but of 2.1.2. The latter was not properly setting the default dmflags in teamgame modes. If you want monsters in teamgame modes, you have to turn off the default flags with "sv_defaultdmflags 0". Does this work for you?
User avatar (0017108)
Korshun (reporter)
2017-04-08 15:28

It works! Thanks!

And sorry for not knowing about sv_defaultdmflags.
User avatar (0017110)
Torr Samaho (administrator)
2017-04-08 16:45

Thanks for confirming! And don't worry, sv_defaultdmflags is not really well documented, so it's not your fault for not knowing about this.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: N30N Korshun
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-04-08 00:10 Korshun New Issue
2017-04-08 00:13 Korshun Note Added: 0017089
2017-04-08 00:13 Korshun Note Edited: 0017089 View Revisions
2017-04-08 00:14 Korshun Note Edited: 0017089 View Revisions
2017-04-08 10:12 Edward-san Note Added: 0017092
2017-04-08 10:12 Edward-san Status new => feedback
2017-04-08 13:12 Torr Samaho Note Added: 0017100
2017-04-08 13:13 Torr Samaho Target Version => 3.0
2017-04-08 13:50 Korshun File Added: NoMonstersInTeamGame.wad
2017-04-08 13:52 Korshun Note Added: 0017105
2017-04-08 13:52 Korshun Status feedback => new
2017-04-08 13:57 Korshun Note Edited: 0017105 View Revisions
2017-04-08 14:42 Torr Samaho Note Added: 0017106
2017-04-08 14:42 Torr Samaho Assigned To => Torr Samaho
2017-04-08 14:42 Torr Samaho Status new => feedback
2017-04-08 15:28 Korshun Note Added: 0017108
2017-04-08 15:28 Korshun Status feedback => assigned
2017-04-08 16:45 Torr Samaho Note Added: 0017110
2017-04-08 16:46 Torr Samaho Status assigned => resolved
2017-04-08 16:46 Torr Samaho Resolution open => no change required
2018-09-30 22:33 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker