Zandronum Chat @
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002812Zandronum[All Projects] Bugpublic2016-08-19 19:092017-04-14 17:43
Assigned To 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version 
Summary0002812: Crash on start up with rewritten .ini on computers with more secure servers
DescriptionEvery Zandronum build made after 8/31/15 crashes on my school computers every time it makes/edits a user configuration file. I personally think it has something to do with not being able to write to program files or it's because I can't run on admin mode. It crashes on startup, giving an access violation error report. The only way to keep it from happening is deleting my school user config, and replacing it with mine from home. The problem is, I can only use the Zandronum builds once after this, or it will crash again, and the process has to be repeated. I also hold the whole Zandronum installation on a flash drive, but the 8.31.15 build doesn't have this issue.
Additional InformationUhhh... First steo is probably being on a more secured system, my PC from home doesn't have this problem.

Step two, run Zandronum with your person CFG from home

Step Three, go back and load Zandronun again, you will crash

Attached Filesrtf file icon log.rtf [^] (43,439 bytes) 2016-12-10 01:03
txt file icon local.txt [^] (219 bytes) 2016-12-10 01:03 [Show Content]
txt file icon report.txt [^] (24,284 bytes) 2016-12-10 01:03 [Show Content]
txt file icon minidump.txt [^] (264,541 bytes) 2016-12-10 01:04
zip file icon [^] (22,288 bytes) 2016-12-20 19:18

- Relationships

-  Notes
User avatar (0015497)
AOSP (updater)
2016-08-19 19:16

Are you running it from Program Files? Try putting it in your user directory if you are.
User avatar (0015498)
Dusk (developer)
2016-08-19 19:17
edited on: 2016-08-19 19:17

Why are you playing Zandronum at school anyway? Shouldn't you be in class?

Also, this is not a crash but a graceful error.

User avatar (0015499)
S_Andrew_S (reporter)
2016-08-19 19:17
edited on: 2016-08-19 19:17

I don't have access to program files on the school computers. I keep everything I need inside a folder in my flash drive.

P.S. I do game club and take Game Design class, we have tournaments

User avatar (0016258)
Edward-san (developer)
2016-11-21 16:56

I think the crash must be fixed, but of course it wasn't configured correctly.

Every Zandronum build made after 8/31/15

Does it mean it doesn't happen in 150819 and happens in 150831 or that it starts appearing in 151004?
User avatar (0016307)
S_Andrew_S (reporter)
2016-11-23 20:52

It starts in 151004.
User avatar (0016308)
Edward-san (developer)
2016-11-24 00:03

Somebody has to make some builds between 150831 and 151004 and find the culprit change.
User avatar (0016355)
Torr Samaho (administrator)
2016-11-27 16:22

Quote from S_Andrew_S
It starts in 151004.

Just to double check: If you now go back to 150831, it still works?

Quote from S_Andrew_S
access violation error report

do you mean Zandronum's "Very Fatal Error" window? If so, can you save and post the crash log? If not, can you post a screenshot of the error?
User avatar (0016410)
S_Andrew_S (reporter)
2016-12-03 17:13

Yes, 150831 works. I will get the crash report when I can.
User avatar (0016453)
S_Andrew_S (reporter)
2016-12-10 01:04

I just put the text from the crash report files in text documents, as I cannot access where the crash reports save to.
User avatar (0016454)
Edward-san (developer)
2016-12-10 07:52

When updating the crash report the zip file must be updated, not its content.
User avatar (0016455)
Torr Samaho (administrator)
2016-12-10 08:47

Quote from S_Andrew_S
I just put the text from the crash report files in text documents

To debug this we need the file minidump.mdmp that is contained in the zip file.
Quote from S_Andrew_S
as I cannot access where the crash reports save to.

Zandronum should ask you where you want the crash log to be saved. Just select a directory you have access to.
User avatar (0016461)
S_Andrew_S (reporter)
2016-12-10 15:30

I gave you the minidump, I was just too lazy to change the extension.
User avatar (0016462)
Torr Samaho (administrator)
2016-12-10 16:11

No, the minidump.txt you attached it not a minidump.mdmp with the wrong extension. Your minidump.txt seems to be like the text output of a hex editor that opens a proper minidump.mdmp. I need the original unaltered binary version of minidump.mdmp as it is stored in the zip file. VC++ can only analyze this file format.
User avatar (0016464)
Edward-san (developer)
2016-12-10 18:31

Just to be clear: is the name of the file you should attach here.
User avatar (0016496)
S_Andrew_S (reporter)
2016-12-16 00:18

Well, I don't really know how to save the crash report to a different location. If there is a dialogue box where it says to save the report, that doesn't work.
User avatar (0016502)
WaTaKiD (updater)
2016-12-16 07:46
edited on: 2016-12-16 07:46

check out crashlog_dir on [^]

User avatar (0016537)
S_Andrew_S (reporter)
2016-12-20 19:22

Two things:
1) I found out that this is never an issue when running in software.
2) I don't know if the crash report save dialogue came up because either I was playing with mods, or because I actually got into the menu before crashing. Long story, I tried running Zandronum to get a crash report after setting those cvars, the cvars did nothing. So, I kinda just gave up, but then I tried running Zandronum with mods again after remaking my ".ini". Once I got in Zandronum it got to the menu where I can see the Doom 2 title pic but then it crashed, only this time, I actually could choose where to save the crash report from the dialogue.
User avatar (0017130)
S_Andrew_S (reporter)
2017-04-14 17:43

I have also found out that the crash can be avoided by playing out of fullscreen too.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-08-19 19:09 S_Andrew_S New Issue
2016-08-19 19:16 AOSP Note Added: 0015497
2016-08-19 19:17 Dusk Note Added: 0015498
2016-08-19 19:17 S_Andrew_S Note Added: 0015499
2016-08-19 19:17 Dusk Severity crash => minor
2016-08-19 19:17 Dusk Note Edited: 0015498 View Revisions
2016-08-19 19:17 S_Andrew_S Note Edited: 0015499 View Revisions
2016-11-21 16:56 Edward-san Note Added: 0016258
2016-11-23 20:52 S_Andrew_S Note Added: 0016307
2016-11-24 00:03 Edward-san Note Added: 0016308
2016-11-24 00:03 Edward-san Status new => feedback
2016-11-27 16:22 Torr Samaho Note Added: 0016355
2016-12-03 17:13 S_Andrew_S Note Added: 0016410
2016-12-03 17:13 S_Andrew_S Status feedback => new
2016-12-10 01:03 S_Andrew_S File Added: log.rtf
2016-12-10 01:03 S_Andrew_S File Added: local.txt
2016-12-10 01:03 S_Andrew_S File Added: report.txt
2016-12-10 01:04 S_Andrew_S File Added: minidump.txt
2016-12-10 01:04 S_Andrew_S Note Added: 0016453
2016-12-10 07:52 Edward-san Note Added: 0016454
2016-12-10 08:47 Torr Samaho Note Added: 0016455
2016-12-10 15:30 S_Andrew_S Note Added: 0016461
2016-12-10 16:11 Torr Samaho Note Added: 0016462
2016-12-10 18:31 Edward-san Note Added: 0016464
2016-12-10 18:31 Edward-san Status new => feedback
2016-12-16 00:18 S_Andrew_S Note Added: 0016496
2016-12-16 00:18 S_Andrew_S Status feedback => new
2016-12-16 07:46 WaTaKiD Note Added: 0016502
2016-12-16 07:46 WaTaKiD Note Edited: 0016502 View Revisions
2016-12-20 19:18 S_Andrew_S File Added:
2016-12-20 19:22 S_Andrew_S Note Added: 0016537
2016-12-24 22:41 Dusk Target Version => 3.0
2017-04-14 17:43 S_Andrew_S Note Added: 0017130

Questions or other issues? Contact Us.


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker