Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002809Zandronum[All Projects] Bugpublic2016-08-18 12:462017-11-09 20:55
ReporterD3X1K AXYZ 
Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
StatusresolvedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target VersionFixed in Version3.0 
Summary0002809: Zandronum will not end process if not responding
Description3.0 alpha Build 160229-1221
when it stops responding, it will not close out even when i use the task manager.
details
display: fullscreen with opengl
mods: does not matter
graphics: low quality

Additional InformationIf you need more info please let me know what you require.
If this is something that has already been addressed, then please forgive me.
Attached Files

- Relationships

-  Notes
User avatar (0015482)
Dusk (developer)
2016-08-18 13:30

And... what is it that you're doing that causes it to stop responding in the first place...?
User avatar (0015501)
D3X1K AXYZ (reporter)
2016-08-19 21:44

It doesn't matter. Any process that would lag the game for a few seconds (normally occurring in the higher levels of the DooM games). I don't mind the lag, crashes, or not responding (esp when I use mods, as I know these can cause problems) , but having to log off just to get the process to end is a problem.

Hope this helps :D.
if not, please let me know
User avatar (0015502)
Visual Vincent (reporter)
2016-08-19 21:57
edited on: 2016-08-19 22:00

Finding the cause to why the process crashes can be very hard. I've experienced this too, and it started happening to me around version 2.1 or 2.1.2.

The thing is, I hardly think this is fixable. Something in one of the updates causes a behaviour at crash that makes the process temporarily unable to terminate. Locating the exact cause will, as previously mentioned, be hard.

I experience this now and then, and the thing is that you don't have to log off (at least I never have had to). End the process via the task manager, wait, and it should terminate at most within a few minutes.


EDIT:
By the way my game usually crashes like this at startup, so I'm unsure if it's the exact same problem.

User avatar (0016360)
Torr Samaho (administrator)
2016-11-27 16:50

D3X1K AXYZ, did 2.1.2 behave differently?
User avatar (0017096)
Torr Samaho (administrator)
2017-04-08 12:22

Since there was no feedback for more than four months and I can't reproduce the problem, I'm closing this. Feel free to reopen this ticket by providing feedback.
User avatar (0017111)
D3X1K AXYZ (reporter)
2017-04-08 17:10

UPDATE: Zandronum 3.0-alpha-170205-2117 has fixed the issue.
I wish I could just update the issue details instead of reopening this whole issue just to say it has been fixed in the new version and can be closed. I had forgotten about this thread otherwise this could have been closed much sooner.
Sorry for the inconvenience.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-08-18 12:46 D3X1K AXYZ New Issue
2016-08-18 13:30 Dusk Note Added: 0015482
2016-08-18 13:30 Dusk Priority high => normal
2016-08-18 13:30 Dusk Severity crash => minor
2016-08-18 13:54 Dusk Status new => feedback
2016-08-19 21:44 D3X1K AXYZ Note Added: 0015501
2016-08-19 21:44 D3X1K AXYZ Status feedback => new
2016-08-19 21:57 Visual Vincent Note Added: 0015502
2016-08-19 22:00 Visual Vincent Note Edited: 0015502 View Revisions
2016-11-27 16:50 Torr Samaho Note Added: 0016360
2016-11-27 16:50 Torr Samaho Status new => feedback
2016-12-24 22:41 Dusk Target Version => 3.0
2017-04-08 12:22 Torr Samaho Note Added: 0017096
2017-04-08 12:22 Torr Samaho Status feedback => closed
2017-04-08 12:22 Torr Samaho Resolution open => unable to reproduce
2017-04-08 12:22 Torr Samaho Target Version 3.0 =>
2017-04-08 17:10 D3X1K AXYZ Note Added: 0017111
2017-04-08 17:10 D3X1K AXYZ Status closed => feedback
2017-04-08 17:10 D3X1K AXYZ Resolution unable to reproduce => reopened
2017-11-09 20:55 Dusk Status feedback => resolved
2017-11-09 20:55 Dusk Resolution reopened => fixed
2017-11-09 20:55 Dusk Fixed in Version => 3.0






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker