Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002768Zandronum[All Projects] Bugpublic2016-07-02 08:482017-07-30 22:11
ReporterWarlon 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionunable to reproduce 
PlatformLinuxOSUbuntu 64bitOS Version14.04
Product Version3.0-beta 
Target Version3.0Fixed in Version 
Summary0002768: Crash with project brutality and valiant.wad
DescriptionZandronum crashes every time with project brutality 2.0 loaded on valiant.wad map 14 - implosion.
Steps To ReproducePlay valiant.wad with project brutality 2.0. At one point in the level the game always crahes as player triggers a monster closet.
Additional InformationPlaying with Zandronum 3.0-alpha-160519-2047
Attached Fileslog file icon zandronum-crash-07_02_2016-11_42_17.31165.log [^] (19,680 bytes) 2016-07-02 08:48
png file icon Screenshot_Doom_20160702_193058_01.png [^] (506,171 bytes) 2016-07-02 16:34
? file icon save5.zds [^] (403,288 bytes) 2016-07-02 16:34

- Relationships

-  Notes
User avatar (0015156)
Torr Samaho (administrator)
2016-07-02 09:20

Does this only happen under Linux?
User avatar (0015162)
Dusk (developer)
2016-07-02 11:10
edited on: 2016-07-02 11:35

I can't seem to reproduce this, at least under a debug build. Trying a release build now. Would be nice to know exactly where the crash happens.

EDIT: Yeah I cannot reproduce this at all.

User avatar (0015184)
Warlon (reporter)
2016-07-02 16:41

I did some more testing and it might be some incompatability with project brutality and valiant.wad. I've attached savegame from that point (if it helps) and a screenshot that is taken just before the game crashes. I noticed that in my savegame there seems to be an imp variant that wasn't there when I started the level again. Then the game didn't crash. Also playing valiant.wad only without project brutality it doesn't crash.
User avatar (0016253)
Edward-san (developer)
2016-11-21 15:33
edited on: 2016-11-22 00:53

Can you reproduce with latest zandronum beta? If yes, can you upload a new savegame of the moment before the crash?

[edit] In my case, when I try to load Valiant and Project Brutality in debug mode, I get an assertion in the decorate expressions parser (and happens also in gzdoom 1.8.6 compiled in debug mode).

[edit2] The strangest thing is that backportinghttps://bitbucket.org/Torr_Samaho/zandronum-zdoom-sync/commits/079bd034faba9526f9956915607177b5114cb6d5 [^] andhttps://bitbucket.org/Torr_Samaho/zandronum-zdoom-sync/commits/881bb9e7dc3962961cc012a8bfde98c5240c15b4 [^] ( committed in sandbox ashttps://bitbucket.org/zandronum/zandronum-sandbox/commits/536acfe314e9b0e29c184f813d7abd372e10b9b3 [^] ) placated the assertion. I think a new build with this changeset would be interesting to see. OP can build it by himself and test it.

User avatar (0016280)
WaTaKiD (updater)
2016-11-22 01:08

this 3.0 build contains the above commit: https://www.dropbox.com/s/4obatx1eycfs497/zandronum-3.0-r161122-0050-536acfe-windows.zip?dl=0 [^]
User avatar (0016821)
Decay (reporter)
2017-02-07 23:45

I'm not sure what exactly the commit changed, but just fyi valiant.wad is not actually compatible with gameplay mods, so crashing with project brutality is unsurprising, and user error.
User avatar (0017293)
Torr Samaho (administrator)
2017-04-23 20:01

Can somebody reproduce this? If so, under which OS?
User avatar (0018128)
Dusk (developer)
2017-07-30 22:01

It's been 3 months and nobody still knows how to reproduce this, so I'm closing this. Please reopen if you have new information.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-07-02 08:48 Warlon New Issue
2016-07-02 08:48 Warlon File Added: zandronum-crash-07_02_2016-11_42_17.31165.log
2016-07-02 09:20 Torr Samaho Note Added: 0015156
2016-07-02 09:20 Torr Samaho Status new => feedback
2016-07-02 11:10 Dusk Note Added: 0015162
2016-07-02 11:35 Dusk Note Edited: 0015162 View Revisions
2016-07-02 16:34 Warlon File Added: Screenshot_Doom_20160702_193058_01.png
2016-07-02 16:34 Warlon File Added: save5.zds
2016-07-02 16:41 Warlon Note Added: 0015184
2016-07-02 16:41 Warlon Status feedback => new
2016-11-21 15:33 Edward-san Note Added: 0016253
2016-11-21 20:25 Edward-san Note Edited: 0016253 View Revisions
2016-11-22 00:51 Edward-san Note Edited: 0016253 View Revisions
2016-11-22 00:53 Edward-san Note Edited: 0016253 View Revisions
2016-11-22 00:53 Edward-san Status new => feedback
2016-11-22 01:08 WaTaKiD Note Added: 0016280
2016-12-24 22:42 Dusk Target Version => 3.0
2017-02-07 23:45 Decay Note Added: 0016821
2017-04-23 20:01 Torr Samaho Note Added: 0017293
2017-07-30 22:01 Dusk Note Added: 0018128
2017-07-30 22:01 Dusk Status feedback => resolved
2017-07-30 22:01 Dusk Resolution open => unable to reproduce
2017-07-30 22:04 Edward-san Status resolved => closed
2017-07-30 22:11 Dusk Status closed => resolved






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker