Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002716Zandronum[All Projects] Bugpublic2016-04-30 13:312018-09-30 22:03
ReporterEdward-san 
Assigned ToEdward-san 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04 x86-64
Product Version2.1 
Target Version3.0Fixed in Version3.0 
Summary0002716: Invisible or transparent map things become visible or opaque on map restart
DescriptionIf a map in hexen format contains invisible or transparent monsters (as a map thing property), then on map restarts, if the thing state changed, the things would become unexpectly visible or opaque, ruining the intended effect.
Steps To Reproduce- Host a game with doom2 + the attached wad (either invisible_monster.wad or transparent_monster.wad) in survival mode;
- connect a client;
- let the client join the game, wake the monster and wait for the survival countdown reach zero.
Additional InformationI noticed this problem when playing Tartarus online (map TAT21, which has almost all monsters invisible).
Attached Files? file icon invisible_monster.wad [^] (608 bytes) 2016-04-30 13:31
? file icon transparent_monster.wad [^] (608 bytes) 2016-04-30 14:40

- Relationships

-  Notes
User avatar (0014773)
Edward-san (developer)
2016-04-30 14:40

I managed to reproduce the problem not only for invisible monsters, but also for transparent monsters. Changed the ticket details.
User avatar (0014774)
Edward-san (developer)
2016-04-30 15:33

https://bitbucket.org/Torr_Samaho/zandronum-stable/pull-requests/32/fixed-invisible-and-transparent-map-things/diff [^]
User avatar (0014838)
Edward-san (developer)
2016-05-08 20:48

Added with this changeset:https://bitbucket.org/Torr_Samaho/zandronum/commits/0f285a72f6e671366e14fb0ea1629885b5989d56 [^] (in 2.x branch) and it's available in 3.0 through this changeset:https://bitbucket.org/Torr_Samaho/zandronum/commits/9709fe9ea5551293a94cb7eef603a77b113bdbbc [^] .
User avatar (0014865)
Ru5tK1ng (updater)
2016-05-11 19:43

Tested the test wads online with r160510-1827.

After the countdown reset, the monsters remained invisible/transparent as intended.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-04-30 13:31 Edward-san New Issue
2016-04-30 13:31 Edward-san File Added: invisible_monster.wad
2016-04-30 14:40 Edward-san Note Added: 0014773
2016-04-30 14:40 Edward-san Assigned To => Edward-san
2016-04-30 14:40 Edward-san Status new => assigned
2016-04-30 14:40 Edward-san Summary Invisible monsters become visible on map restart => Invisible or transparent map things become visible or opaque on map restart
2016-04-30 14:40 Edward-san Description Updated View Revisions
2016-04-30 14:40 Edward-san Steps to Reproduce Updated View Revisions
2016-04-30 14:40 Edward-san File Added: transparent_monster.wad
2016-04-30 15:33 Edward-san Note Added: 0014774
2016-04-30 15:33 Edward-san Status assigned => needs review
2016-05-08 20:48 Edward-san Note Added: 0014838
2016-05-08 20:48 Edward-san Status needs review => needs testing
2016-05-11 19:43 Ru5tK1ng Note Added: 0014865
2016-05-11 19:43 Ru5tK1ng Status needs testing => resolved
2016-05-11 19:43 Ru5tK1ng Resolution open => fixed
2016-05-11 19:43 Ru5tK1ng Fixed in Version => 3.0
2016-05-11 19:43 Ru5tK1ng Target Version => 3.0
2018-09-30 22:03 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker