Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002692Zandronum[All Projects] Bugpublic2016-03-30 21:112018-09-30 22:05
ReporterTiger 
Assigned ToTorr Samaho 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformDesktop (x86_64)OSWindowsOS Version6.3
Product Version 
Target Version3.0Fixed in Version3.0 
Summary0002692: Bot Node Overflow (?)
DescriptionThis issue has been in existence since SkullTag 97D, though probably safe to assume - since forever.

The demonstration PWAD that I have provided shows a crash or hang that occurs when adding just one bot into the map. When the crash or hang occurs, there's no useful information presented to the user -- only course of action is to terminate the PID.

I am unsure if this is even remotely fixable as it seems to be the design of the bots SkullTag uses, ZDoom's Cajun bots [http://zdoom.org/wiki/Bots [^] ] do not have any issues with the demonstration map.
Steps To ReproduceUsing the demonstration PWAD:
Go to MAP01 and set the gamemode to 'Deathmatch'. Once the map reloads to MAP01, add a random bot into the game.
Zandronum should hang within the first second.
Attached Files7z file icon BotCrash.7z [^] (1,483,648 bytes) 2016-03-30 21:11

- Relationships

-  Notes
User avatar (0014650)
Torr Samaho (administrator)
2016-04-03 11:33

Should be fixed now. It was caused by the size of the map, but not because the map is too big in general, but because the code made a wrong assumption that lead to an infinite loop.
User avatar (0014652)
cobalt (updater)
2016-04-03 11:46

Issue addressed by commit 9fe16790e716: Fixed: Bots on a large map may freeze the game (addresses 2692).
Committed by Benjamin Berkels [Torr Samaho] on Wednesday 31 December 1969 23:59:57

Changes in files:

 docs/zandronum-history.txt | 1 +
 src/astar.cpp | 8 ++++----
 2 files changed, 5 insertions(+), 4 deletions(-)

User avatar (0014656)
Tiger (reporter)
2016-04-03 12:21

Great, thanks!
User avatar (0014676)
Tiger (reporter)
2016-04-07 03:25

Using build 3.0-alpha @ 160403-1900 - Commit 96e0e5e40e46, (credit to WaTaKiD), this seems to be fixed for me. I have tested this out on a gameserver environment as well as single player environment, seems to be working just fine now. Thanks for fixing this!

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-03-30 21:11 Tiger New Issue
2016-03-30 21:11 Tiger File Added: BotCrash.7z
2016-04-03 11:33 Torr Samaho Note Added: 0014650
2016-04-03 11:33 Torr Samaho Assigned To => Torr Samaho
2016-04-03 11:33 Torr Samaho Status new => needs testing
2016-04-03 11:46 cobalt Target Version => 3.0
2016-04-03 11:46 cobalt Description Updated View Revisions
2016-04-03 11:46 cobalt Steps to Reproduce Updated View Revisions
2016-04-03 11:46 cobalt Note Added: 0014652
2016-04-03 12:21 Tiger Note Added: 0014656
2016-04-07 03:25 Tiger Note Added: 0014676
2016-04-08 19:12 Dusk Status needs testing => resolved
2016-04-08 19:12 Dusk Fixed in Version => 3.0
2016-04-08 19:12 Dusk Resolution open => fixed
2018-09-30 22:05 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker